Page 1 of 1

Nothing in Kodi works

Posted: Sat Nov 14, 2020 6:37 pm
by mox386
Hello,

I tried installing and using Kodi on Buster on a raspberry pi 4 B recently. This was the 2nd attempt at using kodi as I did try it out some years back and since nothing worked back then I gave up. I think this was circa 2012.

New attempt I tried even more stuff out than before and was very persistent about it.

Youtube; failed because the client required but was not allowed to login
hulu; doesn't exist even though some articles say it does
amazon; failed, no support, and weird way of installing
crackle; failed miserably
retroarch (and various other emulators/programs); failed (only supported on specific OSs apparently)
most music apps straight up don't work either from the repository, their own hosted repository, or install-from-zip
There were a lot more but, and a few weather apps failed as well.

I was only able to get some standalone game with pipes and the yahoo weather to work. NOTHING else works other than local files (vids/music/etc)

I was wondering if others have had the same kind of experience installing/using kodi on Buster. My main suspicion is that I just have missed something or don't understand something extremely basic.

Is it that kodi is only meant for local files mostly? Are only some specific addons I don't know about supported/working? Could it be that I have to use OSMC, Xbian, Openelec, or Libreelec otherwise nothing works (in which case this post is on the wrong forum)?

Thanks for any advice/help/notes in advance

Re: Nothing in Kodi works

Posted: Sat Nov 14, 2020 6:46 pm
by fruitoftheloom
mox386 wrote:
Sat Nov 14, 2020 6:37 pm
Hello,

I tried installing and using Kodi on Buster on a raspberry pi 4 B recently. This was the 2nd attempt at using kodi as I did try it out some years back and since nothing worked back then I gave up. I think this was circa 2012.

New attempt I tried even more stuff out than before and was very persistent about it.

Youtube; failed because the client required but was not allowed to login
hulu; doesn't exist even though some articles say it does
amazon; failed, no support, and weird way of installing
crackle; failed miserably
retroarch (and various other emulators/programs); failed (only supported on specific OSs apparently)
most music apps straight up don't work either from the repository, their own hosted repository, or install-from-zip
There were a lot more but, and a few weather apps failed as well.

I was only able to get some standalone game with pipes and the yahoo weather to work. NOTHING else works other than local files (vids/music/etc)

I was wondering if others have had the same kind of experience installing/using kodi on Buster. My main suspicion is that I just have missed something or don't understand something extremely basic.

Is it that kodi is only meant for local files mostly? Are only some specific addons I don't know about supported/working? Could it be that I have to use OSMC, Xbian, Openelec, or Libreelec otherwise nothing works (in which case this post is on the wrong forum)?

Thanks for any advice/help/notes in advance

Personally I have always used LibreElec and only installed Official add-ons from within Kodi, never tried to install unofficial add-ons due to legalities etcetera..

If there is a requirement for DRM, the Raspberry Pi is not classed as a Secure Platform and therefore services which require DRM *may* not function:

https://libreelec.tv/about/


Many 3rd party add-ons are compiled for x86 CPU Linux and not ARM CPU Linux.

Re: Nothing in Kodi works

Posted: Sat Nov 14, 2020 8:49 pm
by LTolledo
Kodi works for me...

but not with the most common problem culprit called "user misconceptions"

been enjoying Kodi over Raspbian/RPiOS for the last 3 years or so...

Re: Nothing in Kodi works

Posted: Sat Nov 14, 2020 9:31 pm
by geffers
I've used Kodi on a couple of Pi devices mainly as a DLNA client to play my own stored content. Both are the KODI image and not a Pi operating system with Kodi subsequently installed.

What I do use it for successfully is as a TVHeadend client to a TV tuner working on my network, that streams TV content over the network nicely.

Other addons I've had working, then suddenly don't - NASA a good example and that is an official one.

Youtube takes an eternity to open. Having said that both Kodi Pi devices are on an original Pi 1 with only two USB ports.

Geoff