aaa801
Posts: 428
Joined: Mon Jun 04, 2012 9:06 pm
Location: Berkshire

Re: Accelerated X driver testing

Sat Feb 16, 2013 2:27 pm

when i add framebuffer_depth=32
framebuffer_ignore_alpha=1
(the other options dont cause this)
i get the following on boot

[ 1.266977] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[ 1.274688] io scheduler noop registered
[ 1.278731] io scheduler deadline registered (default)
[ 1.283925] io scheduler cfq registered
[ 1.353159] Console: switching to colour frame buffer device 240x67
[ 1.403641] kgdb: Registered I/O driver kgdboc.
[ 1.409121] vc-cma: Videocore CMA driver
[ 1.413235] vc-cma: vc_cma_base = 0x0a000000
[ 1.418185] vc-cma: vc_cma_size = 0x04c00000 (76 MiB)
[ 1.423893] vc-cma: vc_cma_initial = 0x00000000 (0 MiB)
[ 1.439311] brd: module loaded
[ 1.448026] loop: module loaded
[ 1.451728] vchiq: vchiq_init_state: slot_zero = 0xca000000, is_master = 0
[ 1.459811] vchiq_get_state: g_state.remote->initialised != 1 (0)

portets
Posts: 186
Joined: Sat Oct 29, 2011 6:24 am

Re: Accelerated X driver testing

Sat Mar 16, 2013 3:18 am

I got it working under LXDE, but can't under GDM3. I was hoping to maybe get gnome shell working, or at least accelerated Gnome Classic. Should it be possible?

portets
Posts: 186
Joined: Sat Oct 29, 2011 6:24 am

Re: Accelerated X driver testing

Sun Mar 17, 2013 1:02 am

Okay, got it working under gnome 3 classic with metacity compositing.

Gnome shell exits with an EGL and DRI2 error.

User avatar
diereinegier
Posts: 166
Joined: Sun Dec 30, 2012 5:45 pm
Location: Bonn, Germany
Contact: Website

Re: Accelerated X driver testing

Sun Mar 17, 2013 8:18 am

It seems that this thread and the work on the driver was abandoned by Simon.
Maybe you could try to report the bugs via the mechanism that Simon described in the article linked in his original post.
But I am afraid that it is not worth the effort since his answers in this thread suggest that he never even considered to fix the bugs reported here.
Download my repositories at https://github.com/GeorgBisseling

JollyRoger
Posts: 154
Joined: Wed Feb 01, 2012 9:48 am

Re: Accelerated X driver testing

Mon Mar 18, 2013 10:55 am

So what does the future hold? Is work on this being abandoned, at least for now?

portets
Posts: 186
Joined: Sat Oct 29, 2011 6:24 am

Re: Accelerated X driver testing

Mon Mar 18, 2013 11:27 am

Well his last post was 2 months ago, and it says he was last logged in 1 month ago.

I think it's too early to tell if he's not continuing this.

yaggi
Posts: 23
Joined: Wed Dec 12, 2012 3:47 pm

Re: Accelerated X driver testing

Sat Mar 23, 2013 8:02 am

I don't mean any offense but I think you may be jumping the gun when you say
"It seems that this thread and the work on the driver was abandoned by Simon."
Yes it has been two months since Simon has last responded in this thread and maybe he did abandon the project, or maybe he is taking a well deserved break. Two months is not really that long a time at all. :D

@Simon I don't mean to speak for you at all, I am just attempting to put myself in your position when I say the following. He also has a full time job, a girlfriend who maybe was getting sick of him donating all his free time to develop X11 drivers for free, he has a family and IRL friends. Not even getting into something that the Raspberry Pi foundation too knows happens with these kind of projects, it's extremely draining work. Donating all your free time and heart on a project and then after releasing it swamped with bug fixes and why didn't this get done (even though it's a beta). Yes, that's what programmers do, but, it doesn't mean its not tiring. I can't blame him if he wanted to take a couple of months off.

Semi Related: Even if Simon was to drop off the face of the Earth, I was under the impression that Liz stated that the Raspberry Pi Foundation was developing there own X11 drivers and it would be fixed very soon (From October 2012)

http://www.raspberrypi.org/phpBB3/viewt ... 00#p194400

@Liz, that statement wasn't meant as a 'Why the h*ll aren't these finished yet' at all. I was just curious as the the current state of the RPi foundations very own X11 drivers that you guys and girls were working on. Isn't it possible to join forces with Simon or at least utilize some of his work? Obviously I am not aware of the whole situation but something like that seems logical to me. Seems a shame for it to go to waste or for both parties to waste their resources working on the same thing.

Sorry for the long post!!

shuckle
Posts: 565
Joined: Sun Aug 26, 2012 11:49 am
Location: Finland

Re: Accelerated X driver testing

Sat Mar 23, 2013 10:28 am

I agree, it really would be nice to get the status of this.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24117
Joined: Sat Jul 30, 2011 7:41 pm

Re: Accelerated X driver testing

Sat Mar 23, 2013 4:05 pm

As I understand it, X (and esp. the browsers using it) are proving to be almost impossible to accelerate because they are so bad! In effect they are doing lots of one (or very few) pixel operations throughout the rendering process, which are, sadly, impossible to accelerate because the overhead of packaging them up and sending for acceleration is worse than just drawing the pixel.

So there are limits to what can be achieved without moving to something else completely. Simon's code accelerates as much as possible (and decides which rendering operations are more effectively done locally), and is probably close to as good as possible at the moment. Not sure of the bug list though.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

ssvb
Posts: 112
Joined: Sat May 19, 2012 6:15 pm

Re: Accelerated X driver testing

Thu Jun 06, 2013 4:10 pm

Hi Simon,

Looks like there is still some interest in getting at least some performance improvements for Raspberry Pi Xorg drivers: http://www.raspberrypi.org/phpBB3/viewt ... p?p=361307

Trying to play safe and provide a robust drop-in replacement for the traditional fbdev driver, the most interesting and relatively easy thing to accelerate is dragging/scrolling windows. Hence your DMA kernel module could be probably taken into use (with or without some modifications). And your experience is surely valuable.

Today I tried to test your driver to get some basic x11perf benchmark numbers, and it turned out to be a bit challenging. For the start, building from sources is not so easy and does not work out of the box. There is even a bug reported for this by other people: https://github.com/simonjhall/fbdev_exa/issues/1
The pre-built binaries can be extracted over raspbian rootfs, but I still failed to get any reasonable results. For me they either use CPU copy (as can be seen from profiling with 'perf'), or segfault when tweaking the config file and trying some weird settings.

If anybody has a properly installed Simon's driver, could you please share "x11perf -scroll500" results? Thanks!

eel
Posts: 1
Joined: Thu Apr 25, 2013 10:31 am

Re: Accelerated X driver testing

Tue Jun 25, 2013 12:51 pm

Tried building it myself on Pidora, but as the Makefile.am files are missing in the source directory that doesn't work.
Would be great to have the full source somewhere, or some hints to make it work.

For Pidora the prebuilt files aren't going to work, as there is no libudev.so.0 anymore in Fedora 18.

h.b.
Posts: 5
Joined: Mon Dec 16, 2013 2:33 pm

Re: Accelerated X driver testing

Mon Dec 16, 2013 2:35 pm

I'm getting the same error :(

h.b.
Posts: 5
Joined: Mon Dec 16, 2013 2:33 pm

Re: Accelerated X driver testing

Mon Dec 16, 2013 5:33 pm

That's what I expected as well...But therefore we need linux kernel headers installed... but that sounds easier than it really is :roll:
After installation of headers, the 'build' folder will be created which is needed by dma


You can find the header files here:
http://www.niksula.hut.fi/~mhiienka/Rpi ... aders-rpi/

h.b.
Posts: 5
Joined: Mon Dec 16, 2013 2:33 pm

Re: Accelerated X driver testing

Wed Dec 18, 2013 5:57 pm

yeah finally I got it compiled and installed now... but now I'm getting an error, that dmaer module is incompatible... :cry:


any other ideas?

h.b.
Posts: 5
Joined: Mon Dec 16, 2013 2:33 pm

Re: Accelerated X driver testing

Fri Dec 20, 2013 2:37 pm

I already know that site ..but it does not really help for me...

as I played around a little bit, I found out that with a fresh install of raspbian the "modprobe dmaer_master" command works.

after running "apt-get upgrade" it does not work anymore...it seems, that it has to do something with an update of a package or
something... :|

h.b.
Posts: 5
Joined: Mon Dec 16, 2013 2:33 pm

Re: Accelerated X driver testing

Sun Dec 22, 2013 1:32 pm

Yes that works... But you can not upgrade after installation.. Than it won't work anymore.

darkladen
Posts: 22
Joined: Mon Oct 01, 2012 7:54 pm

Re: Accelerated X driver testing

Thu Jan 23, 2014 2:43 am

Hi guys, i have a problem installing linux-header. I try to install the versions "3.10.27+" and "3.10.25+" and always i have the same error.

Here is my error:

Code: Select all

Setting up linux-headers-3.10.27+ (3.10.27+-2) ...
--2014-01-22 18:28:08--  https://github.com/raspberrypi/firmware/raw/master/extra/Module.symvers
Resolving github.com (github.com)... 192.30.252.129
Connecting to github.com (github.com)|192.30.252.129|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.github.com/raspberrypi/firmware/master/extra/Module.symvers [following]
--2014-01-22 18:28:16--  https://raw.github.com/raspberrypi/firmware/master/extra/Module.symvers
Resolving raw.github.com (raw.github.com)... 199.27.77.133
Connecting to raw.github.com (raw.github.com)|199.27.77.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 493077 (482K) [text/plain]
Saving to: `/usr/src/linux-headers-3.10.27+/Module.symvers'

100%[===================================================================================================================================================================================================>] 493,077      175K/s   in 2.8s

Last-modified header missing -- time-stamps turned off.
2014-01-22 18:28:26 (175 KB/s) - `/usr/src/linux-headers-3.10.27+/Module.symvers' saved [493077/493077]

make: Entering directory `/usr/src/linux-headers-3.10.27+'
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/conf
scripts/kconfig/conf --silentoldconfig Kconfig
#
# configuration written to .config
#
make: Leaving directory `/usr/src/linux-headers-3.10.27+'
make: Entering directory `/usr/src/linux-headers-3.10.27+'
  WRAP    arch/arm/include/generated/asm/auxvec.h
  WRAP    arch/arm/include/generated/asm/bitsperlong.h
  WRAP    arch/arm/include/generated/asm/cputime.h
  WRAP    arch/arm/include/generated/asm/current.h
  WRAP    arch/arm/include/generated/asm/emergency-restart.h
  WRAP    arch/arm/include/generated/asm/errno.h
  WRAP    arch/arm/include/generated/asm/exec.h
  WRAP    arch/arm/include/generated/asm/ioctl.h
  WRAP    arch/arm/include/generated/asm/ipcbuf.h
  WRAP    arch/arm/include/generated/asm/irq_regs.h
  WRAP    arch/arm/include/generated/asm/kdebug.h
  WRAP    arch/arm/include/generated/asm/local.h
  WRAP    arch/arm/include/generated/asm/local64.h
  WRAP    arch/arm/include/generated/asm/msgbuf.h
  WRAP    arch/arm/include/generated/asm/param.h
  WRAP    arch/arm/include/generated/asm/parport.h
  WRAP    arch/arm/include/generated/asm/poll.h
  WRAP    arch/arm/include/generated/asm/resource.h
  WRAP    arch/arm/include/generated/asm/sections.h
  WRAP    arch/arm/include/generated/asm/segment.h
  WRAP    arch/arm/include/generated/asm/sembuf.h
  WRAP    arch/arm/include/generated/asm/serial.h
  WRAP    arch/arm/include/generated/asm/shmbuf.h
  WRAP    arch/arm/include/generated/asm/siginfo.h
  WRAP    arch/arm/include/generated/asm/sizes.h
  WRAP    arch/arm/include/generated/asm/socket.h
  WRAP    arch/arm/include/generated/asm/sockios.h
  WRAP    arch/arm/include/generated/asm/termbits.h
  WRAP    arch/arm/include/generated/asm/termios.h
  WRAP    arch/arm/include/generated/asm/timex.h
  WRAP    arch/arm/include/generated/asm/trace_clock.h
  WRAP    arch/arm/include/generated/asm/types.h
  WRAP    arch/arm/include/generated/asm/unaligned.h
  CHK     include/generated/uapi/linux/version.h
  UPD     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  UPD     include/generated/utsrelease.h
  Generating include/generated/mach-types.h
  CC      kernel/bounds.s
  GEN     include/generated/bounds.h
  CC      arch/arm/kernel/asm-offsets.s
  GEN     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
grep: scripts/../arch/x86/syscalls/syscall_32.tbl: No such file or directory
  HOSTCC  scripts/genksyms/genksyms.o
  SHIPPED scripts/genksyms/lex.lex.c
  SHIPPED scripts/genksyms/keywords.hash.c
  SHIPPED scripts/genksyms/parse.tab.h
  HOSTCC  scripts/genksyms/lex.lex.o
  SHIPPED scripts/genksyms/parse.tab.c
  HOSTCC  scripts/genksyms/parse.tab.o
  HOSTLD  scripts/genksyms/genksyms
  CC      scripts/mod/empty.o
  HOSTCC  scripts/mod/mk_elfconfig
  MKELF   scripts/mod/elfconfig.h
  CC      scripts/mod/devicetable-offsets.s
  GEN     scripts/mod/devicetable-offsets.h
  HOSTCC  scripts/mod/file2alias.o
  HOSTCC  scripts/mod/modpost.o
  HOSTCC  scripts/mod/sumversion.o
  HOSTLD  scripts/mod/modpost
  HOSTCC  scripts/kallsyms
  HOSTCC  scripts/pnmtologo
  HOSTCC  scripts/conmakehash
  HOSTCC  scripts/bin2c
  HOSTCC  scripts/sortextable
scripts/sortextable.c:31:32: fatal error: tools/be_byteshift.h: No such file or directory
compilation terminated.
make[1]: *** [scripts/sortextable] Error 1
make: *** [scripts] Error 2
make: Leaving directory `/usr/src/linux-headers-3.10.27+'
I hope someone can help me.
Thanks

Return to “General discussion”