ffelagund
Posts: 30
Joined: Wed Nov 21, 2012 7:53 pm

Re: The User Interface Failed To Load

Tue Jan 22, 2013 9:39 am

If needed, I can create a dd image of my SD card and put on a server for download. Perhaps that helps.

RexRoper
Posts: 67
Joined: Wed Oct 31, 2012 4:45 pm
Location: South Florida
Contact: Website

Re: The User Interface Failed To Load

Tue Jan 22, 2013 3:48 pm

For the record, there are no Proxy Servers in my Internet connection

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Wed Jan 23, 2013 11:05 pm

I'm afraid that even after following Rex's setup steps, I'm unable to reproduce the problem. I'm going to pass the instructions on to a colleague to see if he has any more luck.
ffelagund wrote:If needed, I can create a dd image of my SD card and put on a server for download. Perhaps that helps.
If you wouldn't mind, ffelagund, that'd be really helpful.

Thanks very much,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

User avatar
metaljay
Posts: 51
Joined: Fri Jun 22, 2012 7:26 am

Re: The User Interface Failed To Load

Sun Jan 27, 2013 8:36 am

any update on this?

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Sun Jan 27, 2013 12:30 pm

metaljay wrote:any update on this?
I'm afraid not. Myself and two colleagues have all followed the setup instructions that RexRoper kindly sent over, but we've been unable to reproduce the problem.

If anyone has this issue and would be able to upload their image somewhere, that would be very handy.

Thanks,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

User avatar
metaljay
Posts: 51
Joined: Fri Jun 22, 2012 7:26 am

Re: The User Interface Failed To Load

Mon Jan 28, 2013 7:29 am

i doubt its todo with the image, but rather the encyption on the data. My Pi connects via an Infrastructure mode using WPA2 (from my iphone)

I cant test if this changes as i have no other means of connection.

dimdom
Posts: 4
Joined: Mon Jan 21, 2013 12:16 pm
Location: Kent, England

Re: The User Interface Failed To Load

Mon Jan 28, 2013 4:41 pm

I too have had this problem, and the SD card has been tested in another pi and the pi store works fine. As I have also mentioned I can connect to the internet no problem at all using the current proxy setting in Midora. Does this indicate the issue is with pi-store and the way it connects to the network?

One think I have not tried is to uninstall pi-store and re-install it.

Cheers

Dom

dxvictor
Posts: 1
Joined: Wed Jan 30, 2013 3:51 am

Re: The User Interface Failed To Load

Wed Jan 30, 2013 4:24 am

I have been running my Raspberry PI Model B since receiving this afternoon. I'm having the same problem. I have both wired and wireless working fine. Log contains the following:

***************************************************

***************************************************
Date = Tue Jan 29 21:12:57 2013

Got latest ui version from IndieCity: 2.0.16009.0
Ui is out of date. Old version 0.0.0.0 New Version 2.0.16009.0
Updating client ui
ERROR OnClientInfoRequestFinished ParseFileList : badly formed client info file
Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI

Ayreonaut
Posts: 1
Joined: Fri Dec 28, 2012 1:13 pm

Re: The User Interface Failed To Load

Fri Feb 01, 2013 7:15 pm

Hi guys, new user here.

I'm having a similar problem, but instead of not loading a window for the store, it loads it briefly, comes up with an error message saying

"Granted permissions without asking for password

The '/usr/share/indiecity/pistore/scripts/launchclientupdate.sh' program was started with the privileges of the root user without the need to ask for a password, due to your system's authentication mechanism setup.

It is possible that you are being allowed to run specific programs as user root without the need for a password, or that the password is cached.

This is not a problem report; it's simply a notification to make sure you are aware of this"


It then goes to update the store through a terminal window, which ultimately fails, but I can't see the error message before it closes on its own. I did get this message:

""/usr/share/indiecity/pistore/scripts/updateclient.sh: line 21: kill: (3850) - No such process

before hand though, and I've received this message whilst trying to update or install any other programmes:

"Fetched 56.0 MB in 1min 14s (748 kB/s)
Extracting templates from packages: 100%
Selecting previously unselected package libopencore-amrnb0:armhf.
dpkg: unrecoverable fatal error, aborting:
files list file for package 'xfonts-encodings' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
[email protected] ~ $ "

Sorry for the long post, I'm running what I think is the latest Rasbian(I imaged the SD card just after Christmas) on the 512mb model B Pi. I'm pretty much a n00b, so any help/advice would be greatly appreciated.

Thanks.

neillg65
Posts: 2
Joined: Sat Jan 26, 2013 5:10 pm

Re: The User Interface Failed To Load

Fri Feb 01, 2013 10:07 pm

Hi,

Just got my RPi up and running and am having the same error when trying to start the PiStore App.

User interface error encountered when trying to start from either the GUI or straight from the command line/shell.

Below is the log entry after I try. Seems to be saying I need to update my client, is this the Raspbian distro?
***************************************************
Date = Fri Feb 1 21:34:29 2013

Got latest ui version from IndieCity: 2.0.16009.0
Ui is out of date. Old version 0.0.0.0 New Version 2.0.16009.0
Updating client ui
Client 1.1.0.15366 can not download ui. Ui requires min 1.1.0.15964
Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI


***************************************************

I also get the following error in the shell/command line when I try to start it from there.
"content-type missing in HTTP POST, defaulting to application/octet-stream"

btw, am a total n00b with all this so haven't tried imaging my own card or anything. Using the SD card as bought ready loaded from the Pi Hut. No significant changes or configurations performed.

Hope this helps somewhat.

Neill

neillg65
Posts: 2
Joined: Sat Jan 26, 2013 5:10 pm

Re: The User Interface Failed To Load

Fri Feb 01, 2013 10:22 pm

Update to my previous post.

After a little more investigation I realised that the client in the pistore so updated it with the latest version using the get-apt commands

The error I now get is this.
***************************************************
Date = Fri Feb 1 22:15:12 2013

Got latest ui version from IndieCity: 2.0.16009.0
Ui is out of date. Old version 0.0.0.0 New Version 2.0.16009.0
Updating client ui
ERROR OnCommonFilesRequestFinished ParseFileList : badly formed file list
Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI


***************************************************

Hope this is more helpful...

User avatar
metaljay
Posts: 51
Joined: Fri Jun 22, 2012 7:26 am

Re: The User Interface Failed To Load

Mon Feb 04, 2013 7:41 am

Bump :)

User avatar
DrPiD
Posts: 30
Joined: Wed May 16, 2012 9:44 am
Location: Leamington Spa, UK
Contact: Website

Re: The User Interface Failed To Load

Tue Feb 05, 2013 10:32 am

ffelagund has kindly sent us an image of his card, so we're going to be looking to see if we can find out exactly what's causing the problems.

We'll post more when we have more information :)
Community Manager - IndieCity

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Tue Feb 05, 2013 11:43 am

Just to check, is there anyone having this problem who isn't either using a proxy or some sort of mobile internet dongle?

~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Tue Feb 05, 2013 4:40 pm

We seem to have been able to reproduce the "badly formed filelist" error by putting together a mobile internet setup of our own. We're still investigating the possible causes of this, which could take some time as it's an issue which wasn't previously anticipated.

As for those of you who don't have internet connectivity unless going through a proxy, this is a separate issue and I'm afraid there's nothing to announce on that currently.

I'll let you know when we have more information. :)

Thanks for your patience,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

diplopi
Posts: 4
Joined: Wed Sep 19, 2012 7:25 pm

Re: The User Interface Failed To Load

Sat Feb 09, 2013 4:38 pm

Hey,

I have the same problem with a Rev. 2 (256MB) raspberry pi and Wi-Fi behind a fritz box 7170. No proxy is used.

Tell my what I can test/post so this problem can be looked at?

Thanks in advance. Regards, Robert

User avatar
metaljay
Posts: 51
Joined: Fri Jun 22, 2012 7:26 am

Re: The User Interface Failed To Load

Mon Feb 11, 2013 7:42 am

Any fix identified yet?

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Thu Feb 14, 2013 4:39 pm

I've checked and the latest released build should contain the fix. It transpires that mobile broadband providers will sometimes subtly change the encoding on files and this was enough to throw things off. Having checked with a colleague, the Pi Store should work straight out of the box if you get the newest update.

If this isn't the case, please do let us know. As previously stated, I'm afraid this isn't a fix for those of you who require a proxy in order to have internet access.

~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

johnroe
Posts: 17
Joined: Fri Jan 25, 2013 6:31 pm

Re: The User Interface Failed To Load

Thu Feb 14, 2013 7:29 pm

Whilst still waiting for the answer on this one, i tried running pistore from LXTerminal, I got the usual user interface failed to load, but back on the LXterminal window is the message

content-type missing in HTTP POST, defaulting to application/octet-stream

Don't know if this helps

John

RexRoper
Posts: 67
Joined: Wed Oct 31, 2012 4:45 pm
Location: South Florida
Contact: Website

Re: The User Interface Failed To Load

Fri Feb 15, 2013 8:46 pm

This latest update to the Pi Store Client has resolved the issue I experienced with accessing the Pi Store over mobile broadband Internet connections.

A big High-Five and sincere Thank You to the team that solved this one!
:D

johnroe
Posts: 17
Joined: Fri Jan 25, 2013 6:31 pm

Re: The User Interface Failed To Load

Sat Feb 16, 2013 5:38 pm

I'm glad one problem has been fixed , I am using a wireless internet connection and it still doesn't work for me , even with the latest update.

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Mon Feb 18, 2013 5:40 pm

johnroe wrote:I'm glad one problem has been fixed , I am using a wireless internet connection and it still doesn't work for me , even with the latest update.
Hi johnroe,

Yours is a bit of a strange one unfortunately, as it worked prior to an update, but not afterwards, if I remember correctly?

Would you mind enabling logging as described in this post and either posting the results here or sending them to [email protected] (I mention this address rather than the personal one I've mentioned previously because it's easier to keep track of things - it'll still find its way to me). If you can think of anything irregular about your setup that might be helpful, that'd be great too - the key thing with issues like this is to try to find some sort of correlation between everyone with the problem.

Thanks very much for your time,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

johnroe
Posts: 17
Joined: Fri Jan 25, 2013 6:31 pm

Re: The User Interface Failed To Load

Tue Feb 26, 2013 8:04 pm

For the benefit of others who may have a similar problem, here is a copy of the log file I e-mailed to Richard, for some reason the forum doesnt allow you to attach files of log extension




Id = C8F17D5FF48E87F9364797EC221CC721
Loading ui version from map : 2.0.16129.0
Updating client ui
UI Update completed successfully
ERROR CachedFile Failed to delete GUI_bak folder
***************************************************
Date = Fri Feb 22 20:20:21 2013

Sending 2 Stats. Machine
Failed to rename GUI folder to GUI_bak1
ERROR CachedFile Failed to rename downloaded GUI folder to GUI

Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI


***************************************************

***************************************************
Date = Fri Feb 22 20:20:37 2013

Sending 2 Stats. MachineId = C8F17D5FF48E87F9364797EC221CC721
Loading ui version from map : 2.0.16129.0
Updating client ui
UI Update completed successfully
ERROR CachedFile Failed to delete GUI_bak folder

Failed to rename GUI folder to GUI_bak1
ERROR CachedFile Failed to rename downloaded GUI folder to GUI

Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI


***************************************************

***************************************************
Date = Fri Feb 22 20:20:45 2013

Sending 2 Stats. MachineId = C8F17D5FF48E87F9364797EC221CC721
Loading ui version from map : 2.0.16129.0
Updating client ui
UI Update completed successfully
ERROR CachedFile Failed to delete GUI_bak folder

Failed to rename GUI folder to GUI_bak1
ERROR CachedFile Failed to rename downloaded GUI folder to GUI

Balloon Message: Error - Unable to load GUI
ERROR CachedGui Unable to load GUI


***************************************************


Best Regards


John

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: The User Interface Failed To Load

Wed Feb 27, 2013 10:08 am

Hi johnroe,

Would you mind navigating to /var/lib/indiecity/pistore and running ls -la in a terminal, please? Would you mind either posting or email the output from both that command and the groups command please?

Thanks very much for your time,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

johnroe
Posts: 17
Joined: Fri Jan 25, 2013 6:31 pm

Re: The User Interface Failed To Load

Wed Feb 27, 2013 6:20 pm

Richard as requested see below

Regards
John



[email protected] /var/lib/indiecity/pistore $ ls -la
total 24
drwxr-sr-x 6 root indiecity 4096 Dec 25 22:04 .
drwxrwsr-x 3 root indiecity 4096 Dec 25 22:04 ..
drwxr-sr-x 4 root indiecity 4096 Dec 25 22:04 Cache
drwxr-sr-x 2 root indiecity 4096 Jan 28 10:14 GUI
drwxr-sr-x 2 root indiecity 4096 Dec 25 22:04 GUI_bak
drwxr-sr-x 2 root indiecity 4096 Dec 25 22:04 Installers
[email protected] /var/lib/indiecity/pistore $ groups
pi adm dialout cdrom sudo audio video plugdev games users netdev input indiecity

Return to “General discussion”