SC13NC3F1CT10N
Posts: 16
Joined: Sun Jan 19, 2020 10:53 pm

Cannot Start pcmanfm Using Debian Terminal Environment

Tue Jun 02, 2020 10:25 pm

I really wanted to run x86 on my raspberry pi, so I followed this tutorial.

However, before doing this built and installed a custom kernel for my operating system following these instructions.

I finished step 5 in the x86 tutorial, then tried to install pcmanfm file manager running these commands:

Code: Select all

sudo chroot /home/pi/chroot-stretch-i386/ /bin/su -l root

Code: Select all

apt install pcmanfm

It finally installs after a long time, then I run this in the regular terminal:

Code: Select all

sudo chroot /home/pi/chroot-stretch-i386/ /bin/su -l pi
I run

Code: Select all

pcmanfm

and I get this:

(process:6041): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
** Message: x-terminal-emulator has very limited support, consider choose another terminal

** (pcmanfm:6041): WARNING **: The directory '~/Templates' doesn't exist, ignoring it
Fontconfig warning: ignoring ”C”: not a valid language tag

(pcmanfm:6041): Gdk-WARNING **: shmat failed: error 22 (Invalid argument)
Bus error


I installed xorg but it did not help my situation. Can any of you help with this? My computer is a Raspberry Pi 3b+ running Raspberry Pi OS v3.3 (32 bit) as the official operating system.
If you turn on Javascript, the text will change.

bjtheone
Posts: 731
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: Cannot Start pcmanfm Using Debian Terminal Environment

Wed Jun 03, 2020 1:01 am

It is not clear which model Pi you are trying to do this. Stretch is not going to work on a 4B.

Are you sure you correctly added the required environmental variables to .bashrc and sourced it?

SC13NC3F1CT10N
Posts: 16
Joined: Sun Jan 19, 2020 10:53 pm

Re: Cannot Start pcmanfm Using Debian Terminal Environment

Sun Jun 14, 2020 10:31 am

bjtheone wrote:
Wed Jun 03, 2020 1:01 am
It is not clear which model Pi you are trying to do this. Stretch is not going to work on a 4B.

Are you sure you correctly added the required environmental variables to .bashrc and sourced it?
I fixed the variables, Stretch no longer complains about them. But pcmanfm still does not start, I am using a Pi 3 model B+.


Last bumped by SC13NC3F1CT10N on Sun Jun 14, 2020 10:31 am.
If you turn on Javascript, the text will change.

Return to “General discussion”