gjgilbert
Posts: 2
Joined: Wed Dec 26, 2012 12:09 pm

No sound on 2012-12-16-wheezy-raspian

Wed Dec 26, 2012 12:33 pm

I have my Raspberry Pi working with an old analogue PC monitor and speakers connected to the 3.5mm audio socket. The LXMusic player works fine. However after downloading the the latest distribution (2012-12-16-wheezy-raspian) to make use of 16Gb storage on a new SD card I can't get any sound at all. I don't know what version came on the 4Gb SD card with the Raspberry Pi. Does anyone know how to get analogue sound working on 2012-12-16-wheezy-raspian, or if it is not supported?
Thanks.

KimB
Posts: 38
Joined: Tue Oct 09, 2012 10:38 am
Location: Norfolk, UK

Re: No sound on 2012-12-16-wheezy-raspian

Wed Dec 26, 2012 3:57 pm

Assuming you've already set the sound output to the analogue output and it's not working. You could check the /etc/group file and to see if your username included in the Audio group?

Other things I tried to get sound working are in this thread http://www.raspberrypi.org/phpBB3/viewtopic.php?t=23413

gjgilbert
Posts: 2
Joined: Wed Dec 26, 2012 12:09 pm

Re: No sound on 2012-12-16-wheezy-raspian

Wed Dec 26, 2012 9:20 pm

Yep - Set up the sound the same as the supplied 4Gb distribution which works; 'sudo amixer cset numid-3 1', and I'm running as the 'pi' user who is in the audio group. The only difference I can see is that I'm running the 16Gb card with the later release ...

g3sna
Posts: 20
Joined: Sun Dec 25, 2011 8:04 pm

Re: No sound on 2012-12-16-wheezy-raspian

Mon Jan 07, 2013 4:07 pm

Can someone please explain what the problem is? I have the same trouble running VLC and getting no analogue audio (My HDMI based monitor does not have any built in speakers). On the previous distribution I had (18-9-12) it worked fine - and still does if I plug that SD card in. All the settings in asound.conf are the same in the latest distribution but VLC has a greyed out Audio Device menu item. All I get are one or two clicks from the speakers. If you know what the problem is please make it known.

Many thanks,

Stuart

Pete6
Posts: 29
Joined: Sat Nov 24, 2012 4:02 pm

Re: No sound on 2012-12-16-wheezy-raspian

Mon Jan 07, 2013 5:54 pm

I'll probably get shouted down for suggesting this but, I too struggled with getting MP3s to play out of the analogue output under startx. My fix was simple.

I uninstalled pulseaudio. I tried a lot of things first but this fixed it every time over several virgin SD Card images.

I typed:

Code: Select all

sudo apt-get --yes purge pulseaudio
and the audio worked and has remained working since.
My favorite programming language is a soldering iron.

g3sna
Posts: 20
Joined: Sun Dec 25, 2011 8:04 pm

Re: No sound on 2012-12-16-wheezy-raspian

Mon Jan 07, 2013 8:46 pm

Thank you. I did a fresh install to the SD card first. Then followed your suggestion. That changes the Card default as seen by "amixer info" to 'ALSA'/'bcm2835 ALSA' which is what I had in the 18-9-2012 version. Did a reboot after installing VLC and all working. 8-) Stuart
Pete6 wrote:I'll probably get shouted down for suggesting this but, I too struggled with getting MP3s to play out of the analogue output under startx. My fix was simple.

I uninstalled pulseaudio. I tried a lot of things first but this fixed it every time over several virgin SD Card images.

I typed:

Code: Select all

sudo apt-get --yes purge pulseaudio
and the audio worked and has remained working since.

gyeben
Posts: 150
Joined: Tue Jun 19, 2012 6:38 pm
Location: Hungary, Eger

Re: No sound on 2012-12-16-wheezy-raspian

Mon Jan 07, 2013 9:23 pm

For some really strange reason, they have included pulseaudio in the release released on 2012-12-16
But it seems like that it's neither configured correctly nor required to make audio work, and that's why it causes sound problems.

PS: At last, I know why I had no sound while playing Simutrans :twisted:

User avatar
winkleink
Forum Moderator
Forum Moderator
Posts: 274
Joined: Mon Nov 07, 2011 9:12 am
Location: UK
Contact: Website

Re: No sound on 2012-12-16-wheezy-raspian

Tue Jan 08, 2013 7:50 am

[quote]sudo apt-get --yes purge pulseaudio[/quotdone, and sound came back in Scratch and Stella. Also, Freedroid now has music and SFX.

I expect PulseAudio is the future. It will just take a while to get there.
Twitter:Winkleink
Google+: Winkleink

Wasp_Box
Posts: 19
Joined: Fri Nov 16, 2012 11:20 am
Location: UK

Re: No sound on 2012-12-16-wheezy-raspian

Tue Jan 08, 2013 12:42 pm

Pete6,

Thank you, I owe you a beer. I have spent hours trying to get audio to function. I've tried everything in the Wiki, read the RPi user guide, searched Google and nothing worked.

Got rid of pulseaudio as you suggested and that did the trick.

Perhaps someone with an account could make a note in the Wiki - it would have saved me hours (although I did learn quite a lot in the process).

Pete6
Posts: 29
Joined: Sat Nov 24, 2012 4:02 pm

Re: No sound on 2012-12-16-wheezy-raspian

Tue Jan 08, 2013 4:12 pm

Wasp_Box wrote:Pete6,

Thank you, I owe you a beer. I have spent hours trying to get audio to function. I've tried everything in the Wiki, read the RPi user guide, searched Google and nothing worked.

Got rid of pulseaudio as you suggested and that did the trick.

Perhaps someone with an account could make a note in the Wiki - it would have saved me hours (although I did learn quite a lot in the process).
Hehe, I am glad it worked. If you are ever in the Reading area, we can certainly have a beer or two.

I too spent a while fighting the audio until I found this solution. Hopefully the PulseAudio package will get fixed in later releases.
My favorite programming language is a soldering iron.

Thicko_1970
Posts: 24
Joined: Thu Jan 03, 2013 12:32 am
Location: Hawick

Re: No sound on 2012-12-16-wheezy-raspian

Wed Jan 09, 2013 12:51 am

I've only had my Pi a couple of days, so I'm just getting to grips with the beginning of it. I've been pulling my hair out, over no audio on my Pi, even from a fresh SD image of the 2012-12-16-wheezy-raspbian.

I'd spent ages fiddling around in terminal trying various changes to config.txt, with no joy.

I just discovered that when I added the volume app to the taskbar, the slider was all the way down, which must be it's default volume setting. I can now hear sound, after sliding it up! So easy once found. :oops:

One issue, is when playing the "Front_Center.wav" test file, I hear "nt center". I seem to remember reading something about wave files fading in, but not sure where I read about it.

lewmur
Posts: 363
Joined: Sun Dec 25, 2011 3:20 pm
Contact: Website

Re: No sound on 2012-12-16-wheezy-raspian

Wed Jan 09, 2013 2:39 pm

Pete6 wrote:I'll probably get shouted down for suggesting this but, I too struggled with getting MP3s to play out of the analogue output under startx. My fix was simple.

I uninstalled pulseaudio. I tried a lot of things first but this fixed it every time over several virgin SD Card images.

I typed:

Code: Select all

sudo apt-get --yes purge pulseaudio
and the audio worked and has remained working since.
Pulse Audio has been a PITA in Linux for years. I gave up even trying to use Skype in Linux years ago because each time I tried a new distro, I had to spend hours getting it to work. Also, I have an old ATI TV card which also gave me headaches with Pulse. The solution there was to install the gnome-alsa-mixer. It gives you a GUI volume control with sliders for a multitude of inputs and outputs that the Pulse Audio "master" volume control ignores.

I don't use the sound on my Pi because I have it setup primarily as a Samba and FTP server. But I'm almost positive that using the alsamixer would solve sound problems on the latest Raspbian release. However, if un-installing Pulse Audio works for you, go for it!! :D

Wasp_Box
Posts: 19
Joined: Fri Nov 16, 2012 11:20 am
Location: UK

Re: No sound on 2012-12-16-wheezy-raspian

Thu Jan 10, 2013 2:34 pm

@ lewmur
Alsamixer is still present on the latest release. It seemed to be using PulseAudio as it's "soundcard" if that makes sense (I'm something of a newbie!). Without PulseAudio it defaults to Alsamixer.

Note to others having problems: you can control Alsamixer from terminal with command "alsamixer" (without quotes) then use up/down arrows to raise/lower volume. If you wish, you can add a sound control button on the GUI by right-clicking the bottom bar then "Add" button and then choose "sound control" (or something like that).

@ pete6
I'm near Leeds but if I'm ever near Reading, I'll PM you and set up a beer :)

lewmur
Posts: 363
Joined: Sun Dec 25, 2011 3:20 pm
Contact: Website

Re: No sound on 2012-12-16-wheezy-raspian

Thu Jan 10, 2013 3:11 pm

Wasp_Box wrote:@ lewmur
Alsamixer is still present on the latest release. It seemed to be using PulseAudio as it's "soundcard" if that makes sense (I'm something of a newbie!). Without PulseAudio it defaults to Alsamixer.

Note to others having problems: you can control Alsamixer from terminal with command "alsamixer" (without quotes) then use up/down arrows to raise/lower volume. If you wish, you can add a sound control button on the GUI by right-clicking the bottom bar then "Add" button and then choose "sound control" (or something like that).

@ pete6
I'm near Leeds but if I'm ever near Reading, I'll PM you and set up a beer :)
Alsa is present. The gnome-alsa-mixer is an GUI app for controlling alsa and must be installed via apt-get or Synaptic. Yes, you can control alsa via the command line alsamixer but it is MUCH, MUCH easier for noobs to do with gnome-alsa-mixer.

carolyn
Posts: 1
Joined: Sun Jul 14, 2013 7:20 pm

Re: No sound on 2012-12-16-wheezy-raspian

Sun Jul 14, 2013 7:28 pm

Thicko_1970 wrote:I've only had my Pi a couple of days, so I'm just getting to grips with the beginning of it. I've been pulling my hair out, over no audio on my Pi, even from a fresh SD image of the 2012-12-16-wheezy-raspbian.

I'd spent ages fiddling around in terminal trying various changes to config.txt, with no joy.

I just discovered that when I added the volume app to the taskbar, the slider was all the way down, which must be it's default volume setting. I can now hear sound, after sliding it up! So easy once found. :oops:
.
Thanx Thicko_1970 - this solved my problem immediately. It is so obvious. THIS SHOULD BE THE VERY FIRST ADVICE IN THE LIST FOR RASPBERRY BEGINNERS WITH SOUND PROBLEMS!

Return to “General discussion”