Chris D
Posts: 195
Joined: Tue Sep 20, 2016 11:27 am

RPI3 - Chrome - DNS problems some days / times?

Tue Dec 03, 2019 5:24 pm

Good day,

I have several RPIs all connected together via Ethernet cables and a switch. They are talking to each other fine and are configured with static IPs. This works very reliable and so far no problems.

However, the WiFi gives me fits. Using Chrome, some days websites load up fine, other days, not so much. For example, this morning, I wanted to install some software on it, I couldn't get to that website but I was able to get to Yahoo, and a few other popular websites. The net result is that I could only get onto a few websites and most others came up with the msg. "this site can't be reached"

I am pretty sure it is something with how I configured things with the static IP for the Ethernet port but beyond that don't know what to look for to fix this problem.

Chris D

epoch1970
Posts: 4996
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPI3 - Chrome - DNS problems some days / times?

Tue Dec 03, 2019 6:59 pm

If you can reach some names and some not, it is likely a problem with your DNS server. Or a firewall is in the way. The IP address is ok otherwise you would reach nothing.

Why not use DHCP? It autoconfigures the network and even the DNS server to use.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

Chris D
Posts: 195
Joined: Tue Sep 20, 2016 11:27 am

Re: RPI3 - Chrome - DNS problems some days / times?

Tue Dec 03, 2019 7:22 pm

I believe that my static IP address is ONLY for the Ethernet connection, not the WiFi connection. My Ethernet connections are all RPIs communicating with each other via MQTT and there is NO outside world connection on the Ethernet.

Based on my very minimal understanding of MQTT and the RPI, I need static IPs for MQTT on the Ethernet port, but am using DHCP for the WiFi communications.

mattmiller
Posts: 2230
Joined: Thu Feb 05, 2015 11:25 pm

Re: RPI3 - Chrome - DNS problems some days / times?

Tue Dec 10, 2019 4:53 pm

Because you've got 2 network connections - one to an Ethernet LAN and another WiFi to a router , your Pi computer is probably getting confused as to which one to use to access the internet as both of them are active

Computers use a term called metric to decide which is the best path to use and normally an Ethernet connection is considered better than a wifi one so your computer is trying to use that

Your metric for your Ethernet defaults to 202
Your Wlan one defaults to 303

(lowest one gets priority)

Since you've set static for Ethernet - probably easier to raise its value to 350

see here for example

https://raspberrypi.stackexchange.com/q ... on-raspian

Chris D
Posts: 195
Joined: Tue Sep 20, 2016 11:27 am

Re: RPI3 - Chrome - DNS problems some days / times?

Tue Dec 10, 2019 9:26 pm

Matt,

Thank you for that information. When I get home tonight from work, I will give that a try.

Chris D

Chris D
Posts: 195
Joined: Tue Sep 20, 2016 11:27 am

Re: RPI3 - Chrome - DNS problems some days / times?

Wed Dec 11, 2019 11:05 am

Matt,

Thank you VERY MUCH for pointing this out. That was the magic bullet for getting things to work like I expected. You would not believe how many websites, forum topics, etc. I have read about setting the static IP and no one mentions this important step.

Thank you again!

Chris D

Return to “General discussion”