TheRoark
Posts: 13
Joined: Sun Feb 11, 2018 4:17 pm

GNOME DE on Rpi 4 -- Can't do it

Sun Oct 27, 2019 6:25 pm

I am trying to install GNOME DE on a new Rpi 4 after installing Raspbian (note: I recognize it may be sluggish, so please no "don't do it" responses).

I have followed a few guides online, but none work. Here is what I've done

1. used tasksel as suggested here (https://www.stewright.me/2019/10/instal ... erry-pi-4/)

2. sudo apt install gnome-desktop

3. sudo apt install gnome-core

4. Install via the Raspian software center

Like this fairly recent post (https://www.raspberrypi.org/forums/view ... p?t=241850), the install appears to fail about 1/2 way, and I am asked to run APT --FIX-BROKEN INSTALL, which does not work.

Please post back if you have gotten GNOME DE to install on the Rpi 4?

Giga_Pi
Posts: 42
Joined: Mon May 20, 2019 9:48 am

Re: GNOME DE on Rpi 4 -- Can't do it

Mon Oct 28, 2019 2:19 pm

Hey there!

Just noticed this post...

Not sure what you are expeiriencing here. I usually use:

sudo apt install gnome

And I have been running gnome quite recently, so you don't need to doubt whther it actually works.

I'm not an expert on linux, so I haven't done anything too technical...

Anyway, try the command I told you about and see if you get far.
Microsoft can't help their neighbors, that's bad, hackers, that's bad!

TheRoark
Posts: 13
Joined: Sun Feb 11, 2018 4:17 pm

Re: GNOME DE on Rpi 4 -- Can't do it

Tue Oct 29, 2019 12:58 am

Trying that now. Will report back.....

TheRoark
Posts: 13
Joined: Sun Feb 11, 2018 4:17 pm

Re: GNOME DE on Rpi 4 -- Can't do it

Tue Oct 29, 2019 2:22 am

No go. I get this error:

Code: Select all

 dpkg:  error processsing archive /var/cache/apt/archives/gnome-software_3.30.6-5.armfh.deb (--unpack):
 [b]trying to overwrite '/usr/share/dbus-1/services/org.freedesktop.PackageKit.services', which is also in package pi-package-session 0.5[/b]
The following packages have unmet dependencies:
gnome-core : Depends : gnome-software (>= 3.30) but it is not installed
E: Unmet dependencies.  try 'apt --fix-broken install' with no packages (or specify a solution).
I think is the main issue is the attempt to overwrite '/usr/share/dbus-1/services/org.freedesktop.PackageKit.services', but I don't know what that is or why it is happening.

If I try to fix using `sudo apt --fix-broken install`, it returns

Code: Select all

 dpkg:  error processsing archive /var/cahce/apt/archives/gnome-software_3.30.6-5.armfh.deb (--unpack):
 [b]trying to overwrite '/usr/share/dbus-1/services/org.freedesktop.PackageKit.services', which is also in package pi-package-session 0.5[/b]
The following packages have unmet dependencies:
gnome-core : Depends : gnome-software (>= 3.30) but it is not installed
E: Unmet dependencies.  try 'apt --fix-broken install' with no packages (or specify a solution).
Errors were encountered while processing:
/var/cache/apt/archives/gnome-software_3.30.6-5.armfh.deb
E:  Sub-process /usr/bin/dpkg returned an error code (1)


If I then try to install `gnome-software`, I get this error:

Code: Select all

Errors were encountered while processing:
/var/cache/apt/archives/gnome-software_3.30.6-5.armfh.deb
E:  Sub-process /usr/bin/dpkg returned an error code (1)
There must be way to fix this?!?

wren
Posts: 79
Joined: Mon May 28, 2018 9:06 pm

Re: GNOME DE on Rpi 4 -- Can't do it

Tue Oct 29, 2019 3:34 am

Gnome now uses wayland by default, and I'm sure there are still issues going from x86 to arm. The Debian team just squeaked by getting it into 10. You might be better off trying to get it up and running on Gentoo.

TheRoark
Posts: 13
Joined: Sun Feb 11, 2018 4:17 pm

Re: GNOME DE on Rpi 4 -- Can't do it

Tue Oct 29, 2019 8:19 pm

I took @wren's suggestion - kind of - and tried Manjaro's 19.10 XFCE build for the Raspberry Pi 4 (can be found here https://manjaro.org/download/#).

Then I just installed GNOME using these instructions: https://wiki.manjaro.org/index.php/Inst ... ts#Gnome_3.

I have to say for those who may want to try it: GNOME is very snappy running on Manjaro with the Pi 4. Really. :D

Return to “General discussion”