Posts: 2
Joined: Sun Oct 06, 2019 12:07 pm

Read Only File System

Sun Oct 06, 2019 12:14 pm

Hi all,

I'm running a Plex server on my Raspberry Pi and I've run into a problem.

I've got three separate hard drives, all NTFS formatted (in case I want to transfer a large amount of files, then I can still plug it into Windows instead of using the FTP).

All three drives are auto mounted using the /etc/fstab file.

One of the drives works fine, but the other two are getting 'Read Only File System' errors whenever I try to do anything with them.

I've installed all of them the same way. The only differences are that both drives that don't work were used internally on a Windows before, and are connected through a (powered) USB hub.

Does anyone have any idea how to get rid of these errors? :(

Thanks in advance :)

Posts: 18
Joined: Fri Dec 01, 2017 6:44 am

Re: Read Only File System

Mon Oct 07, 2019 4:05 am

Haven't got a clue and probably not the one to give an answer, but I would suggest giving more info.
What are the relevant fstab lines?
Are you using ntfs-3g?
Do you use uid/gid/umask options in the fstab lines?

I used to mount an NTFS partition with this line:
UUID=0618B4FC18B4CAA9 /home/paul/Mnt/videos ntfs-3g auto,uid=1000,gid=1000,dmask=022,fmask=133 0 0

I believe uid of 1000 is the first user but could be wrong. You can find the uid for your user with the command

Code: Select all

id -u

and group with

Code: Select all

id -g

If you want to use the umask options (dmask for directories, fmask for files), you'd probably want to look that up.

Posts: 2
Joined: Sun Oct 06, 2019 12:07 pm

Re: Read Only File System

Mon Oct 07, 2019 4:44 am

Thanks for the reply.

After I had posted the thread I tried several things which were more in hope than expectation.

The one that worked was safely removing the HDD from a Windows file system, and then re-attaching it to the Pi.

Something that simple can apparently solve something so annoying.

Hope this answer will help someone else who's got the same problem :)


Re: Read Only File System

Wed Oct 09, 2019 2:49 pm

Not sure (I’m a Mac user not PC) but I think you may have had a ‘dirty’ NTFS drive.

There is a flag on each drive that states all data is correct and by just pulling the drive this may well have been still set on the drives so Linux would fall back to a safe mode of read only.

You can reset this with the ntfsfix program

Code: Select all

ntfsfix -d /dev/sda1
BUT this just resets the flag - it would not sort any data issues on the drive or files. That is the original operating systems task - now you know why Windows still provides an eject option fir drives :lol: it’s not because the programmers cannot fix it, it’s because users are not to be trusted :D

If you want to check disk integrity you can use the testdisk program.

Code: Select all

sudo apt install testdisk
should load it (if it’s in the Pi repository - no Pi handy at the mo) BUT like any disk utility - you stand the chance of loosing data if it needs to fix anything. Do not blame me if you do :lol: :roll: :lol:

Return to “General discussion”