User avatar
bucker
Posts: 107
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil

Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Tue Sep 17, 2019 8:56 pm

Hello,

My RPI4 suddenly stopped working and won't boot anymore, i tried the EPROM steps stated in downloads page but it didn't worked. I get always on red and green lights no matter what image i try (tried all flavours of buster and latest libreelec) i found this very weird since it worked for 1 month without any issue, is there something else i can try to fix this or my board is really dead?

More info:

- Tried with both 32 GB Samsung and 16gb Sandisk cards (both of them works in my raspberry pi zero W)
- When i boot my board without a SD card, i get the same static green and red leds, no blinking.
- Tried with 2 versions of bootloader available rpi-boot-eeprom-recovery-2019-05-10 and rpi-boot-eeprom-recovery-2019-07-15 neither worked
- I don't have the official PSU yet, i'm using a 5V 4A wall supply with TYPE-C to USB A cable, this combination worked for 1 month like i said without any issues or drops.

Any help on this please?
Winning is for losers.

Pi Zero W (inside a Pikachu case ;) ) with DietPi running Sonarr,Couchpotato,Pi-hole,Pi-VPN
Pi B running Home Assistant
Pi 2B & HiFiBerry DAC+ running Volumio OS
Pi 3B (inside a genesis case 8-) ) running RetroPie
--

jbudd
Posts: 1018
Joined: Mon Dec 16, 2013 10:23 am

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Tue Sep 17, 2019 10:37 pm

When i boot my board without a SD card, i get the same static green and red leds, no blinking.
This is a bad sign!

Other forum threads about Pi 4 with solid red and green LEDs suggest it's dead and you should try to get a replacement under the seller's warranty.

User avatar
bucker
Posts: 107
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 12:24 am

The only thread i could find with the same or much alike issue is this:

https://www.raspberrypi.org/forums/view ... 51#p1537851

about a month ago and ended with OP sending the board to jamesh at the Foundation labs.

So i think maybe it is dead indeed. Can you please point me to the threads you found? I wanna look a bit more before returning to the seller.
Winning is for losers.

Pi Zero W (inside a Pikachu case ;) ) with DietPi running Sonarr,Couchpotato,Pi-hole,Pi-VPN
Pi B running Home Assistant
Pi 2B & HiFiBerry DAC+ running Volumio OS
Pi 3B (inside a genesis case 8-) ) running RetroPie
--

jbudd
Posts: 1018
Joined: Mon Dec 16, 2013 10:23 am

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 5:03 am

Search the forum for "green light of death".
There are several different failures described, including solid green and red leds.

One reply points to documentation / hardware / boot eeprom, where it describes re-flashing the firmware and monitoring the boot process using a UART cable.

If you try that, please post the results here.

Boa sorte!

User avatar
bucker
Posts: 107
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 12:35 pm

I do have a UART cable (usb to serial PL2303) but i'm confused with the instructions provided in this link https://www.raspberrypi.org/documentati ... teeprom.md

To reflash the EPROM, i should only have 3 files in the root of my FAT formatted SD Card:

pieeprom.bin
README.txt
recovery.bin

but they mention that i have to put the option BOOT_UART=1 but it couldn't find where i have to set this config.
Winning is for losers.

Pi Zero W (inside a Pikachu case ;) ) with DietPi running Sonarr,Couchpotato,Pi-hole,Pi-VPN
Pi B running Home Assistant
Pi 2B & HiFiBerry DAC+ running Volumio OS
Pi 3B (inside a genesis case 8-) ) running RetroPie
--

hippy
Posts: 6076
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 1:30 pm

bucker wrote:
Wed Sep 18, 2019 12:35 pm
but they mention that i have to put the option BOOT_UART=1 but it couldn't find where i have to set this config.
It's not clear is it. From the following it reads to me that you need to have a working Pi with rpi-eeprom installed and a copy of 'pieeprom.bin', need to extract its current configuration into 'bootconf.txt', edit that, rebuild a new 'pieeprom.bin', copy that to SD Card and then boot with that to reload the Boot Eeprom chip -

Code: Select all

# To extract the configuration file from an EEPROM image.
rpi-eeprom-config pieeprom.bin --out bootconf.txt

# To update the configuration file in an EEPROM image.
rpi-eeprom-config pieeprom.bin --config bootconf.txt --out pieeprom-new.bin
For example -

Code: Select all

[email protected]:/tmp $ rpi-eeprom-config pieeprom.bin --out bootconf.txt
[email protected]:/tmp $ cat bootconf.txt
BOOT_UART=0
WAKE_ON_GPIO=0
[email protected]:/tmp $
Edit 'bootconf.txt', rebuild with -

Code: Select all

rpi-eeprom-config pieeprom.bin --config bootconf.txt --out pieeprom-new.bin
Then copy 'pieeprom-new.bin' to your SD Card as 'pieeprom.bin', boot it.

User avatar
bucker
Posts: 107
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 1:37 pm

Unfortunately i don't have access to another Pi now (specially not a PI4 that appears to be needed for this task) since the only one i have is this one that i'm trying to revive :lol:

If any of you guys could upload a file with this debug config i'll be very grateful.
Winning is for losers.

Pi Zero W (inside a Pikachu case ;) ) with DietPi running Sonarr,Couchpotato,Pi-hole,Pi-VPN
Pi B running Home Assistant
Pi 2B & HiFiBerry DAC+ running Volumio OS
Pi 3B (inside a genesis case 8-) ) running RetroPie
--

hippy
Posts: 6076
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Wed Sep 18, 2019 2:36 pm

bucker wrote:
Wed Sep 18, 2019 1:37 pm
Unfortunately i don't have access to another Pi now (specially not a PI4 that appears to be needed for this task)
The code is Python 2 so it should run on anything which supports Python 2, Pi or PC.

Not having a Pi 4B I don't know if I have the latest 'pieeprom.bin' so I would have to investigate that as I would not want to complicate things further. It's a 512KB image but I guess that will archive to something smaller.

User avatar
bucker
Posts: 107
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil

Re: Raspberry Pi 4 (2GB) Solid green and red lights and no boot

Thu Sep 19, 2019 8:18 pm

I just sent it back to my supplier, hopefully the next board will be ok.
Winning is for losers.

Pi Zero W (inside a Pikachu case ;) ) with DietPi running Sonarr,Couchpotato,Pi-hole,Pi-VPN
Pi B running Home Assistant
Pi 2B & HiFiBerry DAC+ running Volumio OS
Pi 3B (inside a genesis case 8-) ) running RetroPie
--

Return to “General discussion”