bdrmachine
Posts: 35
Joined: Fri Sep 20, 2013 8:52 pm

PI 4 no video

Tue Aug 20, 2019 1:26 am

After a 2 month wait, today my PI 4's arrived. I loaded a 16GB sd card with the latest raspbian and connected it all up. My monitor never displays a thing. I see the red led on the pi with a few quick blinks from the green led and the voltages test out fine. Both PI's act the same. I have also pulled working sd cards from prior pi versions with no change. Any suggestions? What brand / style of adapters are you guys using to convert to the micro HDMI connectors? Is there a adapter you could suggest to convert DVI-D to Micro HDMI?

Thanks Brian
Last edited by bdrmachine on Tue Aug 20, 2019 2:29 am, edited 1 time in total.

User avatar
Gavinmc42
Posts: 4034
Joined: Wed Aug 28, 2013 3:31 am

Re: PI 4 no video

Tue Aug 20, 2019 2:20 am

Pulling working SD cards from old Pi's won't work.
You need the new Buster for Pi4's. it has the new GPU drivers.
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

bdrmachine
Posts: 35
Joined: Fri Sep 20, 2013 8:52 pm

Re: PI 4 no video

Tue Aug 20, 2019 2:27 am

Thanks for the reply. I loaded a sd with 2019-07-10-raspbian-buster-full.img with no luck. I will try a second sd with a fresh down load of 2019-07-10-raspbian-buster-full.img.

Thanks

W. H. Heydt
Posts: 11067
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: PI 4 no video

Tue Aug 20, 2019 2:39 am

bdrmachine wrote:
Tue Aug 20, 2019 1:26 am
After a 2 month wait, today my PI 4's arrived. I loaded a 16GB sd card with the latest raspbian and connected it all up. My monitor never displays a thing. I see the red led on the pi with a few quick blinks from the green led and the voltages test out fine. Both PI's act the same. I have also pulled working sd cards from prior pi versions with no change. Any suggestions? What brand / style of adapters are you guys using to convert to the micro HDMI connectors? Is there a adapter you could suggest to convert DVI-D to Micro HDMI?

Thanks Brian
More to the point, are you sure you're connecting to the correct microHDMI port? You should be using the one closest to the power connector.

bdrmachine
Posts: 35
Joined: Fri Sep 20, 2013 8:52 pm

Re: PI 4 no video

Tue Aug 20, 2019 2:33 pm

For anyone that may experience the same problem here is what I found:

First, one of the two pi's appears to have a corrupt bootloader (I will look into this further).
Second the original sd card had some kind of error and the fresh card fixed the video / startup problem.

Return to “General discussion”