Posts: 92
Joined: Fri May 10, 2013 4:52 pm

Configuring WWan LTE modem (SIM7000a)

Sun Aug 11, 2019 3:59 am

I'm trying to figure out how to configure a SIM7000a model for a wwan connection. I'm currently trying to get it working on my ubuntu 18.04 but want to eventually move it onto raspberry pi (buster).

I activated an AT&T prepaid card and they say the apn should be set to 'phone'. I have verified with AT commands that the device sees the sim and set up the prepaid with the devices imei.

mmcli -L shows the device (as does the modem-manager-gui) but I'm getting device not registered on network errors. Is sim7000a not compatible with LTE? The bands seemed to match up and it was listed as the north-american model (a).

Modem Manager Gui is able to see the SMS devices saying the sim was activated. But it says 'Modem must be registered in mobile network to connect to Internet. Please wait...'

Code: Select all

$ mmcli -L
    /org/freedesktop/ModemManager1/Modem/9 [QUALCOMM INCORPORATED] 0
$ mmcli -m 9
  General  |            dbus path: /org/freedesktop/ModemManager1/Modem/9
           |            device id: 38e1ce95f270fd9760a2f3ece20a2f6b00bbd989
  Hardware |         manufacturer: QUALCOMM INCORPORATED
           |                model: 0
           |             revision: MPSS.JO.3.0.2.c3-00017-9607_LTEONLY_PACK-1  1  [Jul 25 2017 12:00:00]
           |         h/w revision: 10000
           |            supported: lte
           |              current: lte
           |         equipment id: xxxxxxxxxxxxx
  System   |               device: /sys/devices/pci0000:00/0000:00:10.1/usb7/7-1
           |              drivers: qmi_wwan, option1
           |               plugin: SimTech
           |         primary port: cdc-wdm1
           |                ports: ttyUSB0 (qcdm), wwp0s16f1u1i5 (net), ttyUSB3 (at), 
           |                       cdc-wdm1 (qmi), ttyUSB2 (at)
  Numbers  |                  own: 1734xxxxxxx
  Status   |                 lock: sim-pin2
           |       unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
           |                state: enabled
           |          power state: on
           |       signal quality: 0% (cached)
  Modes    |            supported: allowed: 4g; preferred: none
           |              current: allowed: 4g; preferred: none
  Bands    |            supported: eutran-2, eutran-3, eutran-4, eutran-12, eutran-13
           |              current: eutran-2, eutran-4, eutran-12, eutran-13
  IP       |            supported: ipv4, ipv6, ipv4v6
  3GPP     |                 imei: xxxxxxxxxxxxxxxxxx
  3GPP EPS | ue mode of operation: csps-1
  SIM      |            dbus path: /org/freedesktop/ModemManager1/SIM/9

$ sudo nmcli dev status
DEVICE      TYPE      STATE         CONNECTION         
eno1        ethernet  connected     Wired connection 1 
wlp3s0      wifi      connected     Auto MYSSID
cdc-wdm1    modem     disconnected  --                 
lo          loopback  unmanaged     --                 

$ sudo cat /etc/NetworkManager/system-connections/ATT\ Wireless 
id=ATT Wireless




$ nmcli c up "ATT Wireless"Error: Connection activation failed: Network registration timed out

I should add that I also downloaded and installed via dkms a GobiSerial module but it doesn't seem to tie to this device in any way. Not sure what to configure so it does (or if it is even necessary).
The old version downloaded from the SIM7000 mfgr website wouldn't compile. I found a newer version of GobiSerial on github and followed the instructions to add it via dkms including blacklisting qcserial. The old version appeared to be set up to use usb_wwan instead of qmi_wwan which is being loaded automatically when I plug the device in. (it's on a PCIE-to-USB adapter currently, but I'm considering picking up a PCIE pi-hat)

Code: Select all

$ lsmod
# edited ...
GobiSerial             16384  0
option                 53248  0
cp210x                 28672  0
cdc_ether              16384  0
qmi_wwan               32768  0
r8169                  86016  0
usb_wwan               20480  1 option
cdc_wdm                20480  1 qmi_wwan
usbnet                 45056  2 qmi_wwan,cdc_ether
usbserial              45056  4 cp210x,GobiSerial,usb_wwan,option
mii                    16384  2 r8169,usbnet

Posts: 92
Joined: Fri May 10, 2013 4:52 pm

Re: Configuring WWan LTE modem (SIM7000a)

Sun Aug 18, 2019 6:45 am

I've picked up yet another device to try to get this working. (this is the 5th overall, I got the AT&T one working briefly last year, but it wasn't working where I planned on using it - tried it again this year and can't even get it working at home - they're apparently switching to all LTE-m and blocking direct connection through a cloud-wall/NAT now)

This time I picked up a 340u aircard as I saw posts of people saying they had gotten in working under linux and on a pi. I confirmed it's working under my only windows, fortunately windows 7 as apparently that's recommended as the only platform that can properly update the firmware to remove Windows 8 QMMI support to get it working on linux.
It was still working after flashing the non-QMMI firmware under windows 7 and initially wouldn't even work on my ubuntu machine. I can see the qmi_wwan load, it creates a wwan0 device. On RPi it tries to rename it but fails. On ubuntu it did rename it but initially wasn't working. I checked on windows 7 again and was considering flashing yet another firmware that gets rid of the nat, but tried it again briefly on ubuntu and it actually worked for the first time getting a 10.185.* (still private NAT) address. But it still is a no go on the pi. That was a 2a+ recently updated to buster with network-manager, I also tried a BPi 2m zero running Jessie, a BPi m1 running armbian (it didn't even create a wwan0 but did load qmi_wwan) and a 2B without network manager. No go on all of them.

So what is ubuntu doing that the others are not and how can I try to figure it out, as I am not sure where to look for modem/device logging. Nothing shows up in dmesg after the initial device comes up and wwan0 gets renamed.


Posts: 26
Joined: Thu Dec 31, 2015 11:13 pm

Re: Configuring WWan LTE modem (SIM7000a)

Sun Aug 18, 2019 1:32 pm

As to your original post, shouldn't the APN for AT&T be "broadband"? That's what I've used in the past on Sierra Wireless devices (MC7455, EM6511, EM7565). Your device wasn't able to register minimally due to a wrong APN.

As to your followup post: no experience with the devices you're using, but the authors of ModemManager do have a forum available but I can't paste it on this tablet - check

Return to “General discussion”