User avatar
Pie_with_Berries
Posts: 5
Joined: Mon Jul 15, 2019 9:47 am
Location: Czech Republic, Olomouc

Kernel panic = ded os because too much gpu ram? (Pls send help. And fix)

Fri Jul 19, 2019 12:46 pm

Okay,
I have RPI 4B 2Gb model
And I was in config settings of pi. Then I maxed out gpu ram because what can go wrong.
Max was 800 something MB.
First I wanted to max it out to 1GB gpu ram because 1. Minecraft is ram eating $!@#.
and 2. I got 2Gb of ram soo I can expand gpu ram to plus minus 900mb (I dont know how much buster eats).

Well after i press restart and check the phone in meanwhile. I see Kernel panic error and after just reading Kernel panic, I knew that OS is F word.
It says this:
---[ end Kernel panic - not syncing : System is deadlocked on memory ]---
I know that system doesn't have enough ram to start.
But is there any way to fix that?
I dont wanna reinstall os (well that will fix that for 100% but I have too important files on that sd card and I didn't do backup so thats no go.)
I can't ssh into a pi. (In short grandma pc is piece of potato..)
And I can't take the sd, and put it into pc (I dont have sd card reader and sd card adapter at grandma. Hell.).
Is in raspbian any safe mode or in the firmware?
Thx for any answers and help.


Your (Idiot that is playing with ram) Pie_with_berries
Don´t worry!! I´m Profesional! 8-)

User avatar
bomblord
Posts: 285
Joined: Sun Jul 14, 2019 2:54 am

Re: Kernel panic = ded os because too much gpu ram? (Pls send help. And fix)

Fri Jul 19, 2019 12:51 pm

Your only option is to remove the SD card, put it in another PC, and edit the GPU ram allocation in the config.txt file. Something like gpu_mem_256


You can pick up a cheap reader on amazon (I use this one) https://www.amazon.com/UGREEN-Reader-Me ... ay&sr=8-14

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 10598
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Kernel panic = ded os because too much gpu ram? (Pls send help. And fix)

Fri Jul 19, 2019 2:04 pm

(a) No, there is no way to directly alter the gpu ram if you've done silly things in config.txt.
(b) There's very little point in increasing gpu_mem significantly. You can't use the legacy 3D driver as it is for the older 3D hardware only. The new 3D hardware has an IOMMU, therefore it doesn't need specific memory reservations. You do need to reserve memory for on screen, but that is from the Linux kernel CMA heap. gpu_mem is pretty much now only used for the camera and H264 codec.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

Return to “General discussion”