Page 1 of 1

Update Error

Posted: Mon Jul 08, 2019 9:06 am
by altanhaligur
sudo apt-get update
Get:1 http://archive.raspbian.org/raspbian jessie InRelease [15.0 kB]
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists... Done
E: Repository 'http://archive.raspbian.org/raspbian jessie InRelease' changed it s 'Suite' value from 'oldstable' to 'oldoldstable'
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.

What should i do?

Re: Update Error

Posted: Mon Jul 08, 2019 9:18 am
by rpdom
This has been mentioned in another post. It is the first time I have encountered this issue on a Debian based system.

One solution (Thanks to PeterO), is to use

Code: Select all

sudo apt-get update --allow-releaseinfo-change
Which will stop the issue from reoccurring.

You should only need to run that once. After that the mormal

Code: Select all

sudo apt-get update
should be sufficient.

Re: Update Error

Posted: Mon Jul 08, 2019 9:18 am
by DougieLawson
Deleted.

Re: Update Error

Posted: Mon Jul 08, 2019 9:20 am
by rpdom
DougieLawson wrote:
Mon Jul 08, 2019 9:18 am
The pragmatic answer is upgrade to Buster on a new SDCard then move your programs & data over from the retired & unsupportable OS.
Dougie. Please read the posts. This is happening if you already have Buster.

Re: Update Error

Posted: Mon Jul 08, 2019 9:26 am
by DougieLawson
rpdom wrote:
Mon Jul 08, 2019 9:20 am
DougieLawson wrote:
Mon Jul 08, 2019 9:18 am
The pragmatic answer is upgrade to Buster on a new SDCard then move your programs & data over from the retired & unsupportable OS.
Dougie. Please read the posts. This is happening if you already have Buster.
Sorry I read it as Jessie.

Buster updates were working ok for me yesterday when I was rebuilding my server with Buster (postfix, MariaDB, apache2, Mosquitto, php7.3) on the backup hard disk partition.

It also worked on my PiAware ADSB server which I cut-over to Buster at 22:45 last night.

Re: Update Error

Posted: Mon Jul 08, 2019 10:44 am
by SimUK
.

Re: Update Error

Posted: Mon Jul 08, 2019 11:42 am
by Elektrik
Just run:

Code: Select all

sudo apt-get clean all
sudo apt-get update