Page 1 of 1

Citrix Workspace on Pi 3

Posted: Sun Jul 07, 2019 3:06 pm
by audetto
I've recently tried to run Citrix Workspace on the Pi with poor results.

1) The chromium app: works on Pi 2 and Pi 3, but it is too slow. Impossible to use on Pi 2, but still too slow on a Pi 3 b+. Connection always happens correctly.

2) Installed Citrix Receiver (wfica) on Pi 2 and 3 in Raspbian 9. It either fails to connect or when it connects it looks like it has massive rendering issues. It seems to work for a few seconds then it kind of stop completely.
Other times it just returns "Unknown error" cannot connect.

I feel the native app would perform much better, but it is riddled with issues.

Is anybody able to run the Workspace app in Raspbian?

Cheers

[SOLVED] Re: Citrix Workspace on Pi 3

Posted: Tue Jul 09, 2019 5:37 am
by audetto
I managed to connect with both a PI2 and PI3 with super good performance.

The error was yet again a certificate issue. The problem is that some errors area clearly linked to certificates, others (like unknown error) are more difficult to relate to it.

In the end I have added all certificates from /etc/ssl/certs AND the certificate of the website I use.

It is really odd that a system designed to ensure security (certificates) becomes so awkward to use that the only solution is basically to trust everything.

Re: Citrix Workspace on Pi 3

Posted: Tue Jul 09, 2019 6:52 am
by clicky
Are you talking about Citrix Workspace on Buster or previous versions of Raspbian?
(I tried to install it on Buster and ended up with some issues regarding libraries - I think libxerces being newer and that broke it)

Re: Citrix Workspace on Pi 3

Posted: Thu Jul 11, 2019 9:26 pm
by audetto
Previous version. With buster I have the same issue as you

Re: Citrix Workspace on Pi 3

Posted: Fri Nov 22, 2019 7:42 am
by Eelcoh
With the previous version of Raspbian it worked fine for more than a year. I upgraded to Buster and have similar problems now. Can't get it to work and will go back tot the previous version Raspbian.