mingmekka
Posts: 1
Joined: Fri Jul 05, 2019 2:58 pm

No output from RCA video

Fri Jul 05, 2019 5:41 pm

Hello and welcome.

I just bought some PI4 for an art installation for which I need the RCA composite video output. I tested the same procedure with PI3 and it works awesome. Now, with the PI4 it seems like the PI can't output the GUI through RCA. Console mode (CLI) works fine, but it seems like there is some problem with the composite out.

Steps I did in config file:

1. enable_tvout=1
2. hdmi_ignore_hotplug=1
3. #hdmi_force_hotplug=1
4. sdtv_mode=2

Also with this settings, when I'm in the NOOBS menu (after pressing shift while boot) usually I can switch to RCA PAL or NTSC with 1,2,3,4. Now with the PI4 it doesn't work. I can stille see that something happens on the TV, but it just flickers. After turning back to hdmi everything crashes and the screen shows a crash dialog (photo attached)
WhatsApp Image 2019-07-05 at 16.55.51.jpeg
Crash after switching to RCA composite output
WhatsApp Image 2019-07-05 at 16.55.51.jpeg (91.23 KiB) Viewed 569 times
In the CLI mode I can boot the PI, but when I try to do something GPU related (like open a video file), the command line shows me the data about the video but not the video itself. After couple of time trying this the PI crashes.

I need it so badly, the art installation is already in two weeks. If some could help me, that would be awesome.

Best Regards
Artur

noggin
Posts: 99
Joined: Sun Feb 21, 2016 1:55 pm

Re: No output from RCA video

Fri Jul 05, 2019 10:33 pm

Have you tried switching back to the legacy video driver - I think you can do that in raspi-config advanced settings? Someone else may be able to advise better.

I think the Pi4B defaults to the new Open Source V3D drivers?

User avatar
DavidS
Posts: 4334
Joined: Thu Dec 15, 2011 6:39 am
Location: USA
Contact: Website

Re: No output from RCA video

Sat Jul 06, 2019 2:59 am

I hope this gets figured out. I am running on composite video out in anticipation of getting a RPi 4B in the furture, as I am not going to throw money at a new MicroHDMI cable until I know I will be using the computer on a daily basis.

I hope this is a simple fix type thing (and not OS Specific as I do most of my stuff outside of Linux, largely in RISC OS).
RPi = The best ARM based RISC OS computer around
More than 95% of posts made from RISC OS on RPi 1B/1B+ computers. Most of the rest from RISC OS on RPi 2B/3B/3B+ computers

User avatar
HawaiianPi
Posts: 5199
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: No output from RCA video

Sat Jul 06, 2019 3:24 am

I read somewhere that composite out was disabled by default on the Pi4, but I believe there was a way to turn it on.

Can't remember the details, though, sorry.

If I find or remember anything I'll pop back in and post it.

mingmekka wrote:
Fri Jul 05, 2019 5:41 pm
I need it so badly, the art installation is already in two weeks. If some could help me, that would be awesome.
If you already knew it worked on the Pi3, you should have stuck with that instead of hoping a new, untested product would work.

Try a forum or goole search for Pi4 composite output.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 7905
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: No output from RCA video

Sat Jul 06, 2019 7:30 am

Code: Select all

enable_tvout=1
is correct to enable the analogue output.

Code: Select all

hdmi_ignore_hotplug=1
forces enabling HDMI0 - you do not want this. (I'd hope that this is ignored with "enable_tvout=1").

TV out puts some fairly strict limits on the clock setup for the Pi4 which limits performance a little, hence it is disabled by default.
I don't know if NOOBS has been checked as to whether you can switch to analog video or not. I'd recommend using Raspbian directly if at all possible.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

noggin
Posts: 99
Joined: Sun Feb 21, 2016 1:55 pm

Re: No output from RCA video

Thu Jul 11, 2019 5:11 pm

Interesting - the Pi4B is outputting 31kHz "PAL" with burst in some situations (a totally non-existent analogue standard!) This is twice the normal line rate of 15.625kHz (as if the Pi is outputting progressive 576p50 rather than interlaced 576i25?)

https://twitter.com/IsItBroke/status/11 ... 48929?s=20

drgeoff
Posts: 10214
Joined: Wed Jan 25, 2012 6:39 pm

Re: No output from RCA video

Thu Jul 11, 2019 5:31 pm

noggin wrote:
Thu Jul 11, 2019 5:11 pm
Interesting - the Pi4B is outputting 31kHz "PAL" with burst in some situations (a totally non-existent analogue standard!) This is twice the normal line rate of 15.625kHz (as if the Pi is outputting progressive 576p50 rather than interlaced 576i25?)

https://twitter.com/IsItBroke/status/11 ... 48929?s=20
No it is not.

The bottom right corner of the screen shows 10us per major division. 6.4 such divisions makes 64us which is the correct 625/50 line period and equivalent to 15625 Hz.

And that 31.2920 number is Hz not kHz. The suggestion that the dot after the 31 is a local language version of a comma and means 31 thousand doesn't hold water. If that were the case the 10.0us would mean 10 thousand microseconds.

Return to “General discussion”