Page 1 of 1

problems with raspberry pi 4b

Posted: Fri Jun 28, 2019 11:45 pm
by settheory
hello together,

i ordered a raspberry pi 4b with 4gb ram and the original PSU. As usual i installed a fresh raspbian on a micro sd card. The first boot was successful but during the upgrade after the configuration, there appeared a problem with the bootloader. Unfortunately i ignored the message and did a reboot. Now the most time the pi doesnt boot (also with another fresh installs) or it hangs after some time. But there are no problems on 3b. Can anyone help?

Im very grateful for hints.

PS: sorry for the bad english.

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 9:23 am
by shifters74a
I would try a different SD card in the first instance.

When you say the original PSU do you mean the PSU for the Pi3b etc with a USB C adapter or the newer 3A pi4 usb c adapter?

regards

Shifters

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 10:18 am
by settheory
Hello shifters,

its the psu for the pi 4b. i already tried different cards but no changes. Last time i managed to boot it. I tried to install some packages but no luck. Its became very slow and hot.

im very helpless.

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 10:35 am
by HawaiianPi

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 10:37 am
by settheory
thank you, i already checked this. It blinks fine in a pattern.

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 11:18 am
by juhas
In my case, the RPI 4 does not boot at all. The red led is on and the green led blinks few times for about one second. After that the green light is off. I tried with a lot of different USB-C power supplies. However, I did yet have the official PSU for RPI 4. I will get that next week. Does RPI-4 work with any other USB-C power supply than the one designed for RPI 4?

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 12:17 pm
by pik33
Does RPI-4 work with any other USB-C power supply than the one designed for RPI 4?
Yes, it works. I have a few of "noname" ("extreme style" is written on the case) 5.3V 3.1A power supplies I bought and tested as good for my RPi3s. They have USB type A connector so for RPi4 I only bought a USB A-USB C cable. This works.

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 12:26 pm
by FTrevorGowen
juhas wrote:
Sat Jun 29, 2019 11:18 am
In my case, the RPI 4 does not boot at all. The red led is on and the green led blinks few times for about one second. After that the green light is off. I tried with a lot of different USB-C power supplies. However, I did yet have the official PSU for RPI 4. I will get that next week. Does RPI-4 work with any other USB-C power supply than the one designed for RPI 4?
Some testing has been done with other devices, FWIW, this is one of them:
http://www.cpmspectrepi.uk/raspberry_pi ... .2FCharger
I found it worked better with the shorter cable.
See also other threads here for examples/issues.
However only the official PSU has been specifically "designed for RPI 4" etc. (I will be getting one eventually, meanwhile one has been assessed by another forum member here: https://www.raspberrypi.org/forums/view ... 3&t=243942 - compare those measurements to that for the above!)
Trev.

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 3:16 pm
by b3lt3r
You may want to check that your display is plugged into HDMI port 0 - closest to the USB-C. The alternate port does not seem to output video once updates have been done following the initial configuration. Fixed mine and several other peoples apparently "not booting" Pis

Re: problems with raspberry pi 4b

Posted: Sat Jun 29, 2019 7:44 pm
by settheory
Hello b3lt3r,

thank you very much. This solved the problem. I hope this is a temporary limitation.

Greetings settheory

Re: problems with raspberry pi 4b

Posted: Sun Jun 30, 2019 10:35 am
by juhas
juhas wrote:
Sat Jun 29, 2019 11:18 am
In my case, the RPI 4 does not boot at all. The red led is on and the green led blinks few times for about one second. After that the green light is off. I tried with a lot of different USB-C power supplies. However, I did yet have the official PSU for RPI 4. I will get that next week. Does RPI-4 work with any other USB-C power supply than the one designed for RPI 4?
Got it working with Raspberry Pi 3+ Power supply + micro-USB to USB-C converter. In addition, got it working with some other USB-C chargers as well. Before that I downloaded the latest Raspian Booster Desktop image. It seems that I was accidentally using an incorrect image.

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 7:04 pm
by esp2gps
This is my first post, I may not be using this forum correctly - I apologize if I'm off topic or not in the right thread.

Raspberry Pi 4 won't boot "2019-07-10-raspbian-buster-full"

I have tried many things and still can't get my new 4B to boot with latest raspbian-buster.

What I have done:
- power supply is 5.1V 3.5A, monitor is HP (see below)

- Forums suggested that eeprom may be corrupted, thus:
- formatted micro SD card as 32FAT, downloaded 'rpi-boot-eeprom-recovery-2019-05-10' to SD
-powered on, to restore eeprom booting software
- I get red power-on light and infinite rapid blinking green ACT light
- light pattern indicates success according to forum discussions


- Formatted micro SD 64Gb 32FAT using Guiformat utility
- downloaded latest "2019-07-10-raspbian-buster-full.img"
- unpacked .img to SD card with 7-zip. Unzip successful. Files look OK.
- \boot\ is empty as expected since boot is from EEPROM
- attempting to boot up from raspbian-buster SD card
- at power-one, red power-light is on, infinite blinking of green light pattern 3-short-1-long
- no signal to HDMI using plug adjacent to power plug

- Monitor is HP and used for years with previous Raspberry Pi's, latest 3B+

I'm spent on this! Don't know why its so hard for a newbie to try this stuff.

Any idea where I went wrong?
I sure appreciate any advice

Ed

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 7:56 pm
by rpdom
esp2gps wrote:
Sun Aug 25, 2019 7:04 pm
Any idea where I went wrong?
I can see a few possibilities.
Forums suggested that eeprom may be corrupted
Did you confirm that with the standard test? Turn on Pi with no SD card or anything else connected and see what the LED shows.
Corrupted EEPROM contents are extremely rare.
\boot\ is empty as expected since boot is from EEPROM
I don't know what \boot\ is supposed to be, but /boot is on the first partition of the SD card. not in EEPROM on any Pi. The file in EEPROM is the bootcode.bin in /boot from earlier Pis.

The blinking LED pattern is the important bit. There should be something in the Not Booting sticky post about that.

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 9:48 pm
by esp2gps
Thanks for the suggestion. I removed the micro SD, nothing else plugged in, powered on and
green flash pattern is 3 shorts and 1 much longer. Pattern repeats infinitely.

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 9:51 pm
by esp2gps
Forgot to comment about the EEPROM. Are you sure about this on Pi 4B? My understanding is this is the first where booting if from the EEPROM.

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 10:22 pm
by rpdom
Yes. Only the bootcode.bin file is in the EEPROM. All the other boot files are on the SD card.

I just noticed
unpacked .img to SD card with 7-zip. Unzip successful. Files look OK
That's not the way to install Raspbian.

The recommended way is to use Etcher to write the img file to the card. Etcher will also work with the zip file.

Once the card has been imaged, you should remove it from your PC. If you then put it back in the PC you should see two partitions. The first one is /boot. The second, which won't be recognised by Windows or Mac is the main Linux filesystem.

If Windows suggests that the partition needs formatting IGNORE IT! It is wrong.

Re: problems with raspberry pi 4b

Posted: Sun Aug 25, 2019 10:50 pm
by esp2gps
Is using a large micro, ie. 64G, an issue? Should I use something smaller?

Re: problems with raspberry pi 4b

Posted: Mon Aug 26, 2019 5:43 am
by markkuk
I have a 128GB MicroSD card in my Pi4. Any size up to 2TB should work without any problems.

Re: problems with raspberry pi 4b

Posted: Mon Aug 26, 2019 11:30 pm
by esp2gps
RPDOM,
Thanks for the Etcher advice. I remade the RPI 4 micro from "2019-07-10-raspbian-buster-full.img" using Etcher. It took a forth the time that zip took including the second phase verification check. My RPI 4 booted up instantly.

Your help was key. Thanks again.