Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Weird boot up

Sun May 19, 2019 11:32 pm

On my raspberry pi 0w appears this stationary "boot up" screen. I've tried 2 different sd cards and flashing the same raspberian image to the pi. I haven't dived into the relm that the image doesn't work but a fresh copy of NOOBS didn't work either. A sample part of the screen shows "[ 489.443019] INFO: task swapper:1 blocked for more than 120 seconds. [ 489.443251]
Not tainted 4.14.98+ #1200 [ 489.443396] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message". Prior to this, the pi worked clockwork booting into raspberian, though my post pi hadn't been directly soldered on. I've searched the great web for a solution but said resource hadn't even a result. Also, I'm a soldering novice, leaving the iron on the board to remove parts. I'm thinking of replacing my pi to a better one if this screen spells inexplicit doom.

User avatar
scruss
Posts: 2224
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: Weird boot up

Sun May 19, 2019 11:52 pm

it's not clear: did you solder something onto it? What, and why?
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Mon May 20, 2019 12:03 am

It’s possible the download is corrupt.

Try the standard lite image and check the SHA value and use Etcher to make the image.

See if that boots.

Also check you soldering for shorts. Please explain what you soldered...
Need Pi spray - these things are breeding in my house...

Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Re: Weird boot up

Mon May 20, 2019 12:12 am

Ok, so I soldered a tft 3.5 inch lcd display onto the pi. I've tried the lite but to the same effect as before.

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Mon May 20, 2019 1:08 am

Start by unsoldering the screen and see if the Pi boots without.

Make sure all solder and flux is removed.
Need Pi spray - these things are breeding in my house...

W. H. Heydt
Posts: 9989
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Weird boot up

Mon May 20, 2019 1:11 am

FYI...the way I normally mount a 3.5" screen to a Pi0/Pi0W is to solder a set of header pins in place and then just attach the screen to those.

Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Re: Weird boot up

Fri May 24, 2019 1:55 am

For a clearer look at the problem...
https://youtu.be/GD5qraNR-Gw

W. H. Heydt
Posts: 9989
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Weird boot up

Fri May 24, 2019 4:52 am

Dri-Files wrote:
Fri May 24, 2019 1:55 am
For a clearer look at the problem...
https://youtu.be/GD5qraNR-Gw
It would be a lot clearer if it was a static shot.

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Fri May 24, 2019 10:31 am

Gut feel is that the Pi is trying to read what type of HAT the screen is and is looping / blocking at that point. Other thought is one / two pins are shorted giving odd results to start up code with the same effect.

Best steps are to remove the screen and try a boot with a solder free Pi.

Do you have a Pi Jam or Maker group near you as these often have an intro to soldering or folk that are happy to help?
Need Pi spray - these things are breeding in my house...

Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Re: Weird boot up

Fri May 24, 2019 12:30 pm

I removed the 3.5 inch tft to the same result and on further inspection on my pi, I could see some blacked out gpio slots. Is there any solution?

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Fri May 24, 2019 12:34 pm

Not sure what you mean by blacked out :oops: - it could be flux from the solder or it could be a short...

Piccy please :D
Need Pi spray - these things are breeding in my house...

Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Re: Weird boot up

Fri May 24, 2019 12:37 pm

From what I see, it's a short out.

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Fri May 24, 2019 12:43 pm

If it’s a short you could be looking at the £35 fix I am afraid :cry:

Or in your case a new Pi WH (ready fitted headers)...

No idea if scraping the board would work but it’s a multi layer PCB and unlikely to be the surface layer only.

What pins are joined?
Need Pi spray - these things are breeding in my house...

Dri-Files
Posts: 8
Joined: Sat Apr 13, 2019 6:46 pm

Re: Weird boot up

Fri May 24, 2019 12:45 pm

The shorted pins are pin 1 and pin 2.

Andyroo
Posts: 2827
Joined: Sat Jun 16, 2018 12:49 am
Location: Lincs U.K.

Re: Weird boot up

Fri May 24, 2019 12:55 pm

That 3v3 to 5V on the physical pins going by https://pinout.xyz/ (too many numbering schemes) - normally that’s a death sentence to a Pi
Need Pi spray - these things are breeding in my house...

Return to “General discussion”