Page 1 of 1

Motion sensor problems

Posted: Sun Apr 21, 2019 1:43 pm
by jadro
Hi,
I have motion sensor working for a two years now without problems.
Unusual behavior start couple a days before, it suddenly start to notify movements, every 15 minutes, sometime every hour, no rules and guess, when nobody is home. Maybe sensor does not work anymore as usual. But, i have mobile mqtt client application that read the movement. Sometimes when i open application, my sensor read a movement in that second i use application, this is so strange. Is anyone having similar unusual motion behavior?

thanx,
Jadro

Re: Motion sensor problems

Posted: Sun Apr 21, 2019 2:05 pm
by pcmanbob
You have not said what type of sensor , but if it was working for 2 years and now its not then I would suspect the sensor had gone faulty.

Try replacing it with a new sensor.

Re: Motion sensor problems

Posted: Sun Apr 21, 2019 2:57 pm
by jadro
it is dht22 sensor. I will try the new one

Re: Motion sensor problems

Posted: Sun Apr 21, 2019 3:11 pm
by pcmanbob
jadro wrote:
Sun Apr 21, 2019 2:57 pm
it is dht22 sensor. I will try the new one
Confused :? you said a motion sensor in your first post, but a dht22 is a temperature/humidity sensor,

but my answer remains the same suspect the sensor or possibly the wiring, if it could have be come damaged.

Re: Motion sensor problems

Posted: Sun Apr 21, 2019 3:21 pm
by jadro
Sorry, i writte two parallel posts..
I have motion PIR Infrared Motion Sensor Module that shows wrong motions. And dht22 is from other post, sorry

Re: Motion sensor problems

Posted: Fri Jun 14, 2019 6:58 am
by jadro
My new PIR sensor arrived but same problem exists. For some reason it still reads motion random...
I dont know what causes this because my script has not been changing for two years. Maybe some update change behavior to this.

Now I have question,
what if I write new script python just for reading motion that runs in new idle with reading same PIN? will this parallel script work? I will try.

Jadro

Re: Motion sensor problems

Posted: Fri Jun 14, 2019 7:35 am
by pcmanbob
Have you tried testing the sensor ( assuming HC-SR501 ) away from the pi, just connect 5v and ground and then use a volt meter to monitor the output.

The HC-SR501 is know to suffer random triggering when used with a pi that has wifi, because the wifi affects the sensor chip causing random triggering.

Re: Motion sensor problems

Posted: Fri Jun 14, 2019 7:44 am
by jadro
pcmanbob wrote:
Fri Jun 14, 2019 7:35 am
Have you tried testing the sensor ( assuming HC-SR501 ) away from the pi, just connect 5v and ground and then use a volt meter to monitor the output.

The HC-SR501 is know to suffer random triggering when used with a pi that has wifi, because the wifi affects the sensor chip causing random triggering.
I didn't know that. I didn't tested it with voltmeter. I will try this. Only...my raspberry pi is on the wifi but whole past year this hasn't been problem. But nothing will cost me to test it.

Re: Motion sensor problems

Posted: Fri Jun 14, 2019 7:49 am
by pcmanbob
May be your original sensor was just a better quality and did not suffer from the problem until it aged/failed , with the increased interest in the use of pi's and arduino's lots of cheap components from china have reached the market, some of them may not be up to the original standard of the components.

Re: Motion sensor problems

Posted: Sat Jun 15, 2019 1:11 pm
by jadro
I think and dont realize how to check with voltmeter my sensor works or not because it works and trigger random,, this is not mesuarable in this way, with voltmeter can only measure if sensor works, no?

Re: Motion sensor problems

Posted: Sat Jun 15, 2019 2:23 pm
by pcmanbob
The idea was to move the sensor away from the pi to see if it triggers randomly then , but I guess it depends on how often it randomly triggers,
to test it you just need to set meter to DC volts and connect between output on sensor and ground,
when sensor detects/triggers you should see 3V .

Re: Motion sensor problems

Posted: Sat Jun 15, 2019 2:26 pm
by jadro
It triggers, then after 5 min triggers again, then after 3 min, then 12, 5, 3, 10 12.. wery often, with no order, somethime after one hour

Re: Motion sensor problems

Posted: Sat Jun 15, 2019 2:34 pm
by pcmanbob
Does it still trigger like this if you have it removed from the pi and using the meter to check for triggering ?

what you looking to do is get it away from the pi wifi , to see if it's the wifi that's causing the triggering.

Re: Motion sensor problems

Posted: Sat Jun 15, 2019 2:39 pm
by jadro
Yes thanx, this will be my next step, removing it from wifi or remove raspberry because they are 30 centimeter from wifi device. And this maybe a problem because this start to happening when i replace my old router wifi

Re: Motion sensor problems - [SOLVED]

Posted: Mon Jun 17, 2019 9:51 am
by jadro
I move sensor about 1 meter from my wifi router, and for now, motion sensor does not trigger false anymore. Thanx for this solution. I did not know this can be a problem.
Jadro