Page 1 of 1

Raspberry Pi B invisible when attached to unmanaged switch [solved]

Posted: Sun Mar 31, 2019 5:27 am
by peewee44
Hello

I have just had my internet connection upgraded.

My Raspberry Pi B is visible on the network when directly attached to my modem TP-Link (Archer VR1600V).

But when I attach an unmanaged gigabit switch (DLink DGS-1008D) to the modem and attach the RPi to the unmanaged switch the RPi is invisible on the network.

Any suggestions welcome.

Re: Raspberry Pi B invisible when attached to unmanaged switch

Posted: Sun Mar 31, 2019 7:25 am
by pootle
sounds like you have a duff cable.

Are all the lan ports lit up wueh you plug things together?

Can you try plugging something else in with the same cable you use with the pi?

I have connected ;pi's via many different typesof switch and never had a problem.

Re: Raspberry Pi B invisible when attached to unmanaged switch

Posted: Sun Mar 31, 2019 7:30 am
by B.Goode
To avoid uncertainty, what model of Raspberry Pi board do you have? There are two models currently available that could be described as 'Model B', and a further 2 that could be described as 'Model B+'.

I haven't found full specs for your switch. It clearly isn't "dumb".

Does it automatically support negotiation of connection speed and other parameters?

If it is a Gigabit-only device (if such things exist) it will be compatible only with an RPi3B+.

Gigabit ports will require a full 8-wire (4 twisted pair) connection. Apparently there are lower-spec cables around that will work with lower speed devices.

Re: Raspberry Pi B invisible when attached to unmanaged switch

Posted: Sun Mar 31, 2019 7:40 pm
by peewee44
Thanks for your replies.

Here are a few clarifications.

- Raspberry Pi B purchased April 2013.

- the switch negotiates speeds etc so this means that it is not dumb, just unmanaged. My error.

- previously the RPi was attached to that same switch which was in turn attached to another upstream switch. It was visible on the network.

I will purchase another cable and report back.

Re: Raspberry Pi B invisible when attached to unmanaged switch

Posted: Sun Mar 31, 2019 8:03 pm
by B.Goode
- the switch negotiates speeds etc so this means that it is not dumb, just unmanaged. My error.

No, unmanaged is what you originally said.. My lack of clarity in replying.

I meant to point out - as you are confirming - that although the switch is unmanaged it still has a lot of automatic intelligence for things like negotiation and power saving.

previously the RPi was attached to that same switch which was in turn attached to another upstream switch. It was visible on the network.

That's more interesting...

To me that suggests maybe the problem is between the trunk ('upload') port of the switch and the modem? Because the RPi-to-switch connection is apparently unchanged?

Can you provide a short word portrait of the layout/interconnect of your LAN infrastructure? Both as it was when working, and as it is now.

Re: Raspberry Pi B invisible when attached to unmanaged switch

Posted: Mon Apr 01, 2019 5:14 am
by peewee44
Thanks so much for suggestions.

I did two things.

I changed the cable and restarted the modem and switch and all is well now.