didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

impossible place Keyboard in AZERTI

Tue Mar 05, 2019 4:07 pm

Hello world i'm new user on Raspberry PI3b and i'm impossible place my keyboard on AZERTY.
I have make the commands below:

sudo nano /etc/default/keyboard
XKBLAYOUT=“be”
sudo dpkg-reconfigure locales

my choice is fr_BE.UTF-8
sudo dpkg-reconfigure tzdata
Rebooter

I noticed that when I do sudo apt-get upgrade I get the following message:

wpasupplicant (2:2.6-19) unstable; urgency=medium
With this release, wpasupplicant no longer respects the system
default minimum TLS version, defaulting to TLSv1.0, not TLSv1.2. If
you're sure you will never connect to EAP networks requiring anything less
than 1.2, add this to your wpasupplicant configuration:

tls_disable_tlsv1_0=1
tls_disable_tlsv1_1=1

wpasupplicant also defaults to a security level 1, instead of the system
default 2. Should you need to change that, change this setting in your
wpasupplicant configuration:

[email protected]=2

Unlike wpasupplicant, hostapd still respects system defaults.

-- Andrej Shadura <[email protected]> Sat, 15 Dec 2018 14:22:18 +0100

Can someone help me please? :roll:

User avatar
scruss
Posts: 2420
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: impossible place Keyboard in AZERTI

Tue Mar 05, 2019 4:33 pm

did you try sudo raspi-config, then option 4 (Localisation Options), then Change keyboard layout?

Are you using a regular USB keyboard? Some keyboards aren't recognized by dpkg-reconfigure keyboard-configuration
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

Re: impossible place Keyboard in AZERTI

Tue Mar 05, 2019 5:26 pm

no keyboard is connected to itI order it from my pc under windows 10 with the remote desktop connection and in addition to Raspbian there is octoprint for my 3D printer

User avatar
scruss
Posts: 2420
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: impossible place Keyboard in AZERTI

Tue Mar 05, 2019 10:38 pm

So if there's no keyboard connected, why are you trying to set the keyboard language?

Use raspi-config, and set the locale via that. Setting the keyboard does nothing for the language locale. Most of us in Canada use US keyboards but en_CA.UTF-8 or fr_CA.UTF-8. The actual CA keyboards are maddeningly weird for just about everyone and their QWERTY and AZERTY variants are special.

Your other messages from wpa_supplicant could be related to setting wifi country, also settable by raspi-config under Localisation.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 5:42 am

Thank you for your answer, I'm just trying to change because whatever I do with my Raspberry remote control I do not know how to encode the text I want because of this keyboard QWERTY for example when I'm in the terminal if i want to write "sudo apt-get update" i have "sudo qpt-get updqte" and that's the case in all Raspberry applications such as open office for example.
I also noticed that if I want to start "Raspberry configuration" via the "preference" menu or the "recommended software" application they do not start.
I think I'll have to do a new installation of raspbian on the micro SD card to get out of this problem I'm bored because I'll have to reinstall everything, NAS, octoprint and many more ...
What do you think? :?:

kaksi
Posts: 92
Joined: Tue Mar 10, 2015 6:19 am

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 9:34 am

The full content of my sudo nano /etc/default/keyboard:

Code: Select all

XKBMODEL=pc105
XKBLAYOUT=ch
XKBVARIANT=
XKBOPTIONS=
BACKSPACE=guess
Even if it is in Swiss German, it is usable. What about starting just with fr?

May depend on you OS, on RPI2, I had to adapt the line to:

Code: Select all

set XKBLAYOUT="ch"

didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 12:38 pm

Thank you but after trying all the commands given above nothing to do I stay in qwerty even with the choice of a Swiss keyboard. :roll:

klricks
Posts: 6550
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 1:33 pm

didiersee wrote:
Wed Mar 06, 2019 12:38 pm
Thank you but after trying all the commands given above nothing to do I stay in qwerty even with the choice of a Swiss keyboard. :roll:
As mentioned..... keyboard settings on the RPi are for the local physically attached keyboard only and have no effect on a remote keyboard.
Ask Google.......
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

User avatar
scruss
Posts: 2420
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 3:47 pm

Yes, it's remote desktop connection on your desktop machine that's not sending the right key events. Can you use VNC? The commercial server comes free with Raspbian and it gives a reliable desktop.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 5:41 pm

I connect with Putty and it's exactly the same problem.

didiersee
Posts: 7
Joined: Sat Mar 24, 2018 6:03 am

Re: impossible place Keyboard in AZERTI

Wed Mar 06, 2019 10:39 pm

Ohhhh congratulations thank you very mutch. It's ok with VNC and with commands XKBLAYOUT=“be” / sudo dpkg-reconfigure locales (my choice is fr_BE.UTF-8) / sudo dpkg-reconfigure tzdata
Rebooter.
All is ok but if I reconnect with VNC the keyboard is memory in azerty but not with the remote desktop windows 10. Is there a solution for windows?
Thank you. You are the best ;)

Return to “General discussion”