Page 1 of 1

Old transmission client?

Posted: Mon Nov 12, 2012 7:33 am
by Picanto
I was wondering why the Raspberry Pi is only getting the Transmission 2.52 version and not the latest 2.73 version of Transmission?

I have to say i'm an total linux n00b, but i can't figure out why only 2.52 is downloaded when using the ''apt-get install transmission-daemon'' command.

Re: Old transmission client?

Posted: Mon Nov 12, 2012 9:30 am
by itimpi
Picanto wrote:I was wondering why the Raspberry Pi is only getting the Transmission 2.52 version and not the latest 2.73 version of Transmission?

I have to say i'm an total linux n00b, but i can't figure out why only 2.52 is downloaded when using the ''apt-get install transmission-daemon'' command.
I expect that is because that is the version that Debian have currently accepted into the Wheezy release (as Raspbian is based on Wheezy). The alternative might be because there have been problems building a later version for the Pi so an earlier version has been used until this can be resolved.

It is not at all unusual in the Linux world for individual packages to be quite a few releases ahead of the versions that have been accepted into distributions. The (possibly optimistic) assumption is that if users want the latest version they can always download the source and build it for themselves

Re: Old transmission client?

Posted: Mon Nov 12, 2012 9:35 am
by Picanto
I wonder if the latest version has some incompatibility errors with the Raspberry Pi or something. If not, i'd be more then willing to learn how to install the latest version on the Raspberry Pi.

Re: Old transmission client?

Posted: Mon Nov 12, 2012 10:40 am
by lewmur
Picanto wrote:I was wondering why the Raspberry Pi is only getting the Transmission 2.52 version and not the latest 2.73 version of Transmission?

I have to say i'm an total linux n00b, but i can't figure out why only 2.52 is downloaded when using the ''apt-get install transmission-daemon'' command.
Probably because the latest version hasn't been converted to run on the ARM processor or just that the earlier version is more stable. If you google "Transmisssion 2.52" you'll see several post from people having problems with later versions.

Re: Old transmission client?

Posted: Mon Nov 12, 2012 11:10 am
by Picanto
lewmur wrote:
Picanto wrote:I was wondering why the Raspberry Pi is only getting the Transmission 2.52 version and not the latest 2.73 version of Transmission?

I have to say i'm an total linux n00b, but i can't figure out why only 2.52 is downloaded when using the ''apt-get install transmission-daemon'' command.
Probably because the latest version hasn't been converted to run on the ARM processor or just that the earlier version is more stable. If you google "Transmisssion 2.52" you'll see several post from people having problems with later versions.
When i googled ''Raspberry Pi Transmission 2.52'' i found this -> http://archlinuxarm.org/forum/viewtopic.php?f=15&t=3990

So it seems possible for people to run it properly, just some non-issue with a whitelist (which i don't intent to use btw).