Page 1 of 2

Cannot Search Forum

Posted: Sun Oct 28, 2018 5:18 pm
by micksulley
I can no longer search the forum. The search icon in the top bar is there, but that searches the main site not the forum. There used to be a search box just to the right on 'New Topic' from memory, but it is no longer there and I cannot search the forum at all.

What is going on?

Re: Cannot Search Forum

Posted: Sun Oct 28, 2018 5:21 pm
by DougieLawson

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 2:02 am
by HawaiianPi
Forum search has always been crap anyway.

Search from google with site:raspberrypi.org/forums after your search term.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 7:00 am
by hansotten
Search is back!

Thanks maintainers of the forum, fighting the bad guys!

While searching the forum is not that good for a general search, google is indeed better, the Menu options e.g. Newposts is very useful and appreciated.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 10:24 am
by Burngate
Yeah, thanx to everyone!

I generally use the unread posts button. When it went missing, it was like clotted cream - you don't know you're hooked on it until the shop stops selling it!

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 10:34 am
by DougieLawson
It's always available https://www.cupcakeproject.com/clotted- ... g-clotted/
Unlike the "unread posts" forum search which is patchy in the extreme.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 10:56 am
by BlackKnight_UK
DougieLawson wrote:
Mon Oct 29, 2018 10:34 am
It's always available https://www.cupcakeproject.com/clotted- ... g-clotted/
Unlike the "unread posts" forum search which is patchy in the extreme.
:lol:

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:05 am
by jamesh
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:08 am
by DougieLawson
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
It's completely borken for me. Gives me the banal
Information

Sorry but you cannot use search at this time. The server has high load. Please try again later.
message every time.

I'm off to Tesco to get some clotted cream, as that may be more useful.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:09 am
by DirkS
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
Same here. It did work occasionally earlier this morning but the last hour or so it just results in error messages.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:22 am
by RaTTuS
yes still off for me ....

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:26 am
by pcmanbob
Still non of the search options work for me.

Your posts :cry:
New posts :cry:
Unread posts :cry:
unanswered topics :cry:
Active topics :cry:

going back to re-upholstering my chair at least I will have something comfy to sit on if the forum ever recovers. :lol:

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:32 am
by B.Goode
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
I think a lot of us assumed, perhaps wrongly, that the Raspberry Pi Foundation were well aware that all the variants of 'search' were 'broken' - possibly by some technical issue, or maybe by load factors caused by Bad Boys doing Naughty Things.

So yes, for me mid-morning UK local time, all the actions under search.php?search_id= fail with
Information
Sorry but you cannot use search at this time. The server has high load. Please try again later.
So specifically that's Your Posts, new posts, unanswered, unread, active..

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:37 am
by jamesh
B.Goode wrote:
Mon Oct 29, 2018 11:32 am
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
I think a lot of us assumed, perhaps wrongly, that the Raspberry Pi Foundation were well aware that all the variants of 'search' were 'broken' - possibly by some technical issue, or maybe by load factors caused by Bad Boys doing Naughty Things.

So yes, for me mid-morning UK local time, all the actions under search.php?search_id= fail with
Information
Sorry but you cannot use search at this time. The server has high load. Please try again later.
So specifically that's Your Posts, new posts, unanswered, unread, active..
We are certainly aware, and it was working OK this morning, I just wanted to checked it wasn't just me for whom it went wrong again.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:48 am
by RaTTuS

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 11:58 am
by hippy
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
egosearch and similar were working late last night but were again unavailable this morning, and still are.

Please thank the team for changing the (paraphrased) "you do not have permission" message to "currently unavailable because of heavy load". Much more informative and less confusing.

Added: Though, having just read RaTTuS's link, perhaps not. Are they actually unavailable because of heavy load / DDoS or a result of the upgrade ?

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 12:05 pm
by grega
Forum search has been hit particularly hard over the last 3 days so we've enabled some temporary limits to try to keep the forums up and accessible to as many people as possible.

These limits mean that, for now, many people will see issues when using functionality that relies on the search backend (eg. "New Posts"). The limits are based on current load; if they're triggering then it's to prevent the forum from becoming inaccessible to all.

We'll post further updates as and when more info becomes available, and of course it goes without saying that we'd like to lift these limits as soon as possible.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 3:46 pm
by pcmanbob
Out of interest just how many people can be viewing this forum before it causes a problem.

Considering that there are 245461 registered users and 14000,000 pi have been sold yet just 1431 users viewing the forum seems to cause a problem !

That's not many considering the potential viewers if say just 1% of the people who have purchased a pi decided to visit.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 3:57 pm
by PhatFil
jamesh wrote:
Mon Oct 29, 2018 11:37 am
B.Goode wrote:
Mon Oct 29, 2018 11:32 am
jamesh wrote:
Mon Oct 29, 2018 11:05 am
Is anyone still seeing problems with New Posts - I cannot get it to work, wondering if others are seeing the same thing.
I think a lot of us assumed, perhaps wrongly, that the Raspberry Pi Foundation were well aware that all the variants of 'search' were 'broken' - possibly by some technical issue, or maybe by load factors caused by Bad Boys doing Naughty Things.

So yes, for me mid-morning UK local time, all the actions under search.php?search_id= fail with
Information
Sorry but you cannot use search at this time. The server has high load. Please try again later.
So specifically that's Your Posts, new posts, unanswered, unread, active..
We are certainly aware, and it was working OK this morning, I just wanted to checked it wasn't just me for whom it went wrong again.
FYI this has been OFF from my end since yesterday, today the 'Hamburger' is back but the links lead nowhere..

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 4:05 pm
by jamesh
Indeed. Still trying to get to the bottom of it. A particularly agressive web crawler kicked things off Friday, and its proving very difficult to get the levels back down again. Clearly something awry somewhere, both the service provider and our internal webteam are working the problem.

Apologies for the problems, and fingers crossed we get somehere soon.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 4:07 pm
by jamesh
pcmanbob wrote:
Mon Oct 29, 2018 3:46 pm
Out of interest just how many people can be viewing this forum before it causes a problem.

Considering that there are 245461 registered users and 14000,000 pi have been sold yet just 1431 users viewing the forum seems to cause a problem !

That's not many considering the potential viewers if say just 1% of the people who have purchased a pi decided to visit.
AIUI, the main problem is the huge size of the backend database, so even one person doing a search takes quite a lot of server time. So when you have 1300 people (crawlers I suspect taking up a large proportion of that) all doing searches at the same time, things start to grind to a halt.

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 7:26 pm
by bensimmo
It's currently on and off for me (just Ego and Active Topics)
I got here with ego, but a bit earlier is was off again.

( If memory serves, Active topics uses less 'power' than New Topics, this is from a similar phpbb forum, Active would always work when New Post would fail due to load, also there we put a restriction in place for time between searches, number in succession or something like that)

Re: Cannot Search Forum

Posted: Mon Oct 29, 2018 7:53 pm
by DirkS
bensimmo wrote:
Mon Oct 29, 2018 7:26 pm
It's currently on and off for me (just Ego and Active Topics)
I got here with ego, but a bit earlier is was off again.
It's been working without problems for the last 1 - 1.5 hours now.
It's actually very quick, including unanswered topics which was quite slow in the past.

The only bit that seems to be switched off is the detail information at the bottom of the main page (users logged in, etc).
That doesn't bother me in the least, though.

Re: Cannot Search Forum

Posted: Tue Oct 30, 2018 10:45 am
by jamesh
Hello all,

You will hopefully have noticed that the forums is now behaving itself. The eagle eyed amongst you will have noticed that the "Number of users online" section at the bottom of the index page has disapeared. It appears we have been suffering from this https://www.phpbb.com/community/viewtopic.php?t=2124014 issue which was soaking up >80% of the forum server performance just to work out the number of users online.

Not sure if a blog post fully explaining things will appear, but for now, we* have hacked phpbb to get rid of the problem, so the forum should be a LOT faster, and now capable of about 10 times the throughput prior to the issue appearing.

Interesting that this phpbb issue was reported in 2011. And has never been fixed.


*we != me. This is way out of my area of expertise.

Re: Cannot Search Forum

Posted: Tue Oct 30, 2018 11:22 am
by pcmanbob
Well done jamesh for finding a fix and restoring the forum to a usable state.