jdb2
Posts: 8
Joined: Wed Sep 07, 2016 10:00 pm

RPi USB audio woes revisited...

Sat Aug 18, 2018 7:10 pm

Well, it's been a while since I last posted about this problem -- see here : https://www.raspberrypi.org/forums/view ... p?t=159261 . My problem is that, when playing audio files from my Raspberry Pi 3 Model B+ over USB to my Schiit Modi 2 Uber DAC, I experience popping noises and other hiccups. I had bought a Schiit Wyrd through which I'm feeding the USB input of my Schiit Modi 2 Uber, along with two AudioQuest JitterBugs. For a while, this setup worked, and I experienced popping only very infrequently, but, when I set up my new RPi 3 Model B+, the popping and stuttering returned and it was worse than before.

My current audio setup it RPi->Schiit Wyrd->->AudioQuest JitterBug->Schiit Modi 2 Uber DAC->Nano Patch passive volume control->M-Audio BX8 DB2 studio monitor speakers. I've tested playing mp3s and also FLAC and ALAC files with JRiver Media Center 24 and also just mplayer and I experience the same problems in each.

If I stream over DLNA from my RPi to my Sony blu-ray player and then to my Schiit Modi 2 Uber via coax S/PDIF, then I hear no popping -- I get the same result if I listen to a CD on my blu-ray player. So, the problem is with the RPi.

I'm running the latest and greatest version of Raspbian along with the latest firmware from rpi-update.

This problem first presented itself to me way back in 2014 or so after I was using the plain old RPi B+. After an OS update, I started experiencing popping and other distortion over USB to my Schiit Modi 2 Uber DAC, when the audio had been glitch free for months, at least. I don't know what the problem is but one would think that the RPi wouldn't have this problem anymore...

Any help or suggestions would be appreciated...

Thanks,

jdb2

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: RPi USB audio woes revisited...

Sat Aug 18, 2018 10:36 pm

I experienced that pops and crackles, first on my RPi3B, even when using the on-board TRRS jack, then using Sound Blaster USB sound dongle. to the point I converted my sound output device to an I2S DAC. but even so, whenever I plug in a particular VU meter module, the pops and crackles reappear.

Inserting a Ground Loop Isolator / Noise Filter immediately after RPi's audio output and the next device removed (or silenced) the pops and crackles.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

jdb2
Posts: 8
Joined: Wed Sep 07, 2016 10:00 pm

Re: RPi USB audio woes revisited...

Mon Aug 20, 2018 6:50 pm

Thanks for the suggestion! :)

I put an ancient EBTECH Hum eliminator / ground-loop-isolator in my audio path just after the passive volume control, and, it seems to completely get rid of the popping. Now the problem is that I'm experienced an irritating hum and some distortion, even with a hum eliminator :( I don't know if the hum eliminator is faulty or not -- I think that there may be some grounding problem somewhere and I'll have to go through my mess of wires to get to it.

jdb2

User avatar
r3d4
Posts: 940
Joined: Sat Jul 30, 2011 8:21 am
Location: ./

Re: RPi USB audio woes revisited...

Tue Aug 21, 2018 6:24 am

how do you power the usb dac ?

jdb2
Posts: 8
Joined: Wed Sep 07, 2016 10:00 pm

Re: RPi USB audio woes revisited...

Tue Aug 21, 2018 6:47 pm

Everything's plugged into an APC Back-UPS 1300VA UPS, including the RPi and the Schiit Modi 2 Uber.

jdb2

Return to “General discussion”