User avatar
bugsy_malone 666
Posts: 289
Joined: Mon Dec 17, 2012 10:50 pm
Location: Basingstoke UK

I think I might have broken my B+ USB everything..

Mon Mar 26, 2018 11:57 am

So Lastnight I was working on a project on my B+ which has had a slight suspect usb power port, which I found only 1 good short USB cable that would work on the PI (all the rest I had just didnt seem to power the PI properly) that was about 4" long from a Nokia. For my project I built a GPIO plug in PCB which has power Jack and connections to I2C and some other stuff for my project, meaning I no longer needed the USB power. My mistake was leaving the USB cable plugged in.

So I set it updating and maybe 3/4 way through its process I moved the thing slightly and it seems the outside of the little USB cable plug shorted out some of the pins on the network socket.

I was running headless and it looked like the Pi had Frozen so I did a full power reset, from which point I can no longer see it on the network (I had been using a WiFi Dongle) Havent tried a network cable yet or plugging it in to a monitor to see what it actually does, but I know it still runs as I have a python program that runs at start up and displays the time on a little display, which is still working.

So I wondered how quickly you could break the network/USB hub? I did wonder if because my PI hasnt had a full update for a while if it might have just switched SSH off as I know that was a new thing.

Also does anyone have any direct pin connection point diagrams for the points on the underside so I can maybe solder in a little multifunction hub direct if the one on board is toast?

wes1977
Posts: 3
Joined: Thu Mar 15, 2018 12:14 pm

Re: I think I might have broken my B+ USB everything..

Mon Mar 26, 2018 2:20 pm

Not that it helps, but mine is broken the same exact way. None of my USB ports work. I got sloppy and let a metal piece short something out on the board. For some reason I don't trust this Pi anymore on the ethernet port.

User avatar
bugsy_malone 666
Posts: 289
Joined: Mon Dec 17, 2012 10:50 pm
Location: Basingstoke UK

Re: I think I might have broken my B+ USB everything..

Tue Mar 27, 2018 7:22 am

I saw on Ebay someone selling about 4 Pi's, some with dead ethernet, some with dead USB, indicating that it wasnt both.

I think I shall rename my B+ 'Zero' for zero connectivity lol.

I cant find my other Raspberry Pi at the minute as we have packed alot of our house ready to move, so not sure if its in a box in the loft or storage, so I cant even just swap over to another Pi to test if it is the ports.

I guess based on worst case scenario I was wonder about where the direct USB connection off the main chip is so I could put in some sort of single USB connection.

I wondered if the connection test points underneath are the same between RPi A+ and B+? on the A+ it seems there are points PP22 and PP23 to the USB port on the B+ they are in a slight different place and connect to the network port lights I think?

Image
Image

Dont know if there is an official connection layout somewhere?

fruitoftheloom
Posts: 20143
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: I think I might have broken my B+ USB everything..

Tue Mar 27, 2018 8:03 am

bugsy_malone 666 wrote:
Tue Mar 27, 2018 7:22 am
I saw on Ebay someone selling about 4 Pi's, some with dead ethernet, some with dead USB, indicating that it wasnt both.

I think I shall rename my B+ 'Zero' for zero connectivity lol.

I cant find my other Raspberry Pi at the minute as we have packed alot of our house ready to move, so not sure if its in a box in the loft or storage, so I cant even just swap over to another Pi to test if it is the ports.

I guess based on worst case scenario I was wonder about where the direct USB connection off the main chip is so I could put in some sort of single USB connection.

I wondered if the connection test points underneath are the same between RPi A+ and B+? on the A+ it seems there are points PP22 and PP23 to the USB port on the B+ they are in a slight different place and connect to the network port lights I think?

Image
Image

Dont know if there is an official connection layout somewhere?

The A+ has a single USB BUS bought out to the single USB Port.

The B+ has a single USB BUS bought out to a USB Hub / Ethernet Lan9514 Chipset:

http://www.microchip.com/wwwproducts/en/LAN9514
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

User avatar
bugsy_malone 666
Posts: 289
Joined: Mon Dec 17, 2012 10:50 pm
Location: Basingstoke UK

Re: I think I might have broken my B+ USB everything..

Tue Mar 27, 2018 9:16 am

I get that, I guess I was wondering about if there are test points the Same as the A+ on the B+ that are before the hub chip.

I have also seen something online that suggests sometimes the power to the USB can fail on the B+ which means the devices dont work, going to see if I can look in to that tonight

User avatar
DougieLawson
Posts: 35542
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: I think I might have broken my B+ USB everything..

Tue Mar 27, 2018 10:52 pm

There's a picture of the underside of MY A+ in https://www.raspberrypi.org/magpi-issues/MagPi29.pdf on page15.

Come along to the Roebuck PH, Stockbridge Road, Winchester at 20:00 on Wed 11th April and we can chat about your wonky B+.
Note: Having anything remotely humorous in your signature is completely banned on this forum. Wear a tinfoil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Return to “General discussion”