Page 1 of 1

3B+ Power LED regular flashing sequence, no Green activity LED [solved]

Posted: Sat Mar 17, 2018 6:34 pm
by rlm
Hi all,

Short:
Regular and continuous sequence of red power LED flashes, no green activity LED.

Long:
Just tried powering up a 3B+ using three different wall plug PSUs (5v, 2 - 2.5a) and a Manson HCS-3202 bench PSU.
With all of them, the red power LED continuously goes through a sequence of four long and three short (might be 4 and 4, not sure) flashes.
The green activity LED never lights. These PSU's all properly power other Raspberry Pi 3's (and their LCD panels) that I have.
All PSU's have been checked against a meter and seem to be operating correctly (good V and A, within tolerance with dummy load).

I know from previous postings that a flashing power (red) LED is usually down to a problematic PSU. But those never refer to a regular sequence of flashes. Is this something new to the 3B+? I can't find any documentation on-line for it, if it is new.

In this case I don't think the issue is a problematic PSU, could be wrong but I don't think so.

Any ideas?

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Mar 18, 2018 2:40 am
by DougieLawson
If the red LED flashes it's either a useless PSU or a useless cable between the PSU and you RPi3B+ (or both).

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Mar 18, 2018 9:03 am
by davidcoton
Have you measured the 5V supply at the Pi? (Measure carefully at the GPIO connector 5V and Ground pins (see here).
Even that may not be conclusive -- checking with an oscilloscope will spot shorter blips than a meter can detect.

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Mar 18, 2018 12:42 pm
by HawaiianPi
rlm wrote:
Sat Mar 17, 2018 6:34 pm
Hi all,

Short:
Regular and continuous sequence of red power LED flashes, no green activity LED.
That does sound like some kind of error code indicator. I've seen the green activity LED do that during certain errors with the µSD card, but I've never heard of that with the power LED. Hopefully one of our helpful RPF engineers will chime in and offer some insight.

Do you know the wire gauge used in your power cables? Many µUSB cables have too much resistance to deliver much more that 500mA (0.5A) without significant voltage drop (due to thin internal wires).

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Mar 18, 2018 12:52 pm
by joan
Have you written a recent image (2018-03-13) of Raspbian to the SD card?

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Mar 18, 2018 9:07 pm
by rlm
Thanks for the suggestion to try an updated O/S. It wasn't the O/S per se, but using a new micro SD card that did the trick. There is something odd with the SD cards I was using. Could read/write them and use to boot an RPi3, just not boot an RPi3B+. Using one of the new SD cards with an older version of the O/S also worked with the RPi3B+. All the SD cards I use are Cat10 and from reputable makers (Toshiba, SanDisk, etc.). Anyhoo all fixed now! :)

USB leads all checked out and within power loss tolerances.
GPIO ground, 5V and 3.3V pins all checked out.

Thanks again.

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Mon Mar 19, 2018 5:52 pm
by Burngate
HawaiianPi wrote:
Sun Mar 18, 2018 12:42 pm
rlm wrote:
Sat Mar 17, 2018 6:34 pm
Regular and continuous sequence of red power LED flashes, no green activity LED.
That does sound like some kind of error code indicator. I've seen the green activity LED do that during certain errors with the µSD card, but I've never heard of that with the power LED. Hopefully one of our helpful RPF engineers will chime in and offer some insight.
It's interesting that the schematic for the 3B has the POWER OK "PWR" LED fed from an APX803-46SAG chip, and the signal goes to PWR_LOW_N. On the 3B+ schematic that chip isn't mentioned, instead we have it fed by a signal called STATUS_LED_R (the green LED is now fed by STATUS_LED_G)

EDIT: viewtopic.php?f=72&t=208381

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Mon Mar 19, 2018 6:56 pm
by wildfire
rlm wrote:
Sun Mar 18, 2018 9:07 pm
Using one of the new SD cards with an older version of the O/S also worked with the RPi3B+.
Curious, Which older version?

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sat Apr 07, 2018 11:54 pm
by posthuman_1000
rlm wrote:
Sun Mar 18, 2018 9:07 pm
Thanks for the suggestion to try an updated O/S. It wasn't the O/S per se, but using a new micro SD card that did the trick. There is something odd with the SD cards I was using. Could read/write them and use to boot an RPi3, just not boot an RPi3B+. Using one of the new SD cards with an older version of the O/S also worked with the RPi3B+. All the SD cards I use are Cat10 and from reputable makers (Toshiba, SanDisk, etc.). Anyhoo all fixed now! :)

USB leads all checked out and within power loss tolerances.
GPIO ground, 5V and 3.3V pins all checked out.

Thanks again.
I've just come across this same issue with my new Pi 3+ - using a SanDisk Ultra 8g C10.

What card did you switch to? Sounds like I'm going to need to order a new one

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Apr 08, 2018 12:11 am
by mahjongg
This is another thread about using software that is NOT compatible with the 3B+, the blue lightening symbol, and the pattern blinking LED"S are the signs that indicate this.


Its NOT normally a power issue, although as always, that may be a secondary problem.
Read the boot problem sticky:

Re: 3B+ Power LED regular flashing sequence, no Green activity LED

Posted: Sun Apr 08, 2018 12:24 am
by posthuman_1000
mahjongg wrote: This is another thread about using software that is NOT compatible with the 3B+
Yes, that's the more likely reason in my case, I should have made that connection myself as I already knew my software wasn't compatible. I'm an idiot. Thanks for helping me understand.

Re: 3B+ Power LED regular flashing sequence, no Green activity LED [solved]

Posted: Tue Apr 10, 2018 4:06 pm
by davidcoton
If you have a working OS installed (up to date Raspbian Stretch), then the red LED is the power indicator and should be constantly ON. If not you probably have a power supply problem.
The green LED is the SDCard activity indicator which will have an apparently random pattern.

If your Pi is not booting, then the red LED may give a pattern indicating that the OS is too old for the Pi3B+.
Or the green LED may give a pattern that helps diagnose particular problems. The patterns are described here.

Re: 3B+ Power LED regular flashing sequence, no Green activity LED [solved]

Posted: Sun Jun 17, 2018 6:12 am
by kevinjjames
Hi,

The below link gives info about which all SD Cards are supported.

https://elinux.org/RPi_SD_cards

Thanks,
Kevin