deep_kap
Posts: 2
Joined: Tue Dec 06, 2016 10:29 am

QT for Raspberry Pi: Display Issue

Mon Jan 22, 2018 6:03 am

Hello,
I'm developing an GUI application with QT on Raspberry Pi.
Below I have attached screenshot of Original GUI , through QT creator RUN command:
Screenshot_2.JPG
Original GUI
Screenshot_2.JPG (54.35 KiB) Viewed 217 times
You can see Tags like Count, P.V. and S.V. and Time Stamp showing correctly.

But when I try to run this QT executable on Power ON, It shows like below:
screenshot_1.JPG
GUI I'm getting while Power ON
screenshot_1.JPG (58.79 KiB) Viewed 217 times
In which Second is not showing Time Stamp and Tags also. Push Button pattern is also changed.

I have write this in /etc/profile, where QT_GPIO is QT executable.
"/home/pi/QT_GPIO/QT_GPIO &"

Why I'm getting this difference in GUI???

QT creator: 3.2.1
QT 5.3.2 - GCC 4.9.2
Raspberry Pi have Raspbian Jessie version 8

procount
Posts: 1149
Joined: Thu Jun 27, 2013 12:32 pm
Location: UK

Re: QT for Raspberry Pi: Display Issue

Mon Jan 22, 2018 9:44 am

I don't know why, but Qt is also used in developing NOOBS, and in their developer notes it states:
Modifying Qt source

Source is in the recovery folder. Be aware that user interface screens will appear larger in Qt Creator then when deployed on the Pi, can raise font sizes 2 points to compensate.

Several constants can be changed in config.h

Wrap code that calls Qt Embedded specific classes (such as QWSServer) between

#ifdef Q_WS_QWS
and

#endif
so that the project also compiles and can be tested under standard Qt.
So I don't think it is anything you've done, but something you must compensate for.
PINN - NOOBS with the extras... https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=142574

Return to “General discussion”

Who is online

Users browsing this forum: allfox, antiriad, FTrevorGowen, timrowledge and 64 guests