Yavor Atanasov
Posts: 3
Joined: Tue May 30, 2017 8:11 am

IQaudio DAC Pro problem

Sat Nov 18, 2017 10:12 pm

Hello guys,
I bought recently DAC Pro and device itself is great - no doubts about that - but after a lot of research I didn't found simple solution for my problem which is the next: I simply didn't find the way to disable all of audio interfaces on my Pi version 3 :-( What i mean: I disabled on-board audio (as suggested by IQ Audio manual and by Gordon himself after I contacted him about that issue):
=============================== My /boot/config
# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
#gpu_mem=64
dtoverlay=vc4-kms-v3d

# IQ-Audio DAC-PRO
dtoverlay=iqaudio-dacplus
========================== End of /boot/config
(I have to say that I already tried to enable or disable i2c_arm module but no luck there) but I simply can't find the solution to disable HDMI sound...
=================== aplay -l here:
**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi [vc4-hdmi], device 0: MAI PCM vc4-hdmi-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
=================== End of aplay -l

DAC Pro is together with HDMI sound (which i never use) and depends how the Pi loads (randomly by my experience) sometimes dac pro is sound card 0 and the other time is card 1. I have asound.conf settled to use my card 0 (or 1)
======================== asound.conf in /etc
pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}
======================== end of asound.conf
(any asound.rc are removed from pi & root acounts home directories too so no conflicts there).
but I really getting tired to change that config file all the time after every reboot because one time hdmi is card 0 and other time is card 0 so this config file basically defeats it's purpose because it never knows which card will be default (meaning which will be one or zero)... I prefer non-modified (vanilla) raspbian but (just for testing purpose) I tested raspbian version by IQ audio which is preconfigured and I noticed that the only card that shows on aplay -l - it is dac pro - no htmi audio there because all other sound hw are disabled. I just want to disable any sound outputs but dac pro...
What Gordon from IQaudio told me is that they simply disabled/un-commented the part of audio in /boot/config (which I did) but still I can't make my pi do load module only for dac pro and disable enything else... Any help Will be highly appreciated

andrum99
Posts: 1291
Joined: Fri Jul 20, 2012 2:41 pm

Re: IQaudio DAC Pro problem

Sat Nov 18, 2017 10:29 pm

The vc4hdmi driver is the audio side of the experimental desktop Open GL driver. It may be possible to disable just the audio driver - for that you will need someone other than me, as I don't know about that. :)

Yavor Atanasov
Posts: 3
Joined: Tue May 30, 2017 8:11 am

Re: IQaudio DAC Pro problem

Sun Nov 26, 2017 11:38 am

Problem solved - I have to disable Full KMS driver and enable Fake KMS driver - now only the hat audio is available and everything works fine.
P.S. andrum99 - Thanks for the hint

Return to “General discussion”