Posts: 71
Joined: Wed Jul 06, 2016 1:36 pm

wrong hash rpd-wallpaper won't download

Sun Sep 24, 2017 5:58 pm

apt reports that rpd-wallpaper has wrong hash and won't download (packages like raspberrypi-ui-mods won't install as it depends on rpd-wallpaper, sadly).

Code: Select all

E: Failed to fetch http://archive.raspberrypi.org/debian/pool/ui/r/rpd-wallpaper/rpd-wallpaper_0.4_all.deb  Hash Sum mismatch
   Hashes of expected file:
    - SHA256:e48df60e3192e4fee37143feb78999b099a42f18ac66603d88f2c532ae85b830
    - SHA1:889b03e412ed01a2744d15ebf5dea7cf81867343 [weak]
    - MD5Sum:1de177c64cb470d250f298ac7aa57a17 [weak]
    - Filesize:27595322 [weak]
   Hashes of received file:
    - SHA256:c2ccc4ddf92bdb7dca373791dbbda35c231b47dc75d422c53fd065830cddd4ae
    - SHA1:3008d11d430b2bd6f04f757b535aca9e03d1dc19 [weak]
    - MD5Sum:dd4e84fd4cfbb0fc4a0d29fc280acd7b [weak]
    - Filesize:25375296 [weak]
   Last modification reported: Thu, 04 May 2017 16:11:01 +0000

tried apt clean autoclean and update with no avail.
weird is that i think other times i tried to install it the received hash differed in filesize section each time. so maybe it is due to my connection? (would be even weirder, for bigger packages will download)

btw apt update and such packages as rpd-wallpaper are pita with slow connection, i know im the minority.

User avatar
Posts: 17958
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: wrong hash rpd-wallpaper won't download

Sun Sep 24, 2017 6:18 pm

The fact that your copy of the file is smaller than the expected size sounds like your download failed.

I just downloaded the file manually and check the size and sha256sum and they match the expected value.

Code: Select all

pi@raspi8:/tmp $ wget http://archive.raspberrypi.org/debian/pool/ui/r/rpd-wallpaper/rpd-wallpaper_0.4_all.deb
--2017-09-24 19:15:49--  http://archive.raspberrypi.org/debian/pool/ui/r/rpd-wallpaper/rpd-wallpaper_0.4_all.deb
Resolving archive.raspberrypi.org (archive.raspberrypi.org)...,,, ...
Connecting to archive.raspberrypi.org (archive.raspberrypi.org)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 27595322 (26M) [application/x-debian-package]
Saving to: ‘rpd-wallpaper_0.4_all.deb’

rpd-wallpaper_0.4_all.de 100%[====================================>]  26.32M  8.65MB/s   in 3.0s   

2017-09-24 19:15:52 (8.65 MB/s) - ‘rpd-wallpaper_0.4_all.deb’ saved [27595322/27595322]

pi@raspi8:/tmp $ sha256sum rpd-wallpaper_0.4_all.deb
e48df60e3192e4fee37143feb78999b099a42f18ac66603d88f2c532ae85b830  rpd-wallpaper_0.4_all.deb
pi@raspi8:/tmp $ ls -l rpd-wallpaper_0.4_all.deb 
-rw-r--r-- 1 pi pi 27595322 May  4 17:11 rpd-wallpaper_0.4_all.deb
Have you got enough space in your file system for the file?

Can you try downloading it manually, like I did, and check the checksum?

If the checksum on your download is correct. move the file into the apt cache and try the install again. It should then use the file you downloaded.

Code: Select all

sudo mv rpd-wallpaper_0.4_all.deb /var/cache/apt/archives

Posts: 71
Joined: Wed Jul 06, 2016 1:36 pm

Re: wrong hash rpd-wallpaper won't download

Sun Sep 24, 2017 6:49 pm

connection might cause the issue and i got around this package with --no-install-recommends and then installing lxsession to get pixel

Return to “General discussion”