ahoang68
Posts: 1
Joined: Thu Jun 15, 2017 7:40 pm

@ symbol and " are mixed up

Thu Jul 06, 2017 7:32 pm

Hi there,
I have a new Raspberry PI3 and try it with 2 different wireless keyboards. I have the same issue. The @ (at symbol) and " (double quote) are mixed up. I wonder if anyone has the same issues or just me.

pcmanbob
Posts: 7983
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 9:05 pm

Hi.

I believe raspbian defaults to a UK keyboard layout may be the keyboards you have are not UK layout and you need to change the keyboard setting in raspi-config.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

pi_everalm
Posts: 33
Joined: Thu Apr 20, 2017 11:44 am

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 10:10 pm

Typically this is seen if you are using a UK physical keyboard but a US logical keyboard mapping

User avatar
davidcoton
Posts: 4546
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 11:05 pm

pi_everalm wrote:Typically this is seen if you are using a UK physical keyboard but a US logical keyboard mapping
or vice-versa.
Signature retired

User avatar
Imperf3kt
Posts: 3246
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 11:14 pm

I have this same issue and it is random. One boot it was switched, then I closed my terminal and reopened it and they weren't.

I've given up trying to set a locale and just keep a text file with ~ in it as I cannot find that on the keyboard at all when it does this.
55:55:44:44:4C
52:4C:52:42:41

User avatar
davidcoton
Posts: 4546
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 11:21 pm

It's not the locale that affects the keyboard mapping, because you might want to use a keyboard that does not match the rest of your locale. IIRC there is a specific selection in raspi-config to let the keyboard driver know the physical layout of your keyboard (which is actually more than locale information anyway).
Signature retired

User avatar
Imperf3kt
Posts: 3246
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: @ symbol and " are mixed up

Thu Jul 06, 2017 11:35 pm

Doesn't explain why the keyboard switches between the two symbols by merely closing a terminal, then opening it again.
55:55:44:44:4C
52:4C:52:42:41

User avatar
davidcoton
Posts: 4546
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: @ symbol and " are mixed up

Fri Jul 07, 2017 12:13 am

Imperf3kt wrote:Doesn't explain why the keyboard switches between the two symbols by merely closing a terminal, then opening it again.
That is not the OP's issue. Your experience is not necessarily related. (OP has not reported random switches, just consistently wrong setting.)
Have you tried to configure the keyboard, not just the locale?
Signature retired

alphanumeric
Posts: 2315
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: @ symbol and " are mixed up

Fri Jul 07, 2017 10:03 am

I have my keyboard set to the correct English US, but when in a terminal window the @ (at symbol) and " (double quote) are swapped. Everywhere else seems fine. This is a recent development for me. Normally setting my keyboard to EN US fixes it and I'm good to go.

SeeGreatness
Posts: 12
Joined: Mon Feb 20, 2017 11:28 pm

Re: @ symbol and " are mixed up

Sat Jul 08, 2017 3:04 pm

have you tryed running

Code: Select all

sudo raspi-config
and then entering localisation
and then change keyboard layout
and just do the "happy hacking keyboard"

pcmanbob
Posts: 7983
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: @ symbol and " are mixed up

Sat Jul 08, 2017 3:56 pm

SeeGreatness wrote:have you tryed running

Code: Select all

sudo raspi-config
and then entering localisation
and then change keyboard layout
and just do the "happy hacking keyboard"

running that on my 2 of my pi's running jessie lite
returns these options
change locale
change timezone
change wifi country

no mention of keyboard in raspi-config that I can find.

one pi has initial build date of 2016-05-10 but has had dis-upgrade run several times
the other has initial build date of 2017-06-21 and never updated as far I remember
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Ernst
Posts: 1273
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: @ symbol and " are mixed up

Sat Jul 08, 2017 4:16 pm

pcmanbob wrote:
SeeGreatness wrote:have you tryed running

Code: Select all

sudo raspi-config
and then entering localisation
and then change keyboard layout
and just do the "happy hacking keyboard"

running that on my 2 of my pi's running jessie lite
returns these options
change locale
change timezone
change wifi country

no mention of keyboard in raspi-config that I can find.

one pi has initial build date of 2016-05-10 but has had dis-upgrade run several times
the other has initial build date of 2017-06-21 and never updated as far I remember
To be able to change the keyboard you have to be working on a local connected keyboard :)
raspi-config will not give you the option if you use ssh to connect to the pi.
The road to insanity is paved with static ip addresses

User avatar
DougieLawson
Posts: 37134
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: @ symbol and " are mixed up

Sat Jul 08, 2017 5:25 pm

Try: sudo dpkg-reconfigure keyboard-configuration in an LXterminal window or from the command line
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

pcmanbob
Posts: 7983
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: @ symbol and " are mixed up

Sat Jul 08, 2017 8:04 pm

Ernst wrote:
To be able to change the keyboard you have to be working on a local connected keyboard :)
raspi-config will not give you the option if you use ssh to connect to the pi.
Thanks for that, must admit 99.9% of the time I connect to my pi's via ssh so its been a long time since I had to change a keyboard layout so things have probably change since the last time, shame the info on raspberry.org does not match the current raspi-config.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

Return to “General discussion”