honda4life
Posts: 75
Joined: Thu Mar 15, 2012 7:27 pm

filesystem corrupted new raspbian image.

Sat Sep 22, 2012 12:54 pm

Hello everyone,

I think there's a problem with the new raspbian distro.
I noticed after first write the image with DD the pi can't mount rootfs. Probably because I forgot to unmount the volumes.
Okay my bad I guess, let's try again.
It now works, doing setup and set overclock to highest settings.
Doing some code compilation etc, no problem at all > overclock seems stable.

Editing iptables and screwed the next restart... okay maybe did something wrong so let's try again.
Same story... again problems after iptables.
Now very carefully... I just finished my whole configururation. And it's time to do some performance tests.
After a short wile the pi hangs again... the OK led is constant on and the SD card has failed.

when rebooting it stops at kdb> with a lot of filesystem troubles above :|

I can start over again, almost a whole day lost, very frustrating :cry:

gstreeter
Posts: 106
Joined: Sun Sep 02, 2012 11:11 am
Location: UK

Re: filesystem corrupted new raspbian image.

Sat Sep 22, 2012 1:20 pm

I've just this morning setup a new SD card from the new Raspian distro image and added lots of packages, compiled code, setup iptables, many reboots etc. None of the issues have occurred which you have experienced.

- did you check the distro download SHA-1 checksum?
- did you try another SD card?
- is your PSU providing sufficient power?
- did you try without overclocking? Jumping in at max may lead to issues which corrupt data.

Seems a little premature to blame the distro.

Return to “General discussion”