Danielgn
Posts: 1
Joined: Fri Mar 17, 2017 8:19 am

Error while upgrade and installing

Fri Mar 17, 2017 8:33 am

Hi everyone, I am having problems with my raspberry pi 3.

When I write:

Code: Select all

sudo dpkg --configure -a

Code: Select all

dpkg: dependency problems prevent configuration of systemd:
 systemd depends on libsystemd0 (= 215-17+deb8u3); however:
  Version of libsystemd0:armhf on system is 215-17+deb8u6.
 systemd depends on udev (>= 208-8); however:
  Package udev is not installed.

dpkg: error processing package systemd (--configure):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.0.2-5) ...
dpkg: dependency problems prevent configuration of bluez:
 bluez depends on udev (>= 170-1); however:
  Package udev is not installed.

dpkg: error processing package bluez (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 systemd
 bluez
so I use:

Code: Select all

sudo apt-get update
sudo apt-get upgrade

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 systemd : Depends: libsystemd0 (= 215-17+deb8u3) but 215-17+deb8u6 is installed
           Recommends: libpam-systemd but it is not installed
 udev : Depends: libudev1 (= 215-17+deb8u3) but 215-17+deb8u6 is installed
E: Unmet dependencies. Try using -f 
Then:

Code: Select all

sudo apt-get -f install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  systemd systemd-sysv udev
Suggested packages:
  systemd-ui
Recommended packages:
  libpam-systemd
The following packages will be upgraded:
  systemd systemd-sysv udev
3 upgraded, 0 newly installed, 0 to remove and 131 not upgraded.
3 not fully installed or removed.
Need to get 3,098 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://mirrordirector.raspbian.org/raspbian/ jessie/main udev armhf 215-17+deb8u6 [850 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ jessie/main systemd armhf 215-17+deb8u6 [2,212 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main systemd-sysv armhf 215-17+deb8u6 [36.3 kB]
Fetched 3,098 kB in 2s (1,129 kB/s)
Preconfiguring packages ...
(Reading database ... 58000 files and directories currently installed.)
Preparing to unpack .../udev_215-17+deb8u6_armhf.deb ...
And it get stopped and take me out from my connection to the raspberry.

Can anyone help me, or give me an advice por it?

Thanks.

tyo100
Posts: 4
Joined: Sat Mar 25, 2017 6:48 am

Re: Error while upgrade and installing

Sat Mar 25, 2017 6:51 am

Same problem, you were able to solve the problem?

tyo100
Posts: 4
Joined: Sat Mar 25, 2017 6:48 am

Re: Error while upgrade and installing

Sat Mar 25, 2017 7:14 am

Go to /var/cache/apt/archives

dpkg --force-all -i systemd-sysv_215-17+deb*.deb

apt-get -f install

and finally

apt-get upgrade

This procedure works for me

Regards :ugeek:

Electron752
Posts: 142
Joined: Mon Mar 02, 2015 7:09 pm

Re: Error while upgrade and installing

Sat Mar 25, 2017 10:38 pm

I would generally avoid running a * patten on the archives directory. Who know what version you're gong to be pickup.

Sometimes the archive gets out of sync as new packages as added, so sometimes it's best to just wait awhile and try again.

tyo100
Posts: 4
Joined: Sat Mar 25, 2017 6:48 am

Re: Error while upgrade and installing

Sun Mar 26, 2017 1:01 am

You are right, my installation is new and only 1 version exists, the latest must be work.


Sorry for my english

Return to “General discussion”