Posts: 232
Joined: Sat Jan 28, 2012 8:07 pm

WiFi channel 13 issues on Zero W

Mon Mar 06, 2017 9:55 pm

When the Raspberry Pi 3 came out, it had some issues with WiFi channel 13. Now it looks like this is repeating with the Zero W for some reason.

I'm seeing some really weird things here with both the 4.4.x and the 4.9.x firmware/kernel branches:

The Zero W won't connect to any WiFi running on channel 13. However, a channel scan does see networks on channel 13! What's even weirder is that it starts to work when I plug in a USB WiFi dongle. Raspbian will still use the internal WiFi in this case, it just looks like plugging in the USB dongle "activates" channel 13 for some reason. And before you ask, the regulatory region is correctly configured.

Does anyone else see something as weird as this?

User avatar
Posts: 33616
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: WiFi channel 13 issues on Zero W

Mon Mar 06, 2017 10:14 pm

Have you set the right country code in /etc/wpa_supplicant/wpa_supplicant.conf?

Channel 12 & 13 are never used in America (it's illegal to do so).
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

Posts: 232
Joined: Sat Jan 28, 2012 8:07 pm

Re: WiFi channel 13 issues on Zero W

Mon Mar 06, 2017 10:37 pm

Of course, like I said, the regulatory region is configured correctly. And if it weren't, even scans for networks on channel 13 wouldn't turn up anything.

Posts: 10
Joined: Fri Mar 10, 2017 1:04 pm

Re: WiFi channel 13 issues on Zero W

Mon Mar 20, 2017 12:49 pm

I have a Pi Zero W, with Rasbian (full) (2017 02 16), and I've had it connect on Channel 13 to the local network, and have been SSHing to it.

Just tried LibreElec, and it didn't appear to identify my access point. I changed to Channel 11, following this thread, and it finally showed. But it could be a signal strength issue. I can't connect to it due to some glitch. Notification flashes: 'network error operation aborted'. I've WIFI issues with another computer running OpenElec, so not sure if this is related or not. I have an old access point.

I tried to stream video to LibreElec using it as an access point, but it didn't really work out for me. I'm starting to suspect I need more power, or an alternative/better power supply. Or I'm expecting too much from the Pi0.

The thing to note is that Rasbian, with credentials added via wpa_passphrase, has worked (with SSH at least).

Posts: 1
Joined: Mon Mar 27, 2017 9:34 pm

Re: WiFi channel 13 issues on Zero W

Mon Mar 27, 2017 9:36 pm

I am having the same issues with pi zero w and channel 13, I did not specify the region in wpa_supplicant.conf and did not check wether this works..
I had to change the channel. FYI I am running dd-wrt on my router

Posts: 1
Joined: Sat May 27, 2017 10:14 am

Re: WiFi channel 13 issues on Zero W

Mon Jul 03, 2017 9:49 am

I've got the same issue,
Scanning shows the network and I've got my country code configured correctly.

It simply doesn't connect on boot.
Latest firmware and packages at time of post.

Posts: 1
Joined: Wed Aug 23, 2017 8:55 pm

Re: WiFi channel 13 issues on Zero W

Wed Aug 23, 2017 9:04 pm

I got the channel 13 working on
Version:August 2017
Release date:2017-08-16
Kernel version:4.9

put the country on somewhere channel 13 is allowed like Japan:
content of file: wpa_supplicant.conf

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 28 guests