Page 1 of 1

ssh Stalls

Posted: Sat Feb 04, 2017 11:08 pm
by bdrmachine
My ssh connection at times stalls. Some times for several minutes. The connection isn't broken but it takes some time before the keyboard is usable. I'm not sure why because there isn't anything running on the pi. Has anyone experienced this? Is there a common fix?


Re: ssh Stalls

Posted: Sun Feb 05, 2017 12:41 am
by CarlRJ
You don't say what model of Raspberry Pi, what, if anything, you have connected to it, whether the ssh connection is going out from the Pi or inbound to it, and what provides the network connection (Ethernet or WiFi? If the latter, Pi3 built-in, or dongle?).

I have seen similar problems, on occasion, that (if I'm not mixing up stories) were caused by ssh'ing into Pi's (model B's and Zeros) that had WiFi dongles (Edimax EW-7811Un, based on the Realtek RTL8188CUS chip) which were "helpfully"going into powersave mode. Turns out there's an option one can put in a configuration file to disable the powersave mode ("options 8192cu rtw_power_mgnt=0 rtw_enusbss=0" placed in /etc/modprobe.d/8192cu.conf) for that particular chip, which made network connections to those machines more reliable/responsive.

But you haven't provided enough information to determine if you're having that problem or something entirely different.

Re: ssh Stalls

Posted: Sun Feb 05, 2017 2:00 pm
by bdrmachine
Sorry I was so brief. My Pi is a 2B. There are no tasks running. As a example: this morning I booted my linux pc and my Pi. They both appeared to come up fine; I have a keyboard and display on the Pi. I tried to ssh connect from my pc and it stalled for 30 seconds after, I typed the Pi password that was requested. Operating the Pi with it's keyboard has no such delay. Here is the command I use to connect "ssh -l pi" I have the Pi set with a static IP. Both my PC and my Pi connect to a Cisco router, hard wired not wifi.

Re: ssh Stalls

Posted: Mon Feb 06, 2017 9:13 pm
by bdrmachine
Has anyone had this problem?

Re: ssh Stalls

Posted: Tue Feb 07, 2017 5:48 pm
by kingosticks
Perhaps you could try to enable verbose mode to see what it is doing (if anything) while unresponsive. Use

Code: Select all

ssh -vvv -l pi