DanDanBu
Posts: 4
Joined: Thu Dec 01, 2016 8:06 am

New release 11-25 video HW acceleration question

Thu Dec 01, 2016 10:03 am

Hi,

I have a question about the latest release Raspbian on 11-25.

2016-11-25:
* Updates to hardware video acceleration in Chromium browser

My current Raspbian version : 2016-11-25-raspbian-jessie

And I open Chromium to enable hardware acceleration by chrome://flags .
flags.png
flags.png (26.91 KiB) Viewed 1662 times
Video Decode is still not support.
decode disable.png
decode disable.png (11.93 KiB) Viewed 1662 times
In chrome://gpu
accelerate.png
accelerate.png (33.36 KiB) Viewed 1662 times
After I enabled, my Chromium become very very slow,
and my cpu almost got 100% while I'm using Chromium.


Is this the right way to open hardware acceleration on Chromium browser?
Or there are other methods to enable it?

Thank you very much.

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: New release 11-25 video HW acceleration question

Thu Dec 01, 2016 12:14 pm

Don't turn that on. It uses software rendering and that's why it's slow. It's enabled out of the box for videos.
There are 10 types of people: those who understand binary and those who don't.

DanDanBu
Posts: 4
Joined: Thu Dec 01, 2016 8:06 am

Re: New release 11-25 video HW acceleration question

Thu Dec 01, 2016 2:56 pm

kusti8 wrote:Don't turn that on. It uses software rendering and that's why it's slow. It's enabled out of the box for videos.
Thank you for your suggestion :)

May I ask you is there a way to check the follow update in 11-25 version??
* Updates to hardware video acceleration in Chromium browser

Thanks again.

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: New release 11-25 video HW acceleration question

Fri Dec 02, 2016 9:51 pm

DanDanBu wrote:
kusti8 wrote:Don't turn that on. It uses software rendering and that's why it's slow. It's enabled out of the box for videos.
Thank you for your suggestion :)

May I ask you is there a way to check the follow update in 11-25 version??
* Updates to hardware video acceleration in Chromium browser

Thanks again.
What does

Code: Select all

apt-cache policy chromium-browser
Say?
There are 10 types of people: those who understand binary and those who don't.

DanDanBu
Posts: 4
Joined: Thu Dec 01, 2016 8:06 am

Re: New release 11-25 video HW acceleration question

Mon Dec 05, 2016 5:25 am

kusti8 wrote:
DanDanBu wrote:
kusti8 wrote:Don't turn that on. It uses software rendering and that's why it's slow. It's enabled out of the box for videos.
Thank you for your suggestion :)

May I ask you is there a way to check the follow update in 11-25 version??
* Updates to hardware video acceleration in Chromium browser

Thanks again.
What does

Code: Select all

apt-cache policy chromium-browser
Say?
Hi,
Thank you for your reply.

It says :

Code: Select all

chromium-browser:
  Installed: 51.0.2704.91-0ubuntu0.14.04.1.7015
  Candidate: 51.0.2704.91-0ubuntu0.14.04.1.7015
  Version table:
 *** 51.0.2704.91-0ubuntu0.14.04.1.7015 0
        500 http://archive.raspberrypi.org/debian/ jessie/main armhf Packages
        100 /var/lib/dpkg/status

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: New release 11-25 video HW acceleration question

Mon Dec 05, 2016 10:36 pm

That's updated. No need to check anything, any HTML5 video (H264) will work out of the box.
There are 10 types of people: those who understand binary and those who don't.

DanDanBu
Posts: 4
Joined: Thu Dec 01, 2016 8:06 am

Re: New release 11-25 video HW acceleration question

Tue Dec 06, 2016 1:39 am

Ok!

Thanks a lot!!

jviyer
Posts: 30
Joined: Mon Nov 04, 2013 3:48 pm

Re: New release 11-25 video HW acceleration question

Fri Dec 09, 2016 12:06 am

I have a rpi3 with jessie. I have chromium-browser installed.
Everything was working fine and then suddenly in the last two days a strange behaviour started happening if I play any *.mp4 file (i.e. I provide a link to the file). The video window starts off right then it keeps shrinking (as if in a special effects) and then boom 5..4..3..2...1 the square/rect window has shrunk to a dot.!
The sound part of the mp4 video file plays correctly.

My packages:

Code: Select all

$apt-show-versions  --allversions | grep chromi
[size=85]chromium-browser:armhf 51.0.2704.91-0ubuntu0.14.04.1.7015 install ok installed
chromium-browser:armhf 51.0.2704.91-0ubuntu0.14.04.1.7015 jessie archive.raspberrypi.org
chromium-browser:armhf/jessie 51.0.2704.91-0ubuntu0.14.04.1.7015 uptodate
rpi-chromium-mods:armhf 20161027 install ok installed
rpi-chromium-mods:armhf 20161027 jessie archive.raspberrypi.org
rpi-chromium-mods:armhf/jessie 20161027 uptodate[/size]
Thanks in advance for any pointers to fix this issue.

Return to “General discussion”