Page 1 of 1

New Pi missing D14

Posted: Mon Sep 03, 2012 3:01 pm
by YellowMonkey
Hi all, first post but been reading for a while.

Just received a new Pi from Farnell and looking at it compared to the pictures posted on this site it seems that I am missing the D14 component on the base of the Pi (near to the HDMI port).

The serial number starts FN1208, I was wondering if this is normal or a production fault? does anyone else have a Pi with D14 missing and will it cause any problems or should I return it for a replacement?

Thanks.

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 3:22 pm
by dom
Check out this thread:
http://www.raspberrypi.org/phpBB3/viewt ... 3&p=160461

D14 can interfere with some CEC devices if the Pi is left plugged in and unpowered. The benefits of having it are minimal so we suggested to RS/Farnel that it was removed.
Looks like you've recieved one of the first with that change.

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 3:32 pm
by YellowMonkey
Hi Dom

I saw that thread when I searched for D14 on the forum but it did not mention that RS/Farnell would be removing that component so I thought I would ask anyway.

Good to know that modifications are still being made to fix small issues.

Many thanks

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 3:47 pm
by Burngate
So now we've got D14 removed as well as F1/F2 replaced by 0R.
Any other changes in the pipeline?

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 4:38 pm
by YellowMonkey
Hi Burngate

Didn't spot the F1/F2 but now you mention it yes they are 0R.. is there a way of telling which revision board you have received without going looking for the component changes? would be good to have a board revision marking like on PC motherboards, I know there is the PCB code 1224 etc. but does this actually refer to the components or just the PCB layout?

Also are these different boards going to introduce some variances which could make some peripherals work on some but not on others? if so this needs to be communicated clearly.

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 4:52 pm
by Burngate
As far as I know (but I know nothing) all the boards should be identical; the screen print varies slightly between suppliers; and there's a label put on by the supplier which seems to be in part a date code. Mine have E2212RSV1.0B1.1 and FN120637146 from RS and Farnell respectively.
Now you know as much as me ;)

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 5:10 pm
by YellowMonkey
It would be great if Eben, Liz or some one else at the RPF could make a sticky topic in the Announcements forum so changes to the board can be communicated to us.

As some of these changes fix known issues it is quite important that we know which version board we have, so if we are having issues such as sticky keys, resets etc. we know what needs to be done to fix them. Even if it does mean getting out the iron and doing some soldering, after all that's half the fun of owning a Pi :)

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 5:28 pm
by dom
YellowMonkey wrote:Didn't spot the F1/F2 but now you mention it yes they are 0R.. is there a way of telling which revision board you have received without going looking for the component changes?
Can you report output of:
cat /proc/cpuinfo

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 6:36 pm
by redhawk
"Didn't spot the F1/F2 but now you mention it yes they are 0R" does that mean they've replaced the polyfuses with 0ohm resistors??

How about F3?? :)

Richard S.

Re: New Pi missing D14

Posted: Mon Sep 03, 2012 6:50 pm
by dom
redhawk wrote:"Didn't spot the F1/F2 but now you mention it yes they are 0R" does that mean they've replaced the polyfuses with 0ohm resistors??

How about F3?? :)
I believe F3 is left the same. The voltage drop caused by F3 is tiny compared to F1/F2, so there was less benefit in changing it.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 6:38 am
by shuckle
Pi without the polyfuses:
$ cat /proc/cpuinfo
Processor : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 0003


and older Pi with the polyfuses:
$ cat /proc/cpuinfo
Processor : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 847.05
Features : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 0002


So it seems the Revision is incremented when there is HW changes?

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 9:02 am
by dom
shuckle wrote: So it seems the Revision is incremented when there is HW changes?
Yes, we had asked for that, but never know for sure until we've checked.
The intention is that hardware changes are indicated in the revision OTP bits.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 10:37 am
by YellowMonkey
My Farnell Pi without D14 and black R0 polyfuses;
---------------------------------------------------------------------
Processor : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 0003

Edit: the new Pi (revision 0003 has a green T075 T3 polyfuse) for those of you who wanted to know

Old RS Pi with D14 and green polyfuses;
--------------------------------------------------------
Processor : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 0002

So this seems the correct way of checking the board revision, good to know.

Shuckle are you overclocking your old Pi? the BogoMIPS score is quite a bit higher than normal..

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 11:06 am
by redhawk
Just out of curiosity do the rev 3 boards still have the LAN overheating problem or will this be fixed in rev 4??

Richard S.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 3:23 pm
by pluggy
redhawk wrote:Just out of curiosity do the rev 3 boards still have the LAN overheating problem or will this be fixed in rev 4??

Richard S.
Its dubious as to whether this is a widespread problem or not. Some people have said it overheats, but I've seen no hard evidence. 56C in an ambient temperature of 28C is the worst I've seen and that corresponds with the readings I get off my rev 2 Pi (48.5C in an ambient of 21C after running continuously for over a week). Typical PC northbridge chipsets run warmer than this with a heatsink. 50C plus usually gives some pain if you stick your finger on it.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 3:26 pm
by dom
redhawk wrote:Just out of curiosity do the rev 3 boards still have the LAN overheating problem or will this be fixed in rev 4??
Rev 3 boards have an unchanged PCB, just with a couple of tweaks to the components fitted, so no fix for LAN overheating.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 3:28 pm
by meltwater
dom wrote:
redhawk wrote:Just out of curiosity do the rev 3 boards still have the LAN overheating problem or will this be fixed in rev 4??
Rev 3 boards have an unchanged PCB, just with a couple of tweaks to the components fitted, so no fix for LAN overheating.
Any chance the details for each rev be listed so they can be added to the wiki. Would be nice to keep a history of the changes and potential fixes for people with issues.

Re: New Pi missing D14

Posted: Tue Sep 04, 2012 4:14 pm
by dom
meltwater wrote:
dom wrote:
redhawk wrote:Just out of curiosity do the rev 3 boards still have the LAN overheating problem or will this be fixed in rev 4??
Rev 3 boards have an unchanged PCB, just with a couple of tweaks to the components fitted, so no fix for LAN overheating.
Any chance the details for each rev be listed so they can be added to the wiki. Would be nice to keep a history of the changes and potential fixes for people with issues.
You've got all the information available now:

Raspberry Pi Model A Revision 1.0 **
Raspberry Pi Model B Revision 1.0 2
Raspberry Pi Model A Revision 1.0 + ECN0001 **
Raspberry Pi Model B Revision 1.0 + ECN0001 3

The model A's never got a board revision number.
ECN0001 is the request to not fit D14 and replace F1 and F2 with 0 ohm.

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 8:58 am
by meltwater
Ok, I've updated the wiki, feel free to correct if I've miss-understood something.
http://elinux.org/RPi_HardwareHistory

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 4:09 pm
by jhornbr225
Hello all, first post, please be gentle.

I'm a complete noob here, I'll admit. I am an Automation Engineer, but have had little to do with any software programming since the early 90's. My realm includes larger horsepower motors and Drives to run them. I do some PLC stuff, but not too much.

To the point:

I attempt to follow the instructions as to get my Pi's board revision. cat/proc/cpuinfo.

I have ssh'ed into my pi. I am currently running Raspbmc, latest version. In fact the Pi is sitting on my desk, happily playing a Pandora feed.

When I try to do the "cat/proc/cpuinfo" command at the "[email protected]:~$" prompt I get:
-bash: cat/proc/cpuinfo: No such file or directory

And If I try "$ cat/proc/cpuinfo" I get:
-bash: $: command not found

I even put in my Wheezy 8-16 SD card and tried, but I got the same result.
What am I doing wrong?

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 5:54 pm
by mahjongg
dom wrote: ECN0001 is the request to not fit D14 and replace F1 and F2 with 0 ohm.
ECN stands for Engineering Change Number.

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 5:58 pm
by inder
I think you are missing a space between cat and /proc/cpuinfo

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 6:04 pm
by thsBavR10
jhornbr225 wrote: When I try to do the "cat/proc/cpuinfo" command at the "[email protected]:~$" prompt I get: -bash: cat/proc/cpuinfo: No such file or directory
What am I doing wrong?
a missing space: cat ist the command, /proc/cpuinfo is the parameter:

Code: Select all

cat /proc/cpuinfo
will do the job.

Re: New Pi missing D14

Posted: Wed Sep 05, 2012 6:59 pm
by jhornbr225
Excellent, Thank you.

Hard to see that little space on a forum such as this. On another forum I frequent (mp3car.com) the forum puts in random spaces. You have to be very careful there in typing in something that someone posted if you need it to be EXACTLY as they typed it. There have been multiple occasions where someone was told to try something, and they come back and say that it does not work, only to find that the forum had put a space in where it didn't belong.

I tried it and it works now! I'm Rev 0002

Thanks again.

Jason

Re: New Pi missing D14

Posted: Thu Sep 06, 2012 8:02 am
by shuckle
YellowMonkey wrote:My Farnell Pi without D14 and black R0 polyfuses;


Shuckle are you overclocking your old Pi? the BogoMIPS score is quite a bit higher than normal..
Yes, my old Pi is "in production" and runs wfrog and is overclocked to
arm_freq=850
sdram_freq=500

It has been on for two weeks, so looks very stabil:
$ uptime
11:01:08 up 16 days, 2:34, 1 user, load average: 0,17, 0,09, 0,07