Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

vnc viewer shows a small screen

Mon Oct 03, 2016 9:46 pm

see attachment.

i would glad for a solution.


https://postimg.org/image/4dsrejq4l/

User avatar
lmarmisa
Posts: 1223
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: vnc viewer shows a small screen

Tue Oct 04, 2016 11:26 am

If your RPi is not connected to any TV or monitor, try this solution:

Code: Select all

sudo /boot/config.txt /boot/config.txt.bak
sudo nano /boot/config.txt
Then modify these lines:

Code: Select all

...
# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=16
...
The new resolution will be 1024x768.

Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

Re: vnc viewer shows a small screen

Tue Oct 04, 2016 1:05 pm

i afraid to do these changes because i don't know how to backup in case of a failure.

i was thinking it is much more simple.

i don't know why this happens

jahboater
Posts: 4595
Joined: Wed Feb 04, 2015 6:38 pm

Re: vnc viewer shows a small screen

Tue Oct 04, 2016 1:48 pm

Fght wrote:i afraid to do these changes because i don't know how to backup in case of a failure.

i was thinking it is much more simple.

i don't know why this happens
You need to learn a little, just a little, which is what the Pi is about.

If you don't have a HDMI monitor plugged in, the Pi cannot ask the monitor what sized screen it is. Instead you need to give the Pi the HDMI details in the config.txt file.

Use the "cd" command to move to the boot directory:

Code: Select all

cd /boot
Then make your backup with the "cp" command:

Code: Select all

sudo cp config.txt config.txt.save
Then if you screw up, you can return the file to its old state with the same cp command in reverse.

Then edit the file with nano as described above.

The last line

Code: Select all

hdmi_mode=58
sets the screen size and the refresh rate. I use 58, you will get scroll bars if its too large. See the documentation
https://www.raspberrypi.org/documentati ... fig-txt.md
See the table a long way down starting with "These values are valid if hdmi_group=2 (DMT):" Choose a value from that table for the mode.
Last edited by jahboater on Tue Oct 04, 2016 6:02 pm, edited 1 time in total.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5000
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: vnc viewer shows a small screen

Tue Oct 04, 2016 2:01 pm

Fght wrote:i afraid to do these changes because i don't know how to backup in case of a failure.
i was thinking it is much more simple.
i don't know why this happens
It happens because
1) Without any HDMI connection the Pi defaults to composite video (RCA) mode ie. SDTV resolution/screensize instead of the "larger" HDTV resolution screensize.
2) and the RealVNC server's default mode is to use the "connected" monitor's (or the unconnected default) screensize. (See also @sconemad's comment in this thread: viewtopic.php?f=91&t=161441 )
Trev.
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my 2xP3A+, P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

User avatar
davidcoton
Posts: 3951
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: vnc viewer shows a small screen

Tue Oct 04, 2016 5:14 pm

Fght wrote:i afraid to do these changes because i don't know how to backup in case of a failure.
Good point. Especially when the post above yours tried to make a backup (to make it easy to undo changes when it went wrong), but there is a typo so there will be no backup. :twisted: :o :shock:

Corrected version (I hope!):
lmarmisa wrote: sudo cp /boot/config.txt /boot/config.txt.bak
sudo nano /boot/config.txt
And to undo any edits:

Code: Select all

sudo cp /boot/config.txt.bak /boot/config.txt
Signature retired

User avatar
DougieLawson
Posts: 35589
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: vnc viewer shows a small screen

Wed Oct 05, 2016 10:09 am

Have you looked at the script that starts vncserver. /usr/bin/vncserver is a perl program (plain text script). In there the screen dimensions are defined (can be overriden with a parameter).

Code: Select all

#
# Global variables.  You may want to configure some of these for your site.
#

$geometry = "1024x768";
$depth = 24;
If you've switched to RealVNC you'll need to do your own investigation.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

Re: vnc viewer shows a small screen

Wed Oct 05, 2016 7:12 pm

I will try to make the backup as you detailed later on...

I was trying to learn it once but it still made a failure to the system...

I appreciate your effort and hope to tell you that I had succeeded later on..

:-)

gideonyuval
Posts: 3
Joined: Wed Oct 05, 2016 12:19 pm

Re: vnc viewer shows a small screen

Wed Oct 05, 2016 7:13 pm

I had the same issue, solved following the instructions at http://elinux.org/RPi_VNC_Server, specifically the line vncserver :0 -geometry 1920x1080 -depth 24

Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

Re: vnc viewer shows a small screen

Wed Oct 05, 2016 10:00 pm

So.
I did followed your instruction (for a change).

But I have the same results :)

check it out...

1: the edited file
2: the small vnc
3: i also can't connect to raspbian often. only after rebooting once again. Putty works just fine by the way.

https://s22.postimg.org/ebm430zdd/Capture1.png
https://s22.postimg.org/tyddged5d/Capture3.png
https://s22.postimg.org/gewjaoz69/Capture.png

jahboater
Posts: 4595
Joined: Wed Feb 04, 2015 6:38 pm

Re: vnc viewer shows a small screen

Wed Oct 05, 2016 10:39 pm

Looks like you missed this bit?

Code: Select all

hdmi_force_hotplug=1

Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

Re: vnc viewer shows a small screen

Thu Oct 06, 2016 12:21 pm

I thought this is not mandatory and doesn't required.
let me try:

works nice!


what about 3? (when i get this error once in two tries)
i mean the vnc connection error

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5000
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: vnc viewer shows a small screen

Thu Oct 06, 2016 12:32 pm

jahboater wrote:Looks like you missed this bit?

Code: Select all

hdmi_force_hotplug=1
Fght wrote:I thought this is not mandatory and doesn't required.
let me try:
works nice!
...
That setting makes a Pi think that an HDMI cable/device is physically connected. It's sometimes also needed with (older) HDMI-to-VGA converters which fail to provide the (electrical) signal. (AFAIK, most, if not all, HDMI/DVI T.V.'s/Monitors do provide such, but the equivalent VGA signal (via DDC "data") isn't always "passed through" especially some basic VGA switches: https://www.cpmspectrepi.uk/raspberry_p ... tches.html )
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my 2xP3A+, P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Fght
Posts: 319
Joined: Thu Feb 05, 2015 10:26 pm

Re: vnc viewer shows a small screen

Thu Oct 06, 2016 8:45 pm

im glad that you explained it.


i would appreciate assistant with the other issue also

:)

jstars
Posts: 6
Joined: Fri Feb 09, 2018 4:07 am

Re: vnc viewer shows a small screen

Mon Jul 23, 2018 4:08 pm

I found this to be my solution. https://youtu.be/LlXx9yVfQ0k

Again, as above, the solution is a modification to /boot/config.txt

Return to “General discussion”