Page 1 of 1

Pi3 wireless problem with phone hotspot

Posted: Wed Jun 29, 2016 4:24 am
by dsc3507
I am having a problem with the Pi3 and wireless connections. I am using arch linux, wpa_supplicant.

First of all let me say that I have absolutely no problem with home wifi wireless connections using either wpa-psk or no password and I understand the wpa_supplicant file.

The problem arises when trying to connect with a cell phone hot spot. The scan sees it, the proper ssid and passphrase are in the wpa_supplicant file but it will not connect.

I get error messages like:

unknown eap method sim
failed to parse eap sim
failed to parse psk
unknown eap IKEV2

This is with an iphone. Here is the edited - pw removed wpa_supplicant file:


The #psk= lines do have the real (correct) passphrase and the created psk= lines are longer.

In the above case the connection to the Buffalo router DOES work as do connections to other routers I have tried. The connection to the iphone does not. Other people have tried iphone and android phones and had the same problem.

If anyone has a working wpa_supplicant for a phone please pass it on - minus passphrase.

Any help or ideas would be appreciated.