Posts: 5
Joined: Thu Jun 09, 2016 11:07 pm

Connecting pi to internet

Thu Jun 16, 2016 4:31 am

Hello Raspberry Pi users
I previously sent an email about using the screen, keyboard and mouse of a laptop instead of having to purchase a monitor, keyboard and mouse.
In the end I decided to just use a mouse, keyboard, and a small TV my neighbour has, by swapping it for some cookbooks for the TV. I had no trouble in loading Raspian using NOOBS. I not only used the version of NOOBS that came with my starter kit, but also downloaded the zip file, which has it, and installed it twice from an SD card. Everything worked well, except connection to the internet. Every time I tried to connect and put www.google.com into the address bar I kept on getting the message 'temporary failure in name resolution'. I switched to my mac and looked this up in google. There were some very technical descriptions of how this might be overcome, with some of the suggested remedies not working ,according to others in the discussions. Does anyone know of a simple, straight forward means by which this problem can be solved?

User avatar
Posts: 5958
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Connecting pi to internet

Thu Jun 16, 2016 5:06 am

It would be helpful to know how you access the Internet.

Who is your provider?

Are you using a router (and which one)?

Wired or wireless?

And anything else you think might be helpful...
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

User avatar
Posts: 17451
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Connecting pi to internet

Thu Jun 16, 2016 5:11 am

It looks like you don't have a connection to the internet.

How are you connecting - wired or wifi, via another computer or direct to a switch or router?

Please start a Terminal session and type in the following commands (some may work, some may not). Then post ALL of the output from the commands (even if they fail). That will help us diagnose the problem.

Code: Select all

ip addr
ip route
cat /etc/resolv.conf
ping -c 1

Return to “General discussion”