W9RAN
Posts: 35
Joined: Wed Feb 08, 2012 10:39 pm

Starting to CLI only

Mon Aug 20, 2012 10:10 pm

Sorry if this is a dumb question but I've looked all over and can't seem to find out how to make the Pi start and run with just a command prompt. It defaults to starting Xorg and running the LXDE desktop - and the script scrolls by so fast I can't see how to abort it or change it so I just get a command prompt.

I want to talk to the board via ssh and will start X manually if I need to.
Thanks, Bob

elatllat
Posts: 1337
Joined: Sat Dec 17, 2011 5:05 pm

Re: Starting to CLI only

Mon Aug 20, 2012 11:05 pm

The official image boots to CLI, you have to type "startx" to start LXDE.
If you are using a Debian variant x is likely started with a service that you can disable with update-rc.d (chkconfig for fedora).
But it totally depend on what distribution you are using.
SBC with 32GB RAM: https://hardkernel.com

FAQ : https://raspberrypi.stackexchange.com

Unanswered: https://www.raspberrypi.org/forums/search.php?search_id=unanswered

W9RAN
Posts: 35
Joined: Wed Feb 08, 2012 10:39 pm

Re: Starting to CLI only

Tue Aug 21, 2012 2:50 am

I am using the standard Wheezy image, and by yet it has started to the LXDE screen from the initial boot. I've never typed "xstart" yet there it is.

Anyhow - I know understand run levels a bit - and learned about rcconf, so I tried that. I can un-toggle x-11 common from the list but it comes right back. Then I tried:
# update-rc.d -f x11-common remove
which should have removed the x11-common script from all run levels, right?

Rebooted -- and it still brings up the stupid raspberry! So what am I missing?

User avatar
alexeames
Forum Moderator
Forum Moderator
Posts: 2869
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
Contact: Website

Re: Starting to CLI only

Tue Aug 21, 2012 7:14 am

Did you make your own SD card? I've made cards with all three Debian distros released so far (Squeeze, Wheezy Beta, Raspbian Wheezy) and they all default to CLI. If you got your SD card preloaded, perhaps something other configuration stuff was added?
Alex Eames RasPi.TV, RasP.iO

james968
Posts: 29
Joined: Tue Jul 17, 2012 8:52 am

Re: Starting to CLI only

Tue Aug 21, 2012 7:44 am

If you have raspbian, you can run 'raspi-config'

If you dont' you can try:

update-rc.d lightdm disable 2

W9RAN
Posts: 35
Joined: Wed Feb 08, 2012 10:39 pm

Re: Starting to CLI only

Tue Aug 21, 2012 4:00 pm

raspi-config did exactly what I was looking for!

Thanks james968!

Return to “General discussion”