sachinwable
Posts: 13
Joined: Fri May 13, 2016 9:17 am
Location: Pune
Contact: Website

Keyboard problem

Sat May 14, 2016 11:22 am

Hi,

I have a brand new logitech keyboard purchased this morning. But when I connect it to my Rpi3, Shift+2 prints " (double quote) instead of "@" and Shift+' (Single quote) prints "@" symbol instead of "(double quote).

All other keys are working as expected and strange thing is keyboard works all good when i connect it to my laptop. I have tried plugging it in different usb port on Rpi3 but it still have that weird behaviour. Is that some bug with my Rpi3? Do you face this problem?

Sachin Wable

User avatar
rpdom
Posts: 15214
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Keyboard problem

Sat May 14, 2016 11:31 am

sachinwable wrote: Is that some bug with my Rpi3? Do you face this problem?
No, and no. Because our keyboards are supposed to have the " character on the 2 key.

It sounds like you are using some weird foreign keyboard (US?), as opposed to the Pi's standard UK layout.

Go into the configuration tool and set your Location, Timezone and Keyboard layout.
(there's one in the desktop menus, or you can use "sudo raspi-config" in a terminal.)

sachinwable
Posts: 13
Joined: Fri May 13, 2016 9:17 am
Location: Pune
Contact: Website

Re: Keyboard problem

Sat May 14, 2016 3:37 pm

But then why it works well when I test it on my laptop with windows os?

Do you mean this has something to do with os configuration?

I have latest noobs rasbian and I have not modified any settings in rasbian. Then?

User avatar
Burngate
Posts: 6012
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: Keyboard problem

Sat May 14, 2016 4:12 pm

Yes, it's in the configuration.

If your keyboard has @ above the 2 and # above the 3, it's probably American.
If you get " and £, your Pi is set to UK.

Have a look in Wikipedia, at https://en.wikipedia.org/wiki/Keyboard_layout

masa-aud
Posts: 144
Joined: Fri Feb 26, 2016 9:20 am

Re: Keyboard problem

Sun May 15, 2016 2:43 am

reply to sachinwable on keyboard
So you can understand that already fixed identification of what KB on BIOS when installing Win 10 of your PC happens just to your new KB, and your Pi wants to identify from now on your new KB with the initial configuration.
OS receives signal of each keystroke as of physical position then recognizes character referring what type of KB from.
masa

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: Keyboard problem

Sun May 15, 2016 3:17 am

To change you keyboard default:

Code: Select all

sudo nano /etc/default/keyboard
XKBLAYOUT="us"
DNPNWO

sachinwable
Posts: 13
Joined: Fri May 13, 2016 9:17 am
Location: Pune
Contact: Website

Re: Keyboard problem

Sun May 15, 2016 5:19 am

Great, Thanks guys you are being very helpful.. setting XKBLAYOUT="us" in /etc/default/keyboard resolved the problem. by default it was XKBLAYOUT="gb"

It required my pi to restart to take effect of this change.. I can type as my KB now.. @@@@@ YAyyyyyyyyyy

Return to “General discussion”