chrisoma
Posts: 4
Joined: Mon Feb 08, 2016 5:52 pm
Location: Mexicali, Mexico

Wine and Mono

Mon Apr 18, 2016 3:07 pm

Hello. I'm trying to use Wine to run an application, but this report that I need to install "Mono for Windows"
I supposedly did it but now I'm not sure how to call it correctly.
i.e Normally I use this command 'wine application.exe'

But as it requested to use Mono for Windows I'm not sure if this should change to 'mono application.exe' or 'wine mono application.exe'

Anyway I tried both and none of them works...

Any idea about the right way, just to confirm the correct path to follow....

Thanks

hal8000
Posts: 187
Joined: Fri Oct 04, 2013 5:22 pm

Re: Wine and Mono

Mon Apr 18, 2016 8:05 pm

You ideally need to state the name of the program you are trying to run
and paste the error message from the terminal/

have a look at the Wine DB to see if anyone has your app working:
https://appdb.winehq.org/

ghans
Posts: 7882
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Wine and Mono

Tue Apr 19, 2016 5:35 am

Why are you using Wine AND Mono ? Usually Mono
should be enough IF the app is pure .NET code.
Also , when you're at it why Mono instead of Microsofts
CLR on top of WINE ?


Furthermore WINE does NOT work on ARM machines directly
and was never meant to - getting the App to work
directly on the Pi through Mono is the way forward.


ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

fsck
Posts: 26
Joined: Mon Feb 23, 2015 4:49 pm

Re: Wine and Mono

Tue Apr 19, 2016 6:08 am

So this thread is not about alcohol and STDs?

Return to “General discussion”