Page 1 of 1

Arduino IDE to desktop - Solved

Posted: Thu Feb 18, 2016 11:23 pm
by tech-mech
To work with wearable electronics that use Arduino code I did the apt-get update, upgrade and install. The directions I followed led me to believe that I would have a new selection with Arduino in the menu on the desk top, didn't happen. I can use run to start the IDE and program Arduino devices but would like a desktop icon.

Any step by step directions?

Re: Arduino IDE to desktop

Posted: Fri Feb 19, 2016 10:26 pm
by buteman
If you can run the application you know the name. In a terminal issue this command

Code: Select all

locate "whatever the name of the application is" 
Right click on the desktop, select 'create a new launcher here' and fill in the details
The locate command will show you the path to the command so you can navigate to it.
Put whatever name and comment you want in the boxes and click 'OK'
That should be it.

Re: Arduino IDE to desktop

Posted: Sat Feb 20, 2016 5:12 am
by HankB
If 'locate' does not work (not installed by default on my Raspbian install) you can try 'which' as in 'which arduino' and that should show the full path to the executable.

If the program shows up in the menu, you may be able to right click on the menu item and create a shortcut or link on the desktop. (My Pi is not up at the moment so I can't actually try this myself.)

HTH,
hank

Re: Arduino IDE to desktop

Posted: Sat Feb 20, 2016 6:57 am
by tech-mech
Thanks for the replies.

whereis got me the path info.

I used nano to look at other desktop files and sorta copied one. It is now on the desk top but not in the menu.

There was an icon file for Arduino so I used it.

Any ideas on how to get it in the menu?

Re: Arduino IDE to desktop

Posted: Sat Feb 20, 2016 7:16 pm
by tech-mech
I found the problem.

The .desktop file in /usr/share/applications listed Icon=arduino when it needed to be Icon=/usr/share/pixmaps/arduino.xpm

After making that change it showed up in the menu.

Re: Arduino IDE to desktop - Solved

Posted: Sun Feb 21, 2016 5:43 am
by liudr
IIRC, arduino IDE is stuck at 1.0.5 for raspberry pi so you are missing out a lot (current version 1.6.x).
What is the reason that makes you want to use Arduino IDE on raspberry pi?