semofa
Posts: 21
Joined: Mon Jun 01, 2015 8:18 pm

"Segmentation fault" error when using Gstreamer on Raspbiam

Mon Aug 10, 2015 5:51 pm

HI all
I installed Gsreamer on Raspbian with

Code: Select all

apt-get install gstreamer1.0
. when I want run my Gstreamer application(writen with pyqt4) On Raspbian, I get "Segmentation fault" error. I should to say when I run my Gstreamer application on Ubuntu It run without anny error.
I don't khow what am i suppose to do now. Please Help me.

User avatar
Defiant
Posts: 179
Joined: Tue Oct 30, 2012 6:17 pm
Location: Hamburg, Germany

Re: "Segmentation fault" error when using Gstreamer on Raspb

Thu Aug 13, 2015 5:43 am

Can you try your pipeline with gst-launch and if it does not work, paste it here?
Also, have you installed the -bad and eglgles packages?

semofa
Posts: 21
Joined: Mon Jun 01, 2015 8:18 pm

Re: "Segmentation fault" error when using Gstreamer on Raspb

Thu Aug 13, 2015 6:35 pm

It turned out that there is a bug in the gstreamer1.0-plugins-bad. this link :https://bugzilla.gnome.org/show_bug.cgi ... tus_bottom is the bug report and this link: http://cgit.freedesktop.org/gstreamer/g ... b60c213682 is the patch for it. I applied the patch to it and compile it by myself and there was no error anymore.

Return to “General discussion”