mcarlton00
Posts: 4
Joined: Thu May 28, 2015 1:43 pm

Virtual Keyboard on Login Screen

Thu Jun 18, 2015 5:35 pm

Has anybody managed to get an onscreen keyboard to appear on the login screen when using Raspbian Wheezy? I'm working to make a kiosk for several users and I'd like to limit use by user accounts and passwords, but I haven't been able to get it working yet.

I've installed both Florence and Matchbox-Keyboard and they both work fine once a user is logged in.

I've tried editing /etc/lightdm/lightdm-gtk-greeter.conf as suggested with most linux distros and added in the "keyboard=" option under greeter, but nothing appears to be changing on the login screen.

Any suggestions are appreciated

unauthorized_user
Posts: 1
Joined: Fri Jun 19, 2015 9:41 am

Re: Virtual Keyboard on Login Screen

Mon Jun 22, 2015 5:28 am

mcarlton00 wrote: I've tried editing /etc/lightdm/lightdm-gtk-greeter.conf as suggested with most linux distros and added in the "keyboard=" option under greeter, but nothing appears to be changing on the login screen.
So, you press F3 and nothing happens? Post this file here:

Code: Select all

/var/log/lightdm/x-*-greeter.log
Greeter has builtin support for "onboard" keyboard. What about it? Usually greeter works much better with it.

mcarlton00
Posts: 4
Joined: Thu May 28, 2015 1:43 pm

Re: Virtual Keyboard on Login Screen

Mon Jun 22, 2015 4:18 pm

Correct, F3 does nothing. In addition, there isn't a keyboard option in the accessibility menu.

/var/log/lightdm/x-0-greeter.log

Code: Select all

** (lightdm-gtk-greeter:2324): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
To my knowledge, Onboard isn't available on the Pi. It's not in the Raspbian repositories, at least.

For reference, here is /etc/lightdm/lightdm-gtk-greeter.conf

Code: Select all

#
# background = Background file to use, either an image path or a color (e.g. #772953)
# show-language-selector (true or false)
# theme-name = GTK+ theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
#
[greeter]
background=#ffffff
#show-language-selector=false
theme-name=Adwaita
#font-name=
xft-antialias=true
#xft-dpi=
xft-hintstyle=hintfull
xft-rgba=rgb
indicators=~language;~a11y;~session:~power
keyboard=florence

jpezz
Posts: 97
Joined: Fri Apr 26, 2013 6:14 pm
Location: North Carolina, U.S.

Re: Virtual Keyboard on Login Screen

Mon Jun 22, 2015 6:19 pm

Works like a charm. I use xdm so:

For Touchscreen keyboard (works with mouse). As root (sudo bash)

Code: Select all

apt-get install -y xvkbd
Edit /etc/X11/xdm/Xsetup to add the line to start virtual keyboard program before login

Code: Select all

export HOME=/root # If that's root's home directory
/usr/X11/bin/xvkbd -xdm -compact -geometry 800x400+20+600 &
Edit /etc/X11/xdm/Xstartup to add the line to stop virtual keyboard program after login

Code: Select all

/usr/bin/pkill xvkbd &

mcarlton00
Posts: 4
Joined: Thu May 28, 2015 1:43 pm

Re: Virtual Keyboard on Login Screen

Tue Jun 23, 2015 12:30 am

you are amazing, thank you so much. you just saved me so much time.

One small tweak, calling the full path

Code: Select all

/usr/X11/bin/xvkbd -xdm -compact -geometry 800x400+20+600 &
didn't work, but just doing
xvkbd -xdm -compact -geometry 800x400+20+600 &
did. Not sure why, but it's working so I'm not going to fight it.

Thanks again

dg_ashby
Posts: 3
Joined: Sat Mar 05, 2016 12:21 am

Re: Virtual Keyboard on Login Screen

Tue Apr 12, 2016 8:29 am

I've tried getting both Florence and matchbox-keyboard working with lightdm and the official 7" display. I've edited /etc/lightdm/lightdm-gtk-greeter.conf and modified and added the following:

Code: Select all

show-indicators=~language;~a11y;~session;~power                                                                                                                                             
keyboard=florence
This has the expected result, when lightdm starts up the Accessibility menu is present and the third option for the On Board Keyboard is present. When this option is selected the Florence keyboard appears.

Initially as soon as any key on the keyboard was pressed the keyboard would disappear. This issue was resolved via a different thread that suggested installing at-spi2-core using apt-get install.

After installing at-spi2-core the keyboard remains on screen and any key presses result in the key colour changing to blue while pressed however the character of the pressed key is not appearing in the username field even though it has focus.

Once logged in (using a wireless keyboard), Florence runs fine and key presses do generate characters, at least in a standard terminal window.

I've found a lot of posts from people having problems with virtual keyboards on Linux in general, it seems to be a particularly fragile area.

I'm running an up to date version of Raspbian with lightdm 1.10.3-3 and lightdm-gtk-greeter 1.8.5-2 on a Pi 3 but have seen the same problem on a Pi 2.

Has anyone had similar experiences and managed to find a solution?

khooke
Posts: 25
Joined: Sun Oct 07, 2012 6:38 am
Location: CA, USA
Contact: Website

Re: Virtual Keyboard on Login Screen

Sat May 14, 2016 4:25 am

I found this thread as I'm looking to set up an onscreen keyboard with the 7" screen and a Pi3. I followed the same steps as the last post in this thread but have exactly the same issue. Keyboard shows onscreen, but on first key press it disappears and nothing appears in the username or password fields.

Has anyone worked out a foolproof approach to getting an onscreen keyboard working yet? Do some work better than others?

khooke
Posts: 25
Joined: Sun Oct 07, 2012 6:38 am
Location: CA, USA
Contact: Website

Re: Virtual Keyboard on Login Screen

Sat May 14, 2016 4:11 pm

I think this is the other thread db_ashby was referring to, I'll try this out later today:
viewtopic.php?f=108&t=123189

Anton Meier
Posts: 1
Joined: Thu Jun 02, 2016 6:58 am

Re: Virtual Keyboard on Login Screen

Thu Jun 02, 2016 7:03 am

Try this in /etc/lightdm/lightdm-gtk-greeter.conf:

Code: Select all

show-indicators=~language;~a11y;~session;~power
keyboard=florence --focus
With the parameter --focus it should react as expected.

As mentioned before the package 'at-spi2-core' is necessary, too.

Greetings

Return to “General discussion”