rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Pi2 Red power LED still blinks

Thu Mar 05, 2015 5:20 am

So just to make sure before I go to obscene lengths to troubleshoot this;

The red LED should never turn out when power is applied and the Pi2 is running unless a brownout is happening, correct?

User avatar
rpdom
Posts: 14483
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 7:06 am

Pretty much, yes. The red LED going out is an indicator that the supply voltage is too low. You should also see a small coloured square in the top corner of the screen.

There are ways to turn off the red LED in software, but unless you did that yourself, it is very unlikely.

rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 11:53 am

Thank you rpdom. I guess I need to find out whats going on. I am feeding it from a 12v 2a wall wart dropped down through http://www.ebay.com/itm/310813369212?_t ... EBIDX%3AIT fed through a cable I can confirm as passing up to 1800ma when connected to a good supply. Sitting here tonight if i leave the camera enabled the led is blinking on and off at fairly regular intervals. If I disable the camera it slows the blink rate but does not stop it. The only other thing hooked up is the wifi adapter. I am running headless. So I dont see the brownout indicator. Would that be visible over xrdp?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5268
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 12:47 pm

rahlquist wrote:So I dont see the brownout indicator. Would that be visible over xrdp?
No. It's a different overlay to the framebuffer. I'm sure it is present.
A voltmeter seems the obvious way to confirm this (but it will be showing a low voltage).

rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 1:47 pm

dom wrote:No. It's a different overlay to the framebuffer. I'm sure it is present.
A voltmeter seems the obvious way to confirm this (but it will be showing a low voltage).
I had a feeling that it was an overlay.

I put my inline usb meter in place with no load the power supply sits at 5.01v. Once I start the Pi, it drops to 4.97v @670ma output. So under a load it seems to sit at 4.97v. Is there any information you can share about the brownout detection, what it considers low +/- any tolerances etc?

I guess I need to get an adjustable regulator, if I am going to that length I may as well stop powering over usb.

User avatar
RaTTuS
Posts: 10325
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 1:57 pm

sounds like a bad PSU
measer the voltage on the test pads on the RPI
you need to be more that 4.75V there [YMMV with less]
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 2:37 pm

RaTTuS wrote:sounds like a bad PSU
measer the voltage on the test pads on the RPI
you need to be more that 4.75V there [YMMV with less]
Do we have a list of the test pads on the Pi2 yet?

I went with PP7 which is +5v after poly fuse on B+. At that point I have 4.70V

I also have 4.69v-4.70v on the GPIO header.

So if thats the right test point something is fubar. Any further test suggestions?
Last edited by rahlquist on Thu Mar 05, 2015 3:10 pm, edited 1 time in total.

rahlquist
Posts: 149
Joined: Tue Jan 21, 2014 1:02 pm

Re: Pi2 Red power LED still blinks

Thu Mar 05, 2015 3:02 pm

Ok, feeling a bit stupid now. Just goes to show the smallest piece can be the issue.

12v 2A PS
5v 3A Buck Converter
20AWG 8ft charge only cable
And the culprit
http://www.ebay.com/itm/2pcs-90-degree- ... 1307017664?

It introduces a 0.25v drop.

Grrrr.

Richard_H
Posts: 12
Joined: Mon Apr 04, 2016 1:48 am

Re: Pi2 Red power LED still blinks

Mon Apr 04, 2016 2:06 am

rahlquist,

Just a note of thanks for following up with your root cause here. While you might have felt silly overlooking the cable, your post shortcut my troubleshooting - so, thanks! It's the details that'll kill ya.

I just ran into exactly the same thing, but with a 6" cable I'd bought for a compact setup. One works, the other doesn't.

Cheers,
Richard

Return to “General discussion”