jchoong
Posts: 3
Joined: Sun Feb 15, 2015 1:57 am

Pi 2 with 32GB micro-SD issue?

Fri Feb 20, 2015 3:09 am

I am new to Raspberry and just got my Pi 2. I got 2 pcs of 32GB Class 10 Sandisk micro-SDs and when I started to use these for NOOBS and OPENELEC, I had problems - both won't boot up; nothing on the screen. I formatted the SDs with SDFormatter and wrote the .img files with the Win32Diskimager - tried a few times. Subsequently I shifted to 3 pcs of 16GB Class 10 Samsung cards, and these work without problems.

After a day of playing around with the 16GB micro-SDs, I was curious and went back to the 32GB cards. I found that some times they work; but most of the time they don't. I searched the net and what I read was that 32GB cards should be OK for the Pi B+. So, my experience with the 32GB is confusing. Anyone having the same issue with the Pi 2?

grousebeater
Posts: 3
Joined: Thu Jan 15, 2015 3:39 pm

Re: Pi 2 with 32GB micro-SD issue?

Fri Feb 20, 2015 12:06 pm

Hi
I to are new to Pi I bought a Pi B+ and and used the noobs card from Pi hut but thought that like a laptop it might run better with more storage so bought a 64gig micro sd card and loaded it with latest openelec image using the same method as you it would boot and load great but after a restart all went pear shaped message about unable to mount system.
I now have the Pi2 and tried the same using the latest openelec image 5.0.3 for Pi2 same result so obtained a class 10 8 gig using same image loads and boots great and runs fast even using 1020p on all kodi addons.
Regards Ken

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: Pi 2 with 32GB micro-SD issue?

Fri Feb 20, 2015 12:22 pm

You probably need to format it to make it one FAT partition instead of exFAT which SDXC uses by default.
There are 10 types of people: those who understand binary and those who don't.

Return to “General discussion”