Usil
Posts: 6
Joined: Mon May 03, 2021 6:12 am

Snap-store not accessible

Fri Jun 11, 2021 3:24 am

I have a Raspberry Pi 400. I had installed the Snap-Store successfully from PiApps and used it to install Telegram which works perfectly. Tonight i just tried starting up the Snap-Store and got the hourglass symbal and then nothing. Thr hourglass symbol went away and the Snap-Store did not load. Worse still, when I tried rebooting it failed. Tried several times and it failed each time. I put a USB good boot drive in and restored Raspberry Pi on the bad drive using SD Copy and tried everything again and got the same results. Not sure what is going on. Anyone experienced this recently with Snap-Store?

User avatar
craigevil
Posts: 209
Joined: Wed Jan 27, 2021 5:22 am
Location: OZ

Re: Snap-store not accessible

Fri Jun 11, 2021 3:50 am

1) Do NOT use PPAs with RPIOS/Debian

2) Do this:

Code: Select all

sudo apt install gnome-software gnome-software-plugin-snap gnome-software-plugin-flatpak
2021-06-10_14-39.png
2021-06-10_14-39.png (128.03 KiB) Viewed 192 times
Raspberry PI 400 Raspberry Pi OS (Unstable) Kernel: 5.10.17-v8+ aarch64 DE: MATE Ram 4GB
Debian - "If you can't apt install something, it isn't useful or doesn't exist"

Moonmarch
Posts: 679
Joined: Thu Mar 07, 2019 1:34 am

Re: Snap-store not accessible

Thu Jun 17, 2021 10:02 pm

I usually compile software that I am not able to install using the apt install command in the terminal. I used the Snap Store when I was starting to use Linux, and at the time I didn't know anything about Linux. The Snap Store created several directories in my file system, and the files were difficult to remove. I needed more space on my storage drive. Back then I didn't know how to install software on a Linux PC or even knew how to use a software repository. I eventually realized Linux operating systems uses software that was designed for Linux operating systems. You have to search for software on the internet to know which programs you should install on your computer.

Return to “General discussion”