Page 1 of 1

Forum editor centers text

Posted: Mon Jul 15, 2019 4:21 pm
by fd_
I hope this is the right sub-forum to post about the forum itself:
For a few months now, the forum's post editor is center-aligning text for me. This makes writing a post a bit inconvenient. I'm using Safari Version 12.1.1 (14607.2.6.1.1) on macOS 10.14.5.

Screenshot:
Image

Is this intended behaviour?

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 4:36 pm
by W. H. Heydt
It's not what happens for me. You probably have set something somewhere. Check your profile settings.

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 4:41 pm
by fd_
W. H. Heydt wrote:
Mon Jul 15, 2019 4:36 pm
It's not what happens for me. You probably have set something somewhere. Check your profile settings.
I just had a look through my profile settings - couldn't find something relevant there. Are you using Safari as well?

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 4:43 pm
by Heater
Never seen that happen. Not on Windows or Linux with Chrome or Firefox.

Could even be a useful feature some times!

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 6:17 pm
by Andyroo
This is from Safari 12.1.1 on 10.12.6 (a bit behind :roll: ) using the RPi style and its fine.
Screenshot 2019-07-15 19.16.29.png
Screenshot 2019-07-15 19.16.29.png (33.46 KiB) Viewed 3258 times
I'll post this and swap to raspberry_pi

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 6:21 pm
by Andyroo
I hate this layout !

But its working so I'm going back to pro-silver :lol:

No its not - well the text is correct but I cannot add attachments - very odd...

High ho pro-silver away (with these odd colours)

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 6:23 pm
by Andyroo
Typical - just 'cause it did not work first time I try twice and it takes both BUT DOES NOT SHOW IT ON MY SCREEN!

Anyway, back to the OP post - the issue does not seem to be in Safari unless the OS has an impact (possible as webkit is OS rather than Safari).

Maybe a log out, clear cookies for the site and log back in? (Sorry sounds like a turn off / back on again fix :oops: ).

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 7:03 pm
by fd_
Andyroo wrote:
Mon Jul 15, 2019 6:23 pm
Typical - just 'cause it did not work first time I try twice and it takes both BUT DOES NOT SHOW IT ON MY SCREEN!

Anyway, back to the OP post - the issue does not seem to be in Safari unless the OS has an impact (possible as webkit is OS rather than Safari).

Maybe a log out, clear cookies for the site and log back in? (Sorry sounds like a turn off / back on again fix :oops: ).
I just logged in in a new private window, which should remove cookies from the equation. Still center-aligned though. Also, just tried Chrome and it's properly left-aligned there, so it's not linked to my profile.

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 7:09 pm
by DougieLawson
If you need a non-proportional font and tabs that don't get mushed to the left use [code] stuff goes here[/code] tags.

Like

Code: Select all

If you need a non-proportional
     font and tabs that don't get 
     mushed to the
left use [ code]stuff goes here[ /code] tags.

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 7:13 pm
by fd_
DougieLawson wrote:
Mon Jul 15, 2019 7:09 pm
If you need a non-proportional font and tabs that don't get mushed to the left use [code][/code] tags.

Like

Code: Select all

If you need a non-proportional
     font and tabs that don't get 
     mushed to the
left use [b][[/b][b]code]
[/b] tags.[/code]
Unless I misunderstood your post, you're suggesting ways to format forum posts. However, the problem I'm seeing is that text in the editor itself (the 'source code' of the post) is always center-aligned, as displayed in my screenshot above :? :D

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 7:15 pm
by DougieLawson
That's got to be a feechur of your web browser.
I don't get that on Win10 with Google Chrome or Firefox.

Re: Forum editor centers text

Posted: Mon Jul 15, 2019 8:40 pm
by Andyroo
DougieLawson wrote:
Mon Jul 15, 2019 7:15 pm
That's got to be a feechur of your web browser.
I don't get that on Win10 with Google Chrome or Firefox.
This is where its odd - I'm running the same version of browser but an older operating system and I do not see it :?: :!:

Using the 'webkit normal' download from here gives me:
Your browser uses WebKit.
Your WebKit version is at least 418.1.
Your WebKit version number is 605.1.15.
Your WebKit version is not a nightly build.
Version information:
0: 605
1: 1
2: 15
isNightlyBuild: false
You are not surfing Mobile.
I would have thought the private may have solved it - if the webkit is the same them maybe AV / Ad blocker impacting...

Re: Forum editor centers text

Posted: Thu Jul 18, 2019 10:00 am
by fd_
Andyroo wrote:
Mon Jul 15, 2019 8:40 pm
Your browser uses WebKit.
Your WebKit version is at least 418.1.
Your WebKit version number is 605.1.15.
Your WebKit version is not a nightly build.
Version information:
0: 605
1: 1
2: 15
isNightlyBuild: false
You are not surfing Mobile.
I'm seeing the exact same version information there - very strange :? :?:

Re: Forum editor centers text

Posted: Wed Oct 02, 2019 12:32 pm
by fd_
The recent Safari 13.0.1 (14608.2.11.1.11) update fixed it now, so it must have somehow been related to the browser :D

Re: Forum editor centers text

Posted: Wed Oct 02, 2019 12:55 pm
by Andyroo
Still not seen this though I have jumped to Mojave on one but of Apple kit.

Wonder if it’s an extension clashing?

Re: Forum editor centers text

Posted: Wed Oct 02, 2019 12:58 pm
by fd_
Andyroo wrote:
Wed Oct 02, 2019 12:55 pm
Still not seen this though I have jumped to Mojave on one but of Apple kit.

Wonder if it’s an extension clashing?
Only extension I have installed is https://apps.apple.com/app/pipifier-pip ... 4471?mt=12

Re: Forum editor centers text

Posted: Wed Oct 02, 2019 1:02 pm
by Andyroo
:?:

Not on the Mojave box today so cannot check the version but at least you are going :D