Phildefer
Posts: 2
Joined: Fri Mar 02, 2018 10:25 pm

Windows 10 Doesn't detect CanaKit MicroSD USB card/reader

Mon Mar 05, 2018 12:42 am

Hi,

I have a CanaKit complete Starter Kit (including RasPi 3, SanDisk 32GB Micro SD HC card, and CanaKit MicroSD USD Reader) which was running Raspbian. I wanted to use the Pi as a Z-Wave bridge instead, hence I searched the web and found out about Hassbian and built-in HomeAssistant. Being a total beginner with the RasPi I found instructions to wipe (format) my MicroSD card using SD Card Formatter utility. However I was only able performing a quick format (overwrite format process would abort everytime). I then used Etcher to load Hassbian on my Micro SD card, but the process would also abort shortly after it started. I thought that perhaps the card was not formatted properly, so I tried formatting again using Windows Explorer right-click option, as well as disk management, but every single time I would get the message "Windows was Unable to Complete the Format" immediately after it started. I would also hear the USB sound indicating the card had been unmounted (removed), but I never touched the card reader throughout the procedure.

I then tried using the diskpart utility but the process would always fail after the format command. After countless tries, my card/reader is no longer detected by my PC (Win 10). When I insert the card reader, no sound, and I do not see the removable drive in Explorer, or in Disk Management, or Device Management. I tried on a different PC, but with the same result. I then took the Micro SD card out and used it in my Samsung tablet, which is able recognizing the Micro SD card. I was also able adding a PDF file onto the card.

I am wondering whether my CanaKit MicroSD USB reader is dead, or if my Micro SD card might also be at cause. Has anyone else ever experienced this?

pcmanbob
Posts: 4094
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Windows 10 Doesn't detect CanaKit MicroSD USB card/reader

Mon Mar 05, 2018 3:25 pm

The card does not appear faulty if you can use it in a tablet, if the card reader is no longer recognised by windows then that must be the suspect item.

Its not unknown for new items to fail the first time you use them or soon after, this does not just apply to SD card reads but any electronic item.

As this is part of a Kit you have purchased your best option would be to contact the the place you purchased the kit from and ask them for a replacement, if its still with in the warranty period.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Return to “Off topic discussion”

Who is online

Users browsing this forum: No registered users and 2 guests