Skype working on Raspbian + RPI 2


15 posts
by adrianrolla » Wed Mar 30, 2016 8:45 pm
Hi,

This post describes how to have Skype working on Raspberry PI 2 + Raspbian.

Skype is not ported to armv7 architecture yet, but there are working versions for linux i386 architecture, and for Debian in particular.

To run i386 linux apps on RPI there is a software that emulates i686 environment on raspberry pi and works fine:
https://eltechs.com/product/exagear-desktop
(I am not part of this company nor have any interest, just wanted to have my RPI doing Skype video calls...)

So using Raspbian + Exagear desktop + Skype + a little hack does the magic to have video+audio calls with good quality.

Installation steps:

0.- Get a license of Exagear desktop, you will need it on step 3.

1.- Install Raspbian on SD card (I used 2016-03-25 release). There are plenty of posts on how to do this on Linux/Windows environments.

2.- Use it to boot your RPI.

3.- Follow all but first step of Eltechs instructions about how to
Run Skype on Raspberry Pi - Eltechs ExaGear
https://eltechs.com/run-skype-on-raspberry-pi/
Dont execute frist step: (1. Install and configure PulseAudio.), just start from step 2.

4 .- When done, you'll have Exagear Desktop + Skype 4.3 on your RPI (you can stop here and try to make Skype 4.3 audio and video work, if you make it, just let me know).
Make a copy of Skype 4.3 executable
Code: Select all
sudo cp /usr/bin/skype  /usr/bin/skype43

5.- Install Skype 4.2
Code: Select all
wget http://download.skype.com/linux/skype-debian_4.2.0.11-1_i386.deb
sudo dpkg -i skype-debian_4.2.0.11-1_i386.deb
sudo cp /usr/bin/skype  /usr/bin/skype42

6.- In order to make it work, flollow "How to use it " instructions.

How to use it

1.- Make first login using Skype 4.3, click on "automatic session start" before click on "start session" button. Run skype 4.3 under exagear using:
Code: Select all
exagear debian-8-wine2g -- /bin/bash -c 'skype43'

2.- From Skype menu "Close Skype" (don't close session, just close skype).

3.- Make further Skype usage with Skype 4.2. Do calls, add contacts, and whatever you want except: "close session". Start Skype 4.2 using:
Code: Select all
exagear debian-8-wine2g -- /bin/bash -c 'skype42'

4.- You can "Close Skype" and start it again on Skype 4.2 version as many times as you want. "close Skype" don´t close session.

5.- If it's the case that you want to close session in order to change Skype user, then do that on Skype 4.3 starting with Step 1 all over again.


I have this running on an RPI 2 + Exagear + Skype 4.3 + Skype 4.2 + Logitech HD C920 webcam. 8-)

Video+audio calls works great!

Enjoy!!!
Posts: 4
Joined: Thu Jan 21, 2016 12:24 am
by pUnK » Wed Mar 30, 2016 9:22 pm
Brilliant livehack!!!
ExaGear Desktop - run x86 apps on Raspberry Pi
pUnK from Eltechs
Posts: 92
Joined: Mon Aug 25, 2014 3:40 pm
by Malman35 » Thu Mar 31, 2016 2:30 am
would the web version (beta) work?
https://web.skype.com
For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return - Leonardo da Vinci

Check out my cool website for my stop motion animations.
www.mem3500films.ml
User avatar
Posts: 425
Joined: Sun Nov 30, 2014 4:51 am
Location: Hokkiado, Japan
by adrianrolla » Thu Mar 31, 2016 4:53 pm
UPDATE:
If you have this error when opening Skype 4.3 or Skype 4.2:
/usr/bin/skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory
or Skype does not open from Main menu, you must complete your i386 Debian setup by executing:
Code: Select all
exagear
sudo apt-get -f install

That will fix the issue.
Posts: 4
Joined: Thu Jan 21, 2016 12:24 am
by MarcFinns » Mon Apr 04, 2016 9:39 pm
Hi there, I have been trying this (an other) hacks on my RPI3, with mixed results.
I agree 4.2 without pulseaudio seems more stable, albeit with seemingly lower resolution.
However, I have the same issue on both: I am not able to make the webcam mic work. Video works both ways, while i can only receive audio on the RPI side. I tried with an old Logitech and a newer Trust, same results.
any hints? thanks!
Posts: 5
Joined: Sat Mar 05, 2016 12:57 am
by MarcFinns » Thu Apr 07, 2016 12:05 am
Some update. As said, the Webcam microphone does not work on Skype 4.2.
When skype is launched from command line, upon establishing a call I see thousands of error lines like the one below, for the duration of the call:
Code: Select all
snd_pcm_avail_update() returned a value that is exceptionally large: 48384 bytes (504 ms).
Most likely this is a bug in the ALSA driver. Please report this issue to the ALSA developers.

I tried to play with .asoundrc to no avail. My configuration is HDMI audio playback / WebCam microphone which I described as follows:
Code: Select all
 pcm.!default {
         type asym
         playback.pcm {
                 type plug
                 slave.pcm "hw:0,0"
         }
         capture.pcm {
                 type plug
                 slave.pcm "hw:1,0"
         }
 }

Any suggestions? (other than buying a tablet - if you are in that mindset perhaps you are browsing the wrong site..?)
To the author of the hack: perhaps you could describe your hardware configuration?
Thank you!
Posts: 5
Joined: Sat Mar 05, 2016 12:57 am
by adrianrolla » Fri May 06, 2016 11:33 pm
Hi MarcFinn.
Before trying pulseaudio , did you try to try selecting different input source from Skype 4.2 / options / sound devices?
From all micropone options that Skype 4.2 / Options / Sound Devices / Microphone offered to me, this was the only one that worked:
HD Pro Webcam C920, USB Audio Hardware device with all software conversions (plughw:CARD=C920,DEV=0)

Another thing to take care is that If your rpi + your webcam consume more power than your power source, audio breaks on the other side of the call (your mic does not provides good audio).
Sometimes this did happen to me randomly, I fixed that it using a powered usb to connect the camera instead of attaching it directly to RPI usb.
If power is your issue, you should see a multicolor small square at the top right of your screen going on and off, that's the "no enough power" warning.
After adding the powered usb hub, that multicolor square never showed again and audio was perfect.

Hope it helps.
Posts: 4
Joined: Thu Jan 21, 2016 12:24 am
by sumika » Thu May 12, 2016 12:55 pm
Hi!

I am facing the (probably) exact same problem as MarcFinns, though I'd like to make audio calls only using Pi3.
My setup is:
Pi3 (Linux raspberrypi 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux)

The exagear version (from the download path):
exagear-desktop-v-1-4-1/exagear-desktop-rpi3.tar.gz, using debian 8, wine 2g.

The headsets I have tried:
Logitech 960 (wired), Logitech H800 (wireless).

When trying to make a test call, I get the same ALSA error messages (a lot of them) as MarcFinns and the other party can't hear me, while audio on my side is working perfectly (thanks to adrianrolla's live hack, as no audio at all was working for me on Skype 4.3).
I've managed to record sound using both headsets on both systems (armv7l and i686). Seems like Skype is unable to find/handle the mic. No power issues here.

Finally a question: has anyone actually succeeded to make Skype work on the Pi3? All tips and tricks are for Pi2.

Any help would be much appreciated!
Posts: 2
Joined: Thu May 12, 2016 9:55 am
by the_brave_rabbit » Fri May 13, 2016 5:24 pm
Hi!
I have been trying this hack on RPI 2.
On 4.2 (without pulseaudio) I am not able to make the webcam work.
On 4.3 (with pulseaudio) video works both ways, while i can't only receive audio on the RPI side.
I am using Logitech C270 Webcam.
Any hints? Thanks.
Posts: 2
Joined: Fri May 13, 2016 4:11 pm
by sumika » Sat May 28, 2016 10:08 am
Finally I've managed to make my mic work with Skype.
It seems I have over complicated things. Skype 4.3 with pulseaudio works like a charm (see instructions here: https://eltechs.com/run-skype-on-raspberry-pi/). It seems that alsa driver is bogus on the Pi3.
My working setup is:
- Raspberry Pi 3 Model B
- Logitech 960 headset
- Raspbian Jessie (Linux raspberrypi 4.1.19-v7)
- Exagear 1.5
- Skype 4.3
- pulseaudio

I was only interested to get a mic working with Skype, don't know about video.
Hope this helps someone...
Posts: 2
Joined: Thu May 12, 2016 9:55 am
by jb63 » Sun Jul 10, 2016 7:23 am
Very interesting topic/project. Sadly, I have a logitech skype camera ($200) and Microsoft no longer supports such product ... Now I need an alternative and thought of going the RPI route. Two questions come to mind:

1. Is this working for both audio/video reliably?
2. Can I use any webcam or it needs to be the Logitech 960 ?

Cheers
JB
Posts: 113
Joined: Mon May 11, 2015 6:41 pm
by daveyman123 » Sat Jul 16, 2016 2:33 am
I too am having problems getting c525 logitech mic to work.

I am also not getting audio from phone mic to raspberry pi
Posts: 100
Joined: Fri Dec 12, 2014 2:21 am
by daveyman123 » Sun Jul 17, 2016 10:24 pm
I eventually got it to work. I can post what i did if someone wants

unfortunately its so laggy that its unusable realistically.
Posts: 100
Joined: Fri Dec 12, 2014 2:21 am
by the_brave_rabbit » Mon Jul 18, 2016 1:57 pm
daveyman123 wrote:I eventually got it to work.

How do you did it?
Posts: 2
Joined: Fri May 13, 2016 4:11 pm
by jb63 » Mon Jul 18, 2016 8:10 pm
daveyman123 wrote:I eventually got it to work. I can post what i did if someone wants

unfortunately its so laggy that its unusable realistically.


Thank you for the feedback. So, it is fair to say they that this is NOT a viable replacement of the Logitech Skype HDMI camera, correct?

https://www.amazon.com/Logitech-960-000 ... B009Z7KMUM
Posts: 113
Joined: Mon May 11, 2015 6:41 pm